The officially official Devuan Forum!

You are not logged in.

#1 2024-01-07 08:44:43

webman
Member
Registered: 2022-08-27
Posts: 44  

Systemtap packaging error - cannot be used

Hello!

Just installed Devuan (daedalus, 6.1.0-16-amd64) in a KVM vm.
Installation of Systemtap (4.8-2) went ok, but the importent step,
executing 'stap-prep' failed:

$ stap-prep
Configuring for kernel release 6.1.0-16-amd64
Debuginfo automatic downloading is not configured via $DEBUGINFOD_URLS
/usr/bin/stap-prep: line 80: rpm: command not found

Quite easy to see, there is usually no rpm, has to be apt ....
How can this be fixed?

Thanks,
Manfred

Offline

#2 2024-01-09 03:44:32

webman
Member
Registered: 2022-08-27
Posts: 44  

Re: Systemtap packaging error - cannot be used

Hello!

According to the given error message:

$ stap-prep
Configuring for kernel release 6.1.0-16-amd64
Debuginfo automatic downloading is not configured via $DEBUGINFOD_URLS
/usr/bin/stap-prep: line 80: rpm: command not found

Now, I found time to look into the script.
The error is obviously easy to see, the root cause is in line 182:

(180) DISTRO="$(lsb_release --id --short 2> /dev/null)"
(181) case "$DISTRO" in
(182) Debian|Ubuntu) <===
(183)        prep_deb_based "$@"
(184)        ;;
(185) *)
(186)        prep_rpm_based "$@"
(187)        ;;
(188) esac

Just insert "|Devuan" after "Ubuntu" in the case expression and it works.
Sad, but usual for the SystemTap installations all the time, the script
contains - ALWAYS(??) - such errors.
Additionally, at the end of the result (of running 'stap-prep'), you get this:

......
Processing triggers for runit (2.1.2-54) ...
Processing triggers for libc-bin (2.36-9+deb12u3) ...
You need package linux-image-6.1.0-16-amd64-dbgsym but it does not seem to be available

No such package exist, but systemtap is running now (say, at least my old script).
Another pointless waste of time.

Regards,
Manfred

Offline

#3 2024-01-09 03:46:07

webman
Member
Registered: 2022-08-27
Posts: 44  

Re: Systemtap packaging error - cannot be used

Someone should contact packagemanagement or whoever is responsible for this.
I dont know!

Regards,
Manfred

Offline

#4 2024-01-09 12:14:51

boughtonp
Member
From: UK
Registered: 2023-01-19
Posts: 212  
Website

Re: Systemtap packaging error - cannot be used

Seems to be a poor way to differentiate between deb-based and rpm-based systems. Devuan wont be the only Debian derivative to fail this test.

I would recommend reporting this as an issue in to upstream SystemTap, maybe with the suggestion to change the logic to whether the relevant binaries exist - i.e. along the lines of if [ -x /usr/bin/dpkg ] elif [ -x /usr/bin/rpm ] else "error unknown system"


3.1415P265E589T932E846R64338

Offline

#5 2024-07-08 14:11:28

webman
Member
Registered: 2022-08-27
Posts: 44  

Re: Systemtap packaging error - cannot be used

Hi!

Just stumpled over this ...
Yes, I told them!

Regards,
Manfred

Offline

Board footer