The officially official Devuan Forum!

You are not logged in.

#26 2023-09-14 22:12:35

From: Battery Point, Tasmania, AUS
Registered: 2016-11-30
Posts: 1,194  

Re: Input/output error with EasyCap capture card on VLC and OBS

Yes;  expanding on @alexkemp's note, the file mode string starts which a marker character to tell whether it's a block device (b), a character device (c, as here), a directory (d), a symbolic link (l) or a normal file (-). Next it shows three triplets to indicate the access mode setting for user, group and other (plus some special meanings depending in type).

In this case root is the user and root is the group, with read and write access, while all other users or groups only have read acccess. In other words, you only have read access (unless you are running this as root or your user is in root group)

Quite possibly the lack of write access to the USB device has been the cause here.

You change that, but only as root, and in this case you could use the command

# chmod o+w /dev/bus/usb/001/015

to add write access to other.


#27 2023-09-16 10:10:22

Registered: 2018-05-14
Posts: 314  

Re: Input/output error with EasyCap capture card on VLC and OBS


Have you tried Ralph's advice?

(in a terminal):

  • Switch to the root user (which means su -; enter the root password, not sudo)

  • lsusb will show all connected usb devices

  • enable write access for the other user on the EasyCap device: chmod o+w /dev/bus/usb/001/015

  • Without rebooting, try qv4l2 & see if now it will allow you to see your vhs screen in the window.

I very much want to work with you to get my script to work with other devices (such as yours) & get a good result to allow folks to stream it to disc.

Last edited by alexkemp (2023-09-16 10:11:39)


#28 2024-02-13 16:01:52

Registered: 2021-12-31
Posts: 68  

Re: Input/output error with EasyCap capture card on VLC and OBS

Sorry for the long wait, but I tried all of your suggestions as well as ones from other forums and unfortunately I've concluded that this EasyCap was a dud. I had already spend so much time on this one I'm embarrassed to admit that I bought a "UCEC" capture card that looks nearly identical (with a number of Linux users who gave good reviews) and it works like a charm. It even uses the same module (uvcvideo) too.


Board footer