The officially official Devuan Forum!

You are not logged in.

#1 2023-03-09 06:40:44

jcamp
Member
Registered: 2019-12-30
Posts: 5  

Calibre qt issue

Have Calibre 5.12 running fine on a desktop with a complete load of Chimera mid 22.

Complete reload on a laptop and loaded latest Calibre. Attempting to run I get
"
jc@devuandell:~$ calibre
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though
it was found.
This application failed to start because no Qt platform plugin could be
initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl,
offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl,
wayland-xcomposite-glx, xcb
"

Reinstalled xcb, rest don't appear to be available ; tried various 5.x versions of Calibre again the same message

Any ideas?"

Offline

#2 2023-03-09 19:32:35

manyroads
Member
From: 20 Jan 2021 ~ "Free at last"
Registered: 2020-08-18
Posts: 73  
Website

Re: Calibre qt issue

Go to the link below and install a current version of calibre. It may work better.  https://calibre-ebook.com/download_linux


Pax vobiscum,
Mark Rabideau - ManyRoads
i3wm, bspwm, dkwm, dwm, hlwm, sway, openbox on Sid/ ceres ~ Linux #449130
"For every complex problem there is an answer that is clear, simple, and wrong." -- H. L. Mencken

Offline

#3 2023-03-10 13:38:54

jcamp
Member
Registered: 2019-12-30
Posts: 5  

Re: Calibre qt issue

That's what I started with:
# calibre-uninstall
Has been used many times

Offline

#4 2023-03-10 13:52:27

fsmithred
Administrator
Registered: 2016-11-25
Posts: 2,446  

Re: Calibre qt issue

What do "complete load" and "complete reload" mean?

Did you run 'apt update' and 'apt upgrade' before installing calibre?

What is different between the two installations? Calibre runs fine on my chimaera laptop.

Offline

#5 2023-03-12 02:51:04

jcamp
Member
Registered: 2019-12-30
Posts: 5  

Re: Calibre qt issue

fsmithred wrote:

What do "complete load" and "complete reload" mean?

Did you run 'apt update' and 'apt upgrade' before installing calibre?

By complete load and complete reload I mean installation from iso including reformat of drives with ' apt update' and 'apt upgrade'

What did work was loading Beowulf on a VM and installing Calibre on that. While not fully satisfactory I am off for some serious dental stuff in Bangkok and will be hanging around in hotel not really up for anything. Sorting out tags etc on Calibre will be a useful way to spent the time.

Offline

#6 2023-03-12 14:50:43

fsmithred
Administrator
Registered: 2016-11-25
Posts: 2,446  

Re: Calibre qt issue

Maybe some qt package is missing. Here's what I have installed that has qt in the name (or description)
Compare what's in your laptop to this list or one like this from your desktop.

$ dpkg -l |grep qt
ii  libaudqt2:amd64                      4.0.5-1                                amd64        audacious media player (libaudqt shared library)
ii  libqt5core5a:amd64                   5.15.2+dfsg-9                          amd64        Qt 5 core module
ii  libqt5dbus5:amd64                    5.15.2+dfsg-9                          amd64        Qt 5 D-Bus module
ii  libqt5designer5:amd64                5.15.2-5                               amd64        Qt 5 designer module
ii  libqt5gui5:amd64                     5.15.2+dfsg-9                          amd64        Qt 5 GUI module
ii  libqt5help5:amd64                    5.15.2-5                               amd64        Qt 5 help module
ii  libqt5multimedia5:amd64              5.15.2-3                               amd64        Qt 5 Multimedia module
ii  libqt5network5:amd64                 5.15.2+dfsg-9                          amd64        Qt 5 network module
ii  libqt5opengl5:amd64                  5.15.2+dfsg-9                          amd64        Qt 5 OpenGL module
ii  libqt5positioning5:amd64             5.15.2+dfsg-2                          amd64        Qt Positioning module
ii  libqt5printsupport5:amd64            5.15.2+dfsg-9                          amd64        Qt 5 print support module
ii  libqt5qml5:amd64                     5.15.2+dfsg-6                          amd64        Qt 5 QML module
ii  libqt5qmlmodels5:amd64               5.15.2+dfsg-6                          amd64        Qt 5 QML Models library
ii  libqt5quick5:amd64                   5.15.2+dfsg-6                          amd64        Qt 5 Quick library
ii  libqt5quickwidgets5:amd64            5.15.2+dfsg-6                          amd64        Qt 5 Quick Widgets library
ii  libqt5sql5:amd64                     5.15.2+dfsg-9                          amd64        Qt 5 SQL module
ii  libqt5svg5:amd64                     5.15.2-3                               amd64        Qt 5 SVG module
ii  libqt5test5:amd64                    5.15.2+dfsg-9                          amd64        Qt 5 test module
ii  libqt5webchannel5:amd64              5.15.2-2                               amd64        Web communication library for Qt
ii  libqt5webengine-data                 5.15.2+dfsg-3                          all          Web content engine library for Qt - Data
ii  libqt5webengine5:amd64               5.15.2+dfsg-3                          amd64        Web content engine library for Qt
ii  libqt5webenginecore5:amd64           5.15.2+dfsg-3                          amd64        Web content engine library for Qt - Core
ii  libqt5webenginewidgets5:amd64        5.15.2+dfsg-3                          amd64        Web content engine library for Qt - Widget
ii  libqt5widgets5:amd64                 5.15.2+dfsg-9                          amd64        Qt 5 widgets module
ii  libqt5x11extras5:amd64               5.15.2-2                               amd64        Qt 5 X11 extras
ii  libqt5xml5:amd64                     5.15.2+dfsg-9                          amd64        Qt 5 XML module
ii  python3-pyqt5                        5.15.2+dfsg-3                          amd64        Python 3 bindings for Qt5
ii  python3-pyqt5.qtsvg                  5.15.2+dfsg-3                          amd64        Python 3 bindings for Qt5's SVG module
ii  python3-pyqt5.qtwebchannel           5.15.2+dfsg-3                          amd64        Python 3 bindings for Qt5's WebChannel module
ii  python3-pyqt5.qtwebengine            5.15.2-2                               amd64        Python 3 bindings for Qt5's WebEngine module
ii  python3-pyqt5.sip                    12.8.1-1+b2                            amd64        runtime module for Python extensions using SIP
ii  qt5-image-formats-plugins:amd64      5.15.2-2                               amd64        Qt 5 Image Formats module
ii  vlc-plugin-qt:amd64                  3.0.18-0+deb11u1                       amd64        multimedia player and streamer (Qt plugin)

Offline

#7 2023-03-14 03:29:53

jcamp
Member
Registered: 2019-12-30
Posts: 5  

Re: Calibre qt issue

fsmithred wrote:

Maybe some qt package is missing. Here's what I have installed that has qt in the name (or description)
Compare what's in your laptop to this list or one like this from your desktop.

dpkg -l |grep qt gives me a lot more that, 92 of the desktop (working) and 38 not the not working laptop. As I have an alternative will work on it on return.

Offline

Board footer