The officially official Devuan Forum!

You are not logged in.

#1 2022-12-16 18:03:52

rolfie
Member
Registered: 2017-11-25
Posts: 759  

[SOLVED] Five-or-more pinning to older version

Daedalus with Cinnamon DE.

The counting of results of the game five-or-more is broken since Chimaera, and hasn't been fixed in Daedalus. I removed the package from the installation, downloaded the older version five-or-more_3.30.0-2_amd64.deb from Beowulf and installed it with dpkg -i. I think I had to install an additional dependency. The older program is working.

To keep the package, I added a file five-or-more to /etc/apt/preferences.d with the contents:

Package: five-or-more
Pin: version 3.30.0*
Pin-Priority: 1001

When I run an apt update this setting is ignored, I still get the version 3.32.3 listed as installation candidate.

What is wrong in my setup? Why is the preference ignored? Shouldn't I see the setting immediately in apt-cache policy?

rolfie

Offline

#2 2022-12-16 18:07:40

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 3,097  
Website

Re: [SOLVED] Five-or-more pinning to older version

Can we see

apt policy
apt policy five-or-more

Thanks!


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII, 18.

Offline

#3 2022-12-16 18:14:30

rolfie
Member
Registered: 2017-11-25
Posts: 759  

Re: [SOLVED] Five-or-more pinning to older version

# apt policy
Paketdateien:
 100 /var/lib/dpkg/status
     release a=now
 500 http://deb.devuan.org/merged daedalus/non-free i386 Packages
     release v=5.0,o=Devuan,a=testing,n=daedalus,l=Devuan,c=non-free,b=i386
     origin deb.devuan.org
 500 http://deb.devuan.org/merged daedalus/non-free amd64 Packages
     release v=5.0,o=Devuan,a=testing,n=daedalus,l=Devuan,c=non-free,b=amd64
     origin deb.devuan.org
 500 http://deb.devuan.org/merged daedalus/contrib i386 Packages
     release v=5.0,o=Devuan,a=testing,n=daedalus,l=Devuan,c=contrib,b=i386
     origin deb.devuan.org
 500 http://deb.devuan.org/merged daedalus/contrib amd64 Packages
     release v=5.0,o=Devuan,a=testing,n=daedalus,l=Devuan,c=contrib,b=amd64
     origin deb.devuan.org
 500 http://deb.devuan.org/merged daedalus/main i386 Packages
     release v=5.0,o=Devuan,a=testing,n=daedalus,l=Devuan,c=main,b=i386
     origin deb.devuan.org
 500 http://deb.devuan.org/merged daedalus/main amd64 Packages
     release v=5.0,o=Devuan,a=testing,n=daedalus,l=Devuan,c=main,b=amd64
     origin deb.devuan.org
Mit Pinning verwaltete Pakete:
# apt policy five-or-more
five-or-more:
  Installiert:           1:3.30.0-2
  Installationskandidat: 1:3.32.3-1
  Versionstabelle:
     1:3.32.3-1 500
        500 http://deb.devuan.org/merged daedalus/main amd64 Packages
 *** 1:3.30.0-2 100
        100 /var/lib/dpkg/status

Offline

#4 2022-12-16 18:16:01

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 3,097  
Website

Re: [SOLVED] Five-or-more pinning to older version

You forgot to add the epoch:

Package: five-or-more*
Pin: version 1:3.30.0*
Pin-Priority: 1001

Tested and works for me.

EDIT: added asterisk after package name to cover multi-arch systems.

Last edited by Head_on_a_Stick (2022-12-16 18:18:23)


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII, 18.

Offline

#5 2022-12-16 18:37:41

rolfie
Member
Registered: 2017-11-25
Posts: 759  

Re: [SOLVED] Five-or-more pinning to older version

Why is this "1:" you call it epoch required? Well it works this way.

I scanned through the man apt_preferences, the Ubuntu wiki article, and other in the internet before posting here, didn't see that in the examples given ....

Offline

#6 2022-12-16 18:43:05

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 3,097  
Website

Re: [SOLVED] Five-or-more pinning to older version

rolfie wrote:

Why is this "1:" you call it epoch required?

The epoch is part of the version string. See also https://www.debian.org/doc/debian-polic … ml#version.


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII, 18.

Offline

#7 2022-12-16 18:49:43

rolfie
Member
Registered: 2017-11-25
Posts: 759  

Re: [SOLVED] Five-or-more pinning to older version

Well, don't fully understand the reasoning. The filename did not include the epoch, and I used that info for the pref file. The epoch is present in Synpatic and when you look closely to the printout of apt policy, but I never thought it would be important, based on the examples I saw.

So far so bad, its solved. Again what learned ....

Offline

Board footer