The officially official Devuan Forum!

You are not logged in.

#1 2022-08-28 07:47:35

Gregors
Member
From: Freiburg, Germany
Registered: 2018-08-09
Posts: 21  
Website

[SOLVED] Error: Package lsb is not installed ...?!

Hi there,

I have trouble installing my printer (Epson ET-M1140):

Searching epson support I found an
epson-inkjet-printer-escpr2
package that has „unmet dependencies“:

The following packages have unmet dependencies:
 epson-inkjet-printer-escpr2 : Depends: lsb (>= 3.2) which is a virtual package and is not provided by any available package

The following actions will resolve these dependencies:

     Remove the following packages:                      
1)     epson-inkjet-printer-escpr2 [1.1.49-1lsb3.2 (now)]



Accept this solution? [Y/n/q/?] n       

When I try to compile that from source make complains about several „undefined references (e.g. „undefined reference to `ppdOpenFile'“)

So, what can I do to make my printer print?

TIA

Gregor

Offline

#2 2022-08-28 09:02:27

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 2,528  

Re: [SOLVED] Error: Package lsb is not installed ...?!

You could use equivs to create a fake lsb package to satisfy the dependency. No idea if that would actually work though. I've never owned a printer. Thank "$DEITY".

EDIT: full quote to prevent globbing.

Last edited by Head_on_a_Stick (2022-08-28 15:00:39)

Offline

#3 2022-08-28 09:17:34

Gregors
Member
From: Freiburg, Germany
Registered: 2018-08-09
Posts: 21  
Website

Re: [SOLVED] Error: Package lsb is not installed ...?!

Head_on_a_Stick wrote:

You could use equivs to create a fake lsb ...

Thanks! I'll try that.

Gregor

Offline

#4 2022-08-28 18:37:24

Grumpy
Member
Registered: 2022-07-18
Posts: 6  

Re: [SOLVED] Error: Package lsb is not installed ...?!

I'm not sure if your printer is supported by the package but have you tried

# apt install printer-driver-escpr

If your printer is supported then you can add the printer to CUPS by pointing the web browser of your choice to http://localhost:631/ and selecting the add printer option

Last edited by Grumpy (2022-08-28 18:46:35)

Offline

#5 2022-08-29 16:11:51

kapqa
Member
Registered: 2019-01-02
Posts: 291  

Re: [SOLVED] Error: Package lsb is not installed ...?!

Offline

#6 2022-08-31 14:58:36

Gregors
Member
From: Freiburg, Germany
Registered: 2018-08-09
Posts: 21  
Website

Re: [SOLVED] Error: Package lsb is not installed ...?!

Thanks a lot!

It prove the printer drivers were not installed. Silly me ... as usual ...

Gregor

Offline

Board footer