The officially official Devuan Forum!

You are not logged in.

#1 2022-08-21 12:39:05

drito
Member
Registered: 2022-08-11
Posts: 5  

Lightdm package changed Grub.

Hello. I installed a minimal Devuan to get bspwm, then I installed Lightdm using apt.
After the restart the Grub screen has changed. It looks better but it is unexpected.
Questions:
Is it a behaviour from Devuan or from Debian ?
Is there some relation between Grub and Lightdm that required a Grub update or is it just a bloated package ?

Offline

#2 2022-08-21 21:40:02

MiyoLinux
Member
Registered: 2016-12-05
Posts: 1,235  

Re: Lightdm package changed Grub.

Without more information,  my guess (based on my own experience) is that...

apt install lightdm

...was used (if installed via a terminal).

If so, my guess (also based on my own experience) is that the package desktop-base was also pulled in with that command, which will change the grub theme.

If you ever try again, use the command...

apt install lightdm --no-install-recommends

...in order to avoid pulling in desktop-base.


I have been Devuanated, and my practice in the art of Devuanism shall continue until my Devuanization is complete. Until then, I will strive to continue in my understanding of Devuanchology, Devuanprocity, and Devuanivity.

Veni, vidi, vici vdevuaned. I came, I saw, I Devuaned. wink

Offline

#3 2022-08-21 22:48:39

drito
Member
Registered: 2022-08-11
Posts: 5  

Re: Lightdm package changed Grub.

I advise to use this option everytime. Stupid people like me read "apt install lightdm" so I expect lightdm to be installed, period, and not the full graphical stack. There is even a "systemd" recommended package in some package, I don't remember the name sorry.
The Devuan people are nice and helpful, but I have to install a sane distro.
Its sad, Debian seems to be the only distro that aims to be stable, but they stupidly break stuff with their insane packages. All my Guix packages was broken by lightdm additional bloat. I used several flavours of Arch and this thing never happened. Sorry for the rant.

Last edited by drito (2022-08-21 22:50:05)

Offline

#4 2022-08-21 23:39:02

fsmithred
Administrator
Registered: 2016-11-25
Posts: 2,152  

Re: Lightdm package changed Grub.

To make --no-install-recommends the default for your system,

echo 'APT::Install-Recommends "0";' > /etc/apt/apt.conf.d/00norecommends

Offline

#5 2022-08-22 15:56:12

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 2,730  

Re: Lightdm package changed Grub.

drito wrote:

I advise to use this option everytime.

Not installing Recommends will lead to reduced or just plain broken functionality for most users.

IMO configuring the bootloader so that the theme is consistent with the new display manager seems sensible, and even perhaps a really nice idea. Purists wouldn't dream of installing bloat like display managers anyway.


"Who's the idiot in charge?" — ralph.ronnquist

Offline

#6 2022-08-22 19:12:05

drito
Member
Registered: 2022-08-11
Posts: 5  

Re: Lightdm package changed Grub.

I think package name must say everything without having to tweak the package manager, or it must be called a meta-package. My grub can run two distros so it is no tied to a particular display manager. This is not about minimalism, I lack Linux skills to build a distro from minimal install. Tiling window managers is just efficient and time saver. If a distro provides a clean bspwm out of the box with lightdm I'd never touch these stuff.

But your opinion is fine, it is just a different philosophy.

Offline

Board footer