The officially official Devuan Forum!

You are not logged in.

#1 2022-03-01 08:35:41

Registered: 2019-01-18
Posts: 14  

New install with runit and Kernel bug

For some context.

Yesterday I have installed Devuan on a pc that used to work perfectly before, but this time I get a suspend issue.

Maybe I am wrong, but I think it is related to runit, as the same drivers are installed as well as the kernel, only runit is new.

Now if I suspend the system while being on gdm, or gnome, Devuan crashes at resume, leaving only a black screen, or some message. I have to hard reboot or reset with Alt Gr+Print Scrn+b.

But if, before suspend, I go to any tty, and then push the suspend button on the keyboard, the system resumes without any problem, but now I can get some output from dmesg.

For each "virual" cpu I get lines like these:

  • BUG: scheduling while atomic: cpuhp/…

  • Preemption disabled at:

  • the call stack

Could be also related to xserver-xorg-video-nvidia, but I tried almost every combination that used to work just before the new installation with Chimaera kernel and drivers, backports kernel and drivers, Ceres…, but since this new installation I get each time the same issue.

Any idea on how to solve this issue?

Finally, to who should I report this bug? Devuan only, if it is related to runit? To Linux kernel maintainers?

Last edited by zero (2022-03-04 17:58:18)


#2 2022-03-02 12:17:41

Registered: 2016-11-25
Posts: 2,068  

Re: New install with runit and Kernel bug

Here's an explanation of the error message you got. It's beyond my understanding. … cpu0-in-ts

I have a chimaera xfce with runit, and I can share a few data points. Maybe it will help.

If I use pm-suspend to put the system to sleep, it wakes normally when I raise the lid.

If I rely on xfce4-power-manager to put it to sleep when I close the lid, it does not suspend. And the screen is locked when I raise the lid. Both of those behaviors are contrary to the settings in the power manager.

No nvidia here. It's all intel. I don't think runit is the problem, but that's just a guess. FWIW, I have enabled runit scripts for the following services:

acpid    connman  dbus getty-tty1-6 getty-ttyS0  lightdm
anacron  cron  elogind  irqbalance  mdadm    ssh


#3 2022-03-04 13:41:38

Registered: 2019-01-18
Posts: 14  

Re: New install with runit and Kernel bug

Thanks for your answer, you help me to better understand the situation.

I have conclude that there are at least two issues.

  • One related to OpenZFS.

  • Another, not yet clearly identified, but probably related to the GPU and how ACPI is handled

For the first issue, this is definitely not what cause the system to hang at resume. Now I have to wait for the fix.

For the second issue, it remembers the exact same problem I get when I tried to enable Wayland with 470 driver series, but here with Xorg only…

So I have tried the lasted driver (510.54) from Nvidia website. Now I can suspend the system without getting any crash. Moreover, I have now Wayland working.

I do not understand how, but before the new install, and with the same drivers, the system worked fine…

Anyway, thanks for your help.


What a noob… I did not noticed that Nouveau was running, until I used some softwares that are GPU greedy… With the Nvidia 510.54 driver, I have the same bug than before, but not with Nouveau.

But at least, now I can blame Nvidia driver.

Last edited by zero (2022-03-04 18:03:03)


Board footer