The officially official Devuan Forum!

You are not logged in.

#1 2021-04-26 19:54:02

devujan
Member
Registered: 2019-10-26
Posts: 15  

Badly missing uswsusp in chimaera

I set up an nice FDE laptop with chimaera (AMD 4700U working out of the box) - but I can not suspend chimaera.
Suspend works in principle somehow - but how do I unload and reload the realtek modules and how do I stabilize the graphic system?
After suspend the machine sometimes "freezes" and loses network connection - all erratically.
With uswsusp I was able to solve these problems in ascii and beowulf....
Are there newer, better tools in place, to help with suspend - or has just the only really working tool been abandoned?

Offline

#2 2021-04-26 20:28:37

Marjorie
Member
From: Teignmouth, UK
Registered: 2019-06-09
Posts: 104  

Re: Badly missing uswsusp in chimaera

I can't speak about Chimaera, as I'll stick with stable/Beowulf, but at some point in my migrations I found I could no longer get uswusp to work but found that kernel suspend works OK.

I use pm (pm-utils package, pm-suspend or pm-hibernate commands) to suspend and hibernate and this has options for the power down methods:

#   kernel    The built-in kernel suspend/resume support.
#                 Use this if nothing else is supported on your system.
#   uswsusp   If your system has support for the userspace
#                 suspend programs (s2ram/s2disk/s2both), then use this.
#   tuxonice  If your system has support for tuxonice, use this.

You can also specify suspend and resume modules in the config (/etc/pm/config.d/defaults). I do this for my wireless ath9k modules as otherwise my atheros wireless card doesn't power down.

You'll also need a resume=[swap partition] parameter in your grub's linux /boot/vmlinuz line if you use hibernate.

Of course they may have removed pm-utils in Chimaera, which would mean I'd have problems upgrading too.

Last edited by Marjorie (2021-04-26 22:10:26)

Offline

#3 2021-04-27 15:32:09

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,654  
Website

Re: Badly missing uswsusp in chimaera

Is the AMD graphics firmware installed? The µcode package should also be installed but I'm not sure if there are any fixes for the Ryzen 4000 series yet.


antifa ftw!

Offline

#4 2021-05-04 16:24:55

devujan
Member
Registered: 2019-10-26
Posts: 15  

Re: Badly missing uswsusp in chimaera

The the AMD graphics firmware is installed and AMD Graphics works from the very start beautifully.
I guess I have to give GRUB_CMDLINE_LINUX in /etc/default/grub a closer look and have check for pm scripts to remove and reinsert kernel modules.
My problem is that my wife is using that particular notebook very productive in school now - and I have to wait for a timeslot to tackle that issue. 
I'll report any news here.

Offline

Board footer