The officially official Devuan Forum!

You are not logged in.

#1 2021-04-04 12:07:36

theIneff
Member
Registered: 2018-09-11
Posts: 8  

[SOLVED] Problem installing on an Acer Aspire 315-23

Hello everyone.
I'm currently trying to install devuan beowulf 3.1.0 on an Acer Aspire 3 315-23.
I tried creating the live-usb both with the old school method (namely dd-ing the iso file on the usb drive)
and the cool kid-method (namely using refracta2usb to create the bootable live-usb).

Currently I'm facing the following problems.
Both the usb's don't boot up with secure boot, shouldn't grub be signed to boot up with secure boot? It seems strange
especially since ubuntu LTS live-usb seems to be able to boot with secure boot.
Nevertheless, disabling secure boot I'm able to boot up the system but the live doesn't start the X-server,
it seems it isn't able to load the graphic driver.

The laptop has a ryzen 3500U with an integrated radeon vega 8 as a graphic adaptor.

Please feel free to ask for any additional information.
Any help is much appreciated.

Offline

#2 2021-04-04 12:14:38

dice
Member
Registered: 2020-11-22
Posts: 445  
Website

Re: [SOLVED] Problem installing on an Acer Aspire 315-23

What medium did you download and copy to USB ? What were the commands?

Last edited by dice (2021-04-04 12:15:26)


Do good things.  Share.  Be helpful.  Be decent.  Live large.
E.V.I.L = Electronic Virtual Intelligent Life

Offline

#3 2021-04-04 13:49:29

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,597  
Website

Re: [SOLVED] Problem installing on an Acer Aspire 315-23

theIneff wrote:

shouldn't grub be signed to boot up with secure boot?

It is. The Devuan installer uses the grub-efi-*-signed package for the UEFI bootloader. What actually happens when you try to boot the ISO? What do you see?

theIneff wrote:

the live doesn't start the X-server,
it seems it isn't able to load the graphic driver.

I'm sure the driver (amdgpu) is fine but your hardware needs the firmware-amd-graphics package to start X.


Black Lives Matter

Offline

#4 2021-04-04 14:54:58

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,857  

Re: [SOLVED] Problem installing on an Acer Aspire 315-23

The desktop-live isos already have firmware-amd-graphics installed. Maybe the version from backports is needed. I don't have an easy way to test that right now. And debian wiki suggests that this is not the problem. (4.19 is new enough)

Offline

#5 2021-04-04 15:11:26

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,597  
Website

Re: [SOLVED] Problem installing on an Acer Aspire 315-23

fsmithred wrote:

the version from backports is needed

Yes I think the backported firmware may be required. The Ryzen 3500U was released 2020-01-06 but the stock AMD firmware package is from 2020-01-14 so it probably isn't supported by that.


Black Lives Matter

Offline

#6 2021-04-04 15:21:10

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,857  

Re: [SOLVED] Problem installing on an Acer Aspire 315-23

I'm going to update my backports test iso today and will post the link later.

Offline

#7 2021-04-04 15:27:23

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,597  
Website

Re: [SOLVED] Problem installing on an Acer Aspire 315-23

My buster-backports ISO image includes the backported firmware so the OP could load that up and check

lspci -k | grep -iA2 'vga\|3d\|display'
dmesg | grep firmware

It doesn't include X but if the amdgpu kernel module & graphics firmware is loaded then it should work.


Black Lives Matter

Offline

#8 2021-04-05 13:05:07

theIneff
Member
Registered: 2018-09-11
Posts: 8  

Re: [SOLVED] Problem installing on an Acer Aspire 315-23

dice wrote:

What medium did you download and copy to USB ? What were the commands?

I downloaded the last iso from the devuan website.
About the commands used, as I said before I created the first usb-live with

dd if=beowulf.iso of=/dev/sdb

while for the second one I used refracta2usb.

Offline

#9 2021-04-05 13:07:48

theIneff
Member
Registered: 2018-09-11
Posts: 8  

Re: [SOLVED] Problem installing on an Acer Aspire 315-23

Thank you all for all you kind answers, I'll try to make a new live-iso with the backports modules,
hopefully this will solve the problem.
Fingers crossed I'll keep you updated!

Offline

#10 2021-04-05 13:47:57

theIneff
Member
Registered: 2018-09-11
Posts: 8  

Re: [SOLVED] Problem installing on an Acer Aspire 315-23

Sorry I missed this part of the post.

Head_on_a_Stick wrote:
theIneff wrote:

shouldn't grub be signed to boot up with secure boot?

It is. The Devuan installer uses the grub-efi-*-signed package for the UEFI bootloader. What actually happens when you try to boot the ISO? What do you see?

Basically the UEFI-system displays an (irony)informative message(/irony) "Secure Boot Fail" and an image showing a lock.

Offline

#11 2021-04-13 15:25:40

theIneff
Member
Registered: 2018-09-11
Posts: 8  

Re: [SOLVED] Problem installing on an Acer Aspire 315-23

Updates: I finally installed my loved devuan. As you suggested I had to modify the live-usb to boot,
but that wasn't enough I had to disable the secure boot.

Anyway now I have a fully functioning devuan system, hence the problem is solved.
Thanks to everyone for the help.

Offline

Board footer