The officially official Devuan Forum!

You are not logged in.

#1 2017-06-17 18:46:30

Registered: 2017-02-04
Posts: 143  

Howto: Sylpheed 3.5.1 in Devuan Jessie

The version of the Sylpheed mail client in Devuan Jessie is 3.5.0~beta1. The current upstream stable release (3.5.1) is in the ASCII repositories. However, backporting Sylpheed from the source package in ASCII is tricky due to a change with the gpgme packages (libgpgme11 in Jessie vs. libgpgme in ASCII). So, here's how to build it from source.

1. Download and verify

Get the source tar ball and the corresponding PGP signature from and verify your download by checking the signature. I have a directory called src/ inside my home directory where I put source files of software I want to build, so Sylpheed's sources will go there as well.

msi@devuan:~$ cd src/
msi@devuan:~/src$ wget

As you probably won't have the public key corresponding to the signature available, you will get the usual error trying to verify it:

msi@devuan:~/src$ gpg --verify sylpheed-3.5.1.tar.gz.asc 
gpg: assuming signed data in `sylpheed-3.5.1.tar.gz'
gpg: Signature made Fri Jul 29 09:41:09 2016 CEST using DSA key ID C00C2E26
gpg: Can't check signature: public key not found

Get the key, using:

msi@devuan:~/src$ gpg --recv-keys C00C2E26
gpg: requesting key C00C2E26 from hkp server
gpg: key C00C2E26: public key "Hiroyuki Yamamoto <>" imported
gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
gpg: depth: 0  valid:   6  signed:   0  trust: 0-, 0q, 0n, 0m, 0f, 6u
gpg: next trustdb check due at 2019-06-08
gpg: Total number processed: 1
gpg:               imported: 1

Then verify the signature:

msi@devuan:~/src$ gpg --verify sylpheed-3.5.1.tar.gz.asc

Successful verification will look like this:

gpg: assuming signed data in `sylpheed-3.5.1.tar.gz'
gpg: Signature made Fri Jul 29 09:41:09 2016 CEST using DSA key ID C00C2E26
gpg: Good signature from "Hiroyuki Yamamoto <>"
gpg:                 aka "Hiroyuki Yamamoto <>"
gpg: WARNING: This key is not certified with a trusted signature!
gpg:          There is no indication that the signature belongs to the owner.
Primary key fingerprint: 8CF3 A5AC 417A DE72 B0AA  4A83 5024 337C C00C 2E26

2. Install build dependencies

Install packages required to build Sylpheed, running:

root@devuan:/home/msi/src# apt-get build-dep sylpheed

3. Build Sylpheed

Extract the tar archive and change into the newly created directory:

msi@devuan:~/src$ tar xfz sylpheed-3.5.1.tar.gz
msi@devuan:~/src$ cd sylpheed-3.5.1/

Building Sylpheed now is as simple as following the instructions given in the INSTALL file:

msi@devuan:~/src/sylpheed-3.5.1$ ./configure
msi@devuan:~/src/sylpheed-3.5.1$ make

(If you have more than one CPU you might want to use the ''-j'' option to speed things up (see "man make").)

msi@devuan:~/src/sylpheed-3.5.1$ su
root@devuan:/home/msi/src/sylpheed-3.5.1# make install

4. Install libsylph1

If you run Sylpheed from the command line after the installation, there will the following error message:

sylpheed: error while loading shared libraries: cannot open shared object file: No such file or directory

This is due a missing package and thus easily cured. Just install libsylph1 and you're set:

msi@devuan:~/src/sylpheed-3.5.1$ su
root@devuan:/home/msi/src# apt-get install libsylph1

(Btw, it's important to install this package after you've installed Sylpheed, for some reason.)

Run the program:

msi@devuan:~$ sylpheed

Source build and Devuan package

For me, building Sylpheed from source is an interim soultion until Devuan ASCII becomes stable. At that point I will upgrade my system and switch over to the distribution package.

To simulate the transition from the source build to a distribtuion package, I first uninstalled Sylpheed by running "make uninstall" in the source directory:

root@devuan:/home/msi/src/sylpheed-3.5.1# make uninstall

Then I installed the package version from the Jessie repositories and tried to use that. This worked flawlessly. As Sylpheed holds all personal data and configuration in a directory called .sylpheed-2.0 (that name should probably be changed upstream) inside your home directory, nothing will get lost, when you uninstall the program itself.

As I wasn't going to use the version from the repositories, I purged that package and then reinstalled the newer version built from source:

root@devuan:/home/msi/src/sylpheed-3.5.1# apt-get purge sylpheed
root@devuan:/home/msi/src/sylpheed-3.5.1# make install

This went well, but when I wanted to run Sylpheed I got the above error again, despite libsylph1 being installed. So I purged and reinstalled that package:

root@devuan:/home/msi/src/sylpheed-3.5.1# apt-get purge libsylph1
root@devuan:/home/msi/src/sylpheed-3.5.1# apt-get install libsylph1

Problem solved.

So, I suppose that if you uninstall Sylpheed before upgrading to ASCII and then install the distribution package after the upgrade, that won't cause any problems.

Last edited by msi (2017-06-18 00:44:22)


Board footer