The officially official Devuan Forum!

You are not logged in.

#1 2020-05-27 05:25:40

little
Member
Registered: 2017-06-08
Posts: 16  

Pocketbeagle and Beagleboard USB issues during Migration from Buster

On these two devices, when connected via USB only, and using the usb gadget ethernet link (i.e. ethernet over usb) to migrate the machine, after the reboot (according to this guide: https://beta.devuan.org/os/documentatio … o-beowulf) (reference: https://dev1galaxy.org/viewtopic.php?id=3044) usb0 is not recreated. This means that connection via the pocketbeagle (and original but not later bb's) requires a serial connection to continue.

The serial connection must also be added to /etc/inittab. The entry for the serial will depend upon your given device. You can simply make a number of them, or look them up. Worst case you end up with duplicates, and can then work from there.

I found scripts in the official bb debian buster images in /opt/script/boot/ (a number of bb tools are here), and among them are some that seem to address configuration of usb. I also found I needed to modprobe g_ether (usb gadget ethernet module). The issue appears to be that the OTG module is not auto loaded/configured.

I don't know if this is worth addressing by developers or not. But the information is here, in case anyone else uses these devices.



Beaglebone has ethernet, so this issue may not come up with bbb.

Ref:
https://linux-sunxi.org/USB_Gadget

Last edited by little (2020-05-27 05:31:13)


give a man an init, he takes an os

Offline

Board footer