The officially official Devuan Forum!

You are not logged in.

#1 2019-04-13 12:43:25

zero
Member
Registered: 2019-01-18
Posts: 10  

Grub memtest86+ entry stuck on black screen

I was trying to use memtest86+ for this topic.
Unfortunately, I get a black screen when I try to use it.

The keyboard's leds shutdown, and do not react when I push keys like num lock and caps lock.

Here the related grub.cfg

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
	insmod part_gpt
	insmod ext2
	set root='hd2,gpt1'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd2,gpt1 --hint-efi=hd2,gpt1 --hint-baremetal=ahci2,gpt1  xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
	else
	  search --no-floppy --fs-uuid --set=root xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
	fi
	linux16	/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
	insmod part_gpt
	insmod ext2
	set root='hd2,gpt1'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd2,gpt1 --hint-efi=hd2,gpt1 --hint-baremetal=ahci2,gpt1  xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
	else
	  search --no-floppy --fs-uuid --set=root xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
	fi
	linux16	/memtest86+.bin console=ttyS0,115200n8
}
menuentry "Memory test (memtest86+, experimental multiboot)" {
	insmod part_gpt
	insmod ext2
	set root='hd2,gpt1'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd2,gpt1 --hint-efi=hd2,gpt1 --hint-baremetal=ahci2,gpt1  xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
	else
	  search --no-floppy --fs-uuid --set=root xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
	fi
	multiboot	/memtest86+_multiboot.bin
}
menuentry "Memory test (memtest86+, serial console 115200, experimental multiboot)" {
	insmod part_gpt
	insmod ext2
	set root='hd2,gpt1'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd2,gpt1 --hint-efi=hd2,gpt1 --hint-baremetal=ahci2,gpt1  xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
	else
	  search --no-floppy --fs-uuid --set=root xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
	fi
	multiboot	/memtest86+_multiboot.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

Offline

#2 2019-04-13 14:59:22

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 290  
Website

Re: Grub memtest86+ entry stuck on black screen

The open source version doesn't work in UEFI mode.

It is possible to get a UEFI system booting in non-UEFI ("Legacy") mode, post back if you want help with that.

For a UEFI-compatible version see https://www.memtest86.com/download.htm

Otherwise, try memtester instead, that can be run from the booted system.


Fabricando fit faber

Offline

#3 2019-04-14 15:31:38

zero
Member
Registered: 2019-01-18
Posts: 10  

Re: Grub memtest86+ entry stuck on black screen

Ok thanks, I did not know that this version doesn't work in UEFI mode :s

I tried the UEFI version with usb sticks, but, strangely, I still get a black screen… Even if, now the keyboard seems to react (led, etc…). But still nothing on screen.

As for memtester, it should be "less accurate" than memtest86+; indeed, I will have to allocate an amount of memory, leaving at least 2GB unchecked—mate takes ~1.2GB.

Can you help me to get my system in Legacy mode?

As an aside, do you have some links about how works EFI with Grub? How can I manage grubx64.efi entries under /boot/efi?
I tried efibootmgr but seems useless—some entries are rewritten at boot?

Offline

#4 2019-04-14 15:58:02

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 290  
Website

Re: Grub memtest86+ entry stuck on black screen

zero wrote:

Can you help me to get my system in Legacy mode?

First create a BIOS boot partition on your main disk: I like to use gdisk and add a new partition of type "EF02" in sectors 34-2047 (these should be free in a correctly aligned disk), do not format the partition.

Then install the grub-pc-bin package and run

# grub-install --target=i386-pc /dev/sdX

Replace X with the letter assigned to your main drive.

Finally reboot and make sure that CSM or "Legacy" mode is enabled in your firmware ("BIOS") options, this will emulate a non-UEFI system and should allow memtester86+ to work.

zero wrote:

How can I manage grubx64.efi entries under /boot/efi?
I tried efibootmgr but seems useless—some entries are rewritten at boot?

If your firmware is crap (most are) then you will probably be using the fallback UEFI loader located on the EFI system partition at /EFI/BOOT/BOOTX64.EFI

See https://www.rodsbooks.com/efi-bootloade … iples.html & https://www.rodsbooks.com/efi-bootloade … ive-naming for more on this.


Fabricando fit faber

Offline

#5 2019-04-14 15:58:25

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,157  

Re: Grub memtest86+ entry stuck on black screen

To free up the memory that mate is using, drop to console (ctrl-alt-F2) log in as root and stop your display manager.
/etc/init.d/slim stop Or replace slim in that command with lightdm or whatever dm you're using. Replace stop with start in that command when you're ready to go back to the desktop.

To read all about booting uefi:
https://www.rodsbooks.com/efi-bootloaders/index.html

Look around in your bios for a Legacy or CSM boot setting. It's also possible that the boot device menu gives you a choice of legacy or uefi. You can usually get to this menu by pressing some key at boot (at the motherboard/computer logo) maybe F12, F11, F8, ESC, or other. Pressing DEL usually gets you to the bios.

Offline

#6 2019-04-21 17:01:32

zero
Member
Registered: 2019-01-18
Posts: 10  

Re: Grub memtest86+ entry stuck on black screen

@Head_on_a_Stick & @fsmithred
Thanks for the links, rodsbooks.com helped me a lot to understand how UEFI works. Previously, in my understanding, UEFI was only a kind of BIOS wrapper.

As for legacy mode, I used to think that I can get it under Grub EFI.

@fsmithred,

fsmithred wrote:

To free up the memory that mate is using, drop to console (ctrl-alt-F2) log in as root and stop your display manager.
/etc/init.d/slim stop Or replace slim in that command with lightdm or whatever dm you're using. Replace stop with start in that command when you're ready to go back to the desktop.

You right, how I did not think about this before :s Anyway, even if I stop lightdm, then stop as many services as possible, I will never get the maximum RAM to test.

Finally, I did my tests with memtest86+ and all 4 pass are OK.

Thanks for all.

Offline

Board footer