The officially official Devuan Forum!

You are not logged in.

#1 2024-02-27 09:35:57

trabant-asb
Member
Registered: 2023-09-27
Posts: 4  

New backports packages for Chimaera

I noticed that there have been a lot of packages put into the backports repository recently for Chimaera. However, due to the lower priority, they do not get installed by a normal upgrade. Of course I can override the priority locally to get them installed... so my question is if there are plans to move them into the upgrades or proposed-upgrades repository any time soon, or if there are reasons why they should not be installed by the default user...

Here comes the list I got from apt-get -s full-upgrade after changing the priority of backports to 500 on my desktop system:

The following packages were automatically installed and are no longer required:
  libcmis-0.5-5v5 liblibreoffice-java libmwaw-0.3-3 libnumbertext-1.0-0 libnumbertext-data liborcus-0.16-0 liborcus-parser-0.16-0
  libqrcodegencpp1 libunoloader-java python3-ldb python3-talloc ure-java
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  libjuh-java libjurt-java libridl-java
The following NEW packages will be installed:
  libabsl20200923 libbox2d2.3.0 libjemalloc2 libmbim-utils libpipewire-0.3-common libqmi-utils libqrtr-glib0 libwireplumber-0.4-0
  pipewire-pulse ure-java wireplumber
The following packages have been kept back:
  chromium chromium-common chromium-sandbox
The following packages will be upgraded:
  at-spi2-core bind9-dnsutils bind9-host bind9-libs bluez-firmware bootlogd bubblewrap curl debhelper dnsutils e2fsprogs
  firmware-amd-graphics firmware-linux firmware-linux-nonfree firmware-misc-nonfree firmware-realtek fonts-opensymbol gir1.2-atk-1.0
  gir1.2-atspi-2.0 gir1.2-lokdocview-0.1 gir1.2-nm-1.0 git git-man gstreamer1.0-pipewire initscripts less libatk-adaptor
  libatk-bridge2.0-0 libatk-wrapper-java libatk-wrapper-java-jni libatk1.0-0 libatk1.0-data libatspi2.0-0 libbpf0 libcom-err2
  libcurl3-gnutls libcurl4 libdebhelper-perl libdeflate0 libdw1 libelf1 libell0 libepoxy0 libext2fs2 libflatpak0 libfreerdp2-2 libldb2
  liblibreoffice-java liblibreofficekitgtk liblouis-data liblouis20 liblouisutdml-bin liblouisutdml-data liblouisutdml9 libmbim-glib4
  libmbim-proxy libmm-glib0 libnm0 libnss-myhostname libpcap0.8 libpipewire-0.3-0 libpipewire-0.3-modules libqmi-glib5 libqmi-proxy
  libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-gnome libreoffice-gtk3
  libreoffice-impress libreoffice-math libreoffice-style-colibre libreoffice-style-elementary libreoffice-writer libreofficekit-data
  libsmbclient libspa-0.2-modules libss2 libtalloc2 libtdb1 libtevent0 libuno-cppu3 libuno-cppuhelpergcc3-3 libuno-purpenvhelpergcc3-3
  libuno-sal3 libuno-salhelpergcc3-3 libunoloader-java libva-drm2 libva-x11-2 libva2 libvulkan1 libwbclient0 libwinpr2-2 logsave man-db
  modemmanager network-manager pipewire pipewire-bin python3-gi python3-gi-cairo python3-ldb python3-markupsafe python3-pkg-resources
  python3-pyatspi python3-setuptools python3-talloc python3-uno python3-websockets rsync samba-libs sysv-rc sysvinit-core sysvinit-utils
  tcpdump uno-libs-private ure va-driver-all wpasupplicant xdg-desktop-portal xdg-desktop-portal-gtk
123 upgraded, 11 newly installed, 3 to remove and 3 not upgraded.

Interestingly the sysv-rc, initscripts and sysvinit-core are among the listed packages.

Please note that I have put the chromium packages on hold manually because of an issue with the latest build on ARM64.

Greetings from Berlin,
Alex

Last edited by trabant-asb (2024-02-27 09:39:46)

Offline

#2 2024-02-27 18:48:54

fsmithred
Administrator
Registered: 2016-11-25
Posts: 2,425  

Re: New backports packages for Chimaera

Yes, there is a reason not to install everything that's in backports.

Things get backported to bring new features into the stable distribution.  Maintainers will test their backported packages with the stable system.

Nobody tests all the backported packages together, therefore nobody knows if they all work together. If you need something from backports, just install what you need.
.

Offline

Board footer