The officially official Devuan Forum!

You are not logged in.

#1 2023-09-16 02:38:44

Registered: 2018-06-12
Posts: 41  

[SOLVED] (Daedalus) live-installer vs installed system

I've got a bit of a conundrum.  I have the desktop-live installer, amd64, on a usb stick and it runs great on my hp elitedesk 705 G4...  It's got an Amd ryzen 5 pro 2400ge w/ radeon vega graphics.  I ran the installer from the desktop-live environment. The problem is in the installed system.  It boots.  X will usually refuse to start - errors are

[    10.529] (EE) open /dev/dri/card0: No such file or directory
[    10.530] (EE) Unable to find a valid framebuffer device
[    10.530] (EE) open /dev/fb0: No such file or directory
[    10.530] (EE) Screen 0 deleted because of no matching config section.
[    10.532] (EE) VESA(0): No V_BIOS found
[    10.533] (EE) Screen(s) found, but none have a usable configuration.
[    10.533] (EE) no screens found(EE) 

The few times X is able to start up, a mouse arrow appears on the screen and the screen does not respond at this point (no mouse movement; ctrl-alt-f1 does not display a text-mode vt).  I am able to ssh in, and see that Xorg is taking up 100% cpu.  when I kill the process, the plugged-in monitor still shows the mouse arrow and black background - have to reboot to get anything back on the screen.

Some things I have tried (1 at a time):
- update the kernel to 6.4 (backports)
- boot the 6.1.0-10-amd64 kernel (that matches the desktop-live iso)
- install seatd
- uninstall slim
- add "nomodeset" to grub cmdline
(as a side note, it was necessary for me to add "acpi_rev_override" to grub cmdline in order for eth0 to work properly - but it works properly in desktop-live)

desktop-live reports:
[    18.279] Kernel command line: BOOT_IMAGE=/live/vmlinuz initrd=/live/initrd.img boot=live username=devuan apparmor=0
installed-system (on 6.1.0-10-amd64 kernel) reports:
2023-09-15T22:05:00.730651-04:00 fccvideo kernel: [    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz-6.1.0-10-amd64 root=UUID=d68c3ae3-7db1-4c37-a6d9-2dd16cd407c5 ro quiet acpi_rev_override nomodeset

The installed system does not have /dev/fb0, nor /dev/dri/* - I think this is part of X's startup problem.  These files do exist when booting from the desktop-live iso.  What do I need to do to get the installed system working right?

Other things that may be of note
I've tried both "disabling" (hiding) TPM and re-enabling it, in the UEFI setup.  Currently it is enabled.
The boot is legacy, not EFI.  Partition table is dos (not gpt).

---- edit ----
It's now the next day.  I tried removing the acpi_rev_override and nomodeset from the grub commandline.  Then I installed every .deb package in /firmware.  The network adapter seems to be working fine now without that acpi_rev_override.  X does start (with startx) but the local screen is locked up again, and Xorg uses 100% cpu.  /dev/fb0 and /dev/dri/* do not exist.
I have another system (the one I'm posting from) that also does not have /dev/fb0 so that may not be related.
I've noticed when I startx as user "fcc" on the non-working machine, that Xorg is started as root (?)  Could this be the problem?

$ ps aux|grep Xorg
root      1931 96.4  1.2 375984 89548 tty2     Rl   12:29   0:44 /usr/lib/xorg/Xorg -nolisten tcp :0 vt2 -keeptty -auth /tmp/serverauth.EYjJMCyPr8

On my working machine, Xorg runs as the logged in user:

$ ps aux|grep Xorg
tempo     3152  1.0  0.7 6720588 249772 tty8   Sl   Aug25 327:26 /usr/lib/xorg/Xorg -nolisten tcp :0 vt8 -keeptty -auth /tmp/serverauth.UUKV7OIIz6

Still stuck, unsure how to proceed.

---- edit later ----
I copied the /etc/X11/xorg.conf from my working system to the non-working system (it had no xorg.conf), and edited it, only replacing Driver "nvidia" with Driver "amdgpu".  Now startx does start x, and Xorg runs as the current user.    /dev/fb0 and /dev/dri/ do exist now.  Unfortunately things are not completely working right.  If I press ctrl-alt-f2 to change virtual terminals, the X server on tty1 is instantly killed.  Also, the display settings application (as well as xrandr) only show modes 640x480 and 720x400.  That doesn't seem right.  But, progress is being made! :-)

---- edit later later ----
After a reboot, X failed to start again, with the same errors as given above.  Another reboot, it did start, with the 2 low-resolution options again.  Other reboots, X will not start at all.  Now (I'm not going to update the subject line but it is inaccurate) now, the desktop-live iso is not starting X either (same USB stick).  Arg.

---- later ----
Tried some more things.  Ubuntu iso goes into GUI mode and screen freezes.  Linux Mint iso boots, goes into GUI mode, seems to run okay.  Now the Devuan desktop-live iso booted into GUI mode successfully again (and when it does, it's not in low resolution mode; it looks right).  I think I have some flakey hardware (I did get this machine "refurbished" (used)).

Last edited by rbit (2023-09-16 19:52:09)


#2 2023-09-17 03:27:30

Registered: 2019-06-12
Posts: 154  

Re: [SOLVED] (Daedalus) live-installer vs installed system

with a vega gpu. on AMD system, you might need some firmware to get it to boot outside of console / lowresolution getty.

I had a similar issue on a old live USB. xinit would run in tty1.
Then Xorg would run in tty7. When I open tty1, it would crash xorg in tty7. Then xinit would get slim running on tty1 where tty7 becomes nothing.
I somehow fixed after updating the live-iso.

Last edited by czeekaj (2023-09-17 03:31:10)


#3 2023-09-17 03:48:42

Registered: 2018-06-12
Posts: 41  

Re: [SOLVED] (Daedalus) live-installer vs installed system

Thanks for the response.  I've actually got X working now, every boot.  What I had to do was make the disk gpt, re-partition it, addding an efi partition, and re-install devuan in efi mode instead of legacy.  There's still a minor issue with booting, I have to select the efi file each time but I may have found a fix for that too.  Not sure why it has this problem with legacy boot.  It booted fine, just something with the graphics/drm would not load consistently.  Anyway, I'm marking this solved.


Board footer