The officially official Devuan Forum!

You are not logged in.

#1 2023-09-10 22:40:55

chomwitt
Member
Registered: 2019-09-24
Posts: 119  

Sway with seatd

I was happy to read in Daedalus release notes:

### Wayland GUI without elogind

Users can now enjoy a wayland desktop without elogind by installing
libpam-ck-connector, sway and seatd.

The main reason is that i like to have options and secondly (but not least important) i like to have a system that feels less opaque regarding the functionality offered by each package.

So i started a desktopless fresh installation into my PC and i gradually installed various packages in order to setup a decent , ligthweight desktop based on sway but without elogind and using seatd.

For reason that i dont currently undrestand sway wont start unless  libpam-ck-connector
is installed. (that package is mentioned also in  'Devuan without elogind' by Iggy64 but again with no much explanation.

So sway starts by command line and  i am happy but various application try to pull elogind and also to remove libpam-ck-connector.
Example:

$ sudo apt-get install calibre
The following packages will be REMOVED:
  libpam-ck-connector libsystemd0
The following NEW packages will be installed:
  blt calibre calibre-bin eject elogind ...

So i try:

$ sudo apt-get install calibre elogind-
..
The following packages will be REMOVED:
  libpam-ck-connector
The following NEW packages will be installed:
  blt calibre calibre-bin dummy-logind
...

What can i do in that case ?

Last edited by chomwitt (2023-09-10 22:42:31)


Devuan(Chimaera)(Daedalus)  DS+WM: XorgX11server+StumpVM

Offline

#2 2023-09-11 00:38:07

hunter0one
Member
Registered: 2021-12-31
Posts: 68  

Re: Sway with seatd

libpam-ck-connector is for Consolekit2 to communicate with PAM. Consolekit2 is a more Unix respecting alternative to elogind and seatd is used alongside it to cover Wayland sessions.

Offline

#3 2023-09-11 16:01:48

chomwitt
Member
Registered: 2019-09-24
Posts: 119  

Re: Sway with seatd

but why do i need PAM to access my pc that i am the only user ?


Devuan(Chimaera)(Daedalus)  DS+WM: XorgX11server+StumpVM

Offline

#4 2023-09-12 12:49:32

stopAI
Member
Registered: 2023-04-04
Posts: 147  

Re: Sway with seatd

chomwitt wrote:

but why do i need PAM to access my pc that i am the only user ?

Because you are a system administrator.

More info here:

https://en.wikipedia.org/wiki/Linux_PAM

Online

#5 2023-09-14 10:57:48

chomwitt
Member
Registered: 2019-09-24
Posts: 119  

Re: Sway with seatd

thanks stopAI .
I see the broad picture now . How PAM is a common authentication functionality library-service .
I ll try to dig little deeper and see how seatd- consolekit2-pam and greetd work together. Because in first glance apt depents fields dont offer any insigths and reading the project's sites seems that consolekit2 functonality overalps seatd.

ps: how to stop AI ? I think by creating p2p AI and fediverse AI ?


Devuan(Chimaera)(Daedalus)  DS+WM: XorgX11server+StumpVM

Offline

#6 2023-09-14 11:37:41

stopAI
Member
Registered: 2023-04-04
Posts: 147  

Re: Sway with seatd

chomwitt wrote:

thanks stopAI .
ps: how to stop AI ? I think by creating p2p AI and fediverse AI ?

The only way to deal with the threat from AI is shut It down!

Last edited by stopAI (2023-09-14 11:38:12)

Online

#7 2023-09-23 14:58:26

chomwitt
Member
Registered: 2019-09-24
Posts: 119  

Re: Sway with seatd

System : Daedalus , sway+seatd+libpam-ck-connector

I find a way to install Calibre without pulling elogind  .

(due to past command: sudo dpkg --add-architecture i386 we see also various i386 packages)

$ sudo apt-get install calibre
     The following packages will be REMOVED:
       libasound2-plugins:i386 libpam-ck-connector libpulse0:i386
       libsdl2-2.0-0:i386 libsystemd0 libsystemd0:i386
     The following NEW packages will be installed:
       blt calibre calibre-bin eject elogind 

After we lowering apt priority to -1 for elogind in /etc/apt/preferences :
$ sudo apt-get install calibre
     The following packages will be REMOVED:
       libpam-ck-connector libsystemd0 libsystemd0:i386
     The following NEW packages will be installed:
       blt calibre calibre-bin eject elogind:i386   

After we lowering apt priority to -1 for elogind:i386 in /etc/apt/preferences : 
$ sudo apt-get install calibre
     The following packages will be REMOVED:
       libpam-ck-connector
     The following NEW packages will be installed:
       blt calibre calibre-bin dummy-logind ..

I didnt found how to keep 'libpam-ck-connector' from being removed in /etc/apt/preferences
but that command worked:
$ sudo apt-mark hold libpam-ck-connector
$ sudo apt-get install calibre
 // now libpam-ck-connector was not listed for removal but
 // neither dummy-logind for installation. But calibre was installed and seems to work ok.

Checking afterward in cases i missed something:
$ sudo apt-cache policy elogind
elogind:
  Installed: (none)
  Candidate: (none)
$ sudo apt-cache policy elogind:i386
elogind:i386:
  Installed: (none)
  Candidate: (none)

And here is my /etc/apt/preferences
Althougth as i noted  the libpam-ck-connector didnt work.

                                                
Package: elogind
Pin: release a=stable
Pin-Priority: -1

Package: elogind:i386
Pin: release a=stable
Pin-Priority: -1

Package: libpam-ck-connector
Pin: release a=stable
Pin-Priority: 1001

Please for anyone usiing  Daedalus with sway , seatd] and libpam-ck-connector it would be great to hear how you installed packages that try to remove libpam-ck-connector or pull elogind.

Last edited by chomwitt (2023-09-23 15:04:30)


Devuan(Chimaera)(Daedalus)  DS+WM: XorgX11server+StumpVM

Offline

#8 2023-10-16 18:37:01

czeekaj
Member
Registered: 2019-06-12
Posts: 154  

Re: Sway with seatd

I am not running into many issues if elogind is still installed. dependency wise you don't really need to run it but more uncomplicated if it's present.

Last edited by czeekaj (2023-10-16 18:38:23)

Offline

Board footer