The officially official Devuan Forum!

You are not logged in.

#1 2023-08-16 15:12:20

Registered: 2022-01-09
Posts: 28  

Switching VT crashes Xorg after upgrade to Daedalus

Hi all. I had a really nice setup on Chimaera where I had one user for gaming and one for everything else. I had stopped using slim because I wanted to avoid having xorg running as root so instead my computer would require me to login on a virtual terminal (Ctrl+Alt+F1) and then I would run startx to start XFCE. This worked perfectly. Both users were able to run separate Xorgs on different virtual terminals and I could switch between them by Ctrl+Alt+F* at will.

After upgrading to Daedalus if I try to switch away from the first Xorg, even if I'm just switching to a plain virtual terminal and not another xorg, even if there's no other Xorg running, the first Xorg crashes and when I switch back to it (Ctrl+Alt+F1) I'm already dropped back at the console.

I found these in the xorg crash log in my user directory:

[  3132.705] (II) seatd_libseat try close /dev/input/event3 (27:27)
[  3132.706] (II) event3  - Video Bus: device removed
[  3132.744] (II) seatd_libseat try close /dev/input/event6 (30:30)
[  3132.745] (II) event6  - Power Button: device removed
[  3132.785] (II) seatd_libseat try close /dev/input/event5 (31:31)
[  3132.785] (II) event5  - Logitech Wireless Mouse: device removed
[  3132.844] (II) seatd_libseat try close /dev/input/event11 (32:32)
[  3132.844] (II) event11 - Integrated_Webcam_FHD: Integrat: device removed
[  3132.888] (II) seatd_libseat try close /dev/input/event2 (33:33)
[  3132.928] (II) seatd_libseat try close /dev/input/event9 (34:34)
[  3132.928] (II) event9  - (redacted by me) Touchpad: device removed
[  3132.992] (II) seatd_libseat try close /dev/input/event1 (35:35)
[  3132.992] (II) event1  - Dell WMI hotkeys: device removed
[  3133.036] (II) seatd_libseat try close /dev/input/event0 (36:36)
[  3133.037] (II) event0  - AT Translated Set 2 keyboard: device removed
[  3133.072] (II) seatd_libseat try close /dev/input/event4 (37:37)
[  3133.128] (II) seatd_libseat try close /dev/input/event8 (38:38)
[  3133.128] (II) event8  - DELL Wireless hotkeys: device removed
[  3133.176] (II) seatd_libseat try close /dev/input/event14 (39:39)
[  3133.177] (II) event14 - BRLTTY 6.6 Linux Screen Driver Keyboard: device removed
[  3133.204] (II) AIGLX: Suspending AIGLX clients for VT switch
[  3134.008] (II) AIGLX: Resuming AIGLX clients after VT switch
[  3134.008] (EE) AMDGPU(0): failed to set mode: Permission denied
[  3134.008] (WW) AMDGPU(0): Failed to set mode on CRTC 0
[  3134.008] (EE) AMDGPU(0): Failed to enable any CRTC
[  3134.008] (EE) 
Fatal server error:
[  3134.008] (EE) EnterVT failed for screen 0

I saw in the release notes for Daedalus that there some changes around running xorg as non-root but I don't understand how they apply to me since I do not use any login manager like elogind, nor do I want to start using one if that's possible. But I do have elogind installed because it's a dependency of digiKam. I'd rather just use startx after having logged in on the console. My user is a member of the video group, I checked again. I'm not sure why I get this: "AMDGPU(0): failed to set mode: Permission denied"

Any ideas? Am I unknowingly using a login manager?

Thank you!

EDIT: I tried installing seatd and now I can switch out of my active xorg and into a VT but it will fail to start a second Xorg under a different user account. I removed it again for now since I think just solving the permission denied issue will make everything as it was before the upgrade.

Last edited by Tritonio (2023-08-16 15:56:00)


Board footer