The officially official Devuan Forum!

You are not logged in.

#1 2023-04-09 19:08:27

Carolina In My Mind
Member
Registered: 2023-01-10
Posts: 11  

[SOLVED] could you add the latest version of xfce4-notes that avoids libunique?

I was informed in this thread https://dev1galaxy.org/viewtopic.php?id=5464 that because xfce4-notes' depndency libunique is abandoned, Devuan cannot include xfce4-notes. However, I found out that for my other distro, MX, the developers solved that problem. They told me "libunique is no longer a dependency" and "[they] packaged it up for [their] own repo." (Source: https://forum.mxlinux.org/viewtopic.php … #p718487.) Could the Devuan team do this?

I dunno, perhaps this new version of xfce4-notes is the same one in Devuan's experimental repo that Head_on_a_Stick suggested I backport. (This backporting--would that be most likely what the MX team did?) But regardless, if the Devuan developers can't or won't do what MX did, then I guess I'll try myself to backport. I wasn't going to, but I don't particularly like the xfce4-notes alternatives that I've found.

Last edited by Carolina In My Mind (2023-04-09 19:24:01)

Offline

#2 2023-04-09 20:34:47

fsmithred
Administrator
Registered: 2016-11-25
Posts: 2,415  

Re: [SOLVED] could you add the latest version of xfce4-notes that avoids libunique?

It's very unlikely that we'll do it. You could backport it or you could probably download and install the version from mx that was made for the same version of debian that matches the devuan you're running.

Offline

#3 2023-04-10 14:54:47

Carolina In My Mind
Member
Registered: 2023-01-10
Posts: 11  

Re: [SOLVED] could you add the latest version of xfce4-notes that avoids libunique?

fsmithred wrote:

It's very unlikely that we'll do it. You could backport it or you could probably download and install the version from mx that was made for the same version of debian that matches the devuan you're running.

I tried your second suggestion. I didn't know it was safe to just try another distro's package--I had been advised against doing it; but so I tried MX's xfce4-notes package in Devuan, and it seems to work fine.

Last edited by Carolina In My Mind (2023-04-10 14:55:24)

Offline

#4 2023-04-10 21:41:59

fsmithred
Administrator
Registered: 2016-11-25
Posts: 2,415  

Re: [SOLVED] could you add the latest version of xfce4-notes that avoids libunique?

In general, yes it's a bad idea to pull packages from another distro. MX and Devuan are both very close to pure Debian, so there's a good chance that their forked packages will work for us.

Offline

Board footer