The officially official Devuan Forum!

You are not logged in.

#1 2022-11-26 00:30:16

AhmadRaniri
Member
Registered: 2020-12-23
Posts: 28  

lximage-qt: missing a library though it's already installed.

lximage-qt :

- Version :  1.1.0-2.
- Package from unstable.
- missing library : libfm-qt.so.11.

[ahmad ~]$ ldd /usr/bin/lximage-qt | grep found                                                                                                                           
        libfm-qt.so.11 => not found                                                                                                                                       
[ahmad ~]$

- package that possible has  *libfm-qt.so.11* : libfm-qt11.

[ahmad ~]$ apt-file find libfm-qt.so.11                                                                                                                                   
libfm-qt11: /usr/lib/x86_64-linux-gnu/libfm-qt.so.11                                                                                                                      
libfm-qt11: /usr/lib/x86_64-linux-gnu/libfm-qt.so.11.0.0                                                                                                                  
[ahmad ~]$

- Check if libfm-qt11 is installed :

[ahmad ~]$ apt search libfm-qt11                                                                                                                                          
Sorting... Done                                                                                                                                                           
Full Text Search... Done                                                                                                                                                  
libfm-qt11/unstable,now 1.2.0-1 amd64 [installed]                                                                                                                         
  file management support for pcmanfm-qt                                                                                                                                  
                                                                                                                                                                          
[ahmad ~]$

- Check libfm-qt11 package list files :

[ahmad ~]$ apt-file list libfm-qt11                                                                                                                                       
libfm-qt11: /usr/lib/x86_64-linux-gnu/libfm-qt.so.11                                                                                                                      
libfm-qt11: /usr/lib/x86_64-linux-gnu/libfm-qt.so.11.0.0                                                                                                                  
libfm-qt11: /usr/share/doc/libfm-qt11/AUTHORS                                                                                                                             
libfm-qt11: /usr/share/doc/libfm-qt11/README.md                                                                                                                           
libfm-qt11: /usr/share/doc/libfm-qt11/changelog.Debian.gz                                                                                                                 
libfm-qt11: /usr/share/doc/libfm-qt11/changelog.gz                                                                                                                        
libfm-qt11: /usr/share/doc/libfm-qt11/copyright                                                                                                                           
libfm-qt11: /usr/share/libfm-qt/archivers.list                                                                                                                            
libfm-qt11: /usr/share/libfm-qt/terminals.list                                                                                                                            
libfm-qt11: /usr/share/mime/packages/libfm-qt-mimetypes.xml                                                                                                               
[ahmad ~]$

I already installed the package but lximage-qt still complain about missing that one library.

Offline

#2 2022-11-26 00:32:06

AhmadRaniri
Member
Registered: 2020-12-23
Posts: 28  

Re: lximage-qt: missing a library though it's already installed.

Surprisingly I have *libfm-qt.so.12* instead.

[ahmad ~]$ ls /usr/lib/x86_64-linux-gnu/libfm-qt.so.12                                                                                                                    
/usr/lib/x86_64-linux-gnu/libfm-qt.so.12                                                                                                                                  
[ahmad ~]$

Last edited by AhmadRaniri (2022-11-26 00:32:32)

Offline

#3 2022-11-26 00:37:39

AhmadRaniri
Member
Registered: 2020-12-23
Posts: 28  

Re: lximage-qt: missing a library though it's already installed.

Linking libfm-qt.so.12 & libfm-qt.so.12.0.0 to libfm-qt.so.11 & libfm-qt.so.11.0.0 make lximage-qt run.

Offline

#4 2022-11-26 10:54:03

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 3,097  
Website

Re: lximage-qt: missing a library though it's already installed.

AhmadRaniri wrote:

Linking libfm-qt.so.12 & libfm-qt.so.12.0.0 to libfm-qt.so.11 & libfm-qt.so.11.0.0 make lximage-qt run.

Don't do that.

Soname bumps are a "feature" of the development branches. If you don't know how to handle them correctly then you probably shouldn't be using those branches.

Relevant bug report: https://bugs.debian.org/cgi-bin/bugrepo … ug=1024687

Should be fixed soon so revert that "fix", downgrade the relevant packages and wait.


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII, 18.

Offline

Board footer