The officially official Devuan Forum!

You are not logged in.

#1 2022-10-20 09:53:48

Geoff 42
Member
Registered: 2016-12-15
Posts: 425  

[SOLVED] libc6 bug fix has not reached chimaera-proposed-updates

when I attempted an update with

apt update
apt upgrade

I got the following warning :-

critical bugs of libc6 (2.31-13+deb11u3 → 2.31-13+deb11u4) <Resolved in some Version>
b4 - #1019855 - Fwd: libc6: immediately crashes with SIGILL on 4th gen Intel Core CPUs (seems related to AVX2 instructions), bricking the whole system (Fixed: glibc/2.31-13+deb11u5 glibc/2.35-2)

My system has 4th gen Intel Core CPUs, so this looks a bit serious.

I have watched the bug report :-

https://bugs.debian.org/cgi-bin/bugrepo … ug=1019855

and it appears that this has now been fixed and is available in version: 2.31-13+deb11u5 of glibc/libc6.

When I look at the Devuan package info at

https://pkginfo.devuan.org/cgi-bin/poli … 6&x=submit

it seems to report that 2.31-13+deb11u5 is available in chimaera-proposed-updates.

I have added chimaera-proposed-updates to the repositories and updated, however, instead of being at u5 it is still at u4, which has the bug. The bug report had the fix on Fri 14 Oct, which is nearly a week ago. How long should it take for the fix to reach chimaera-proposed-updates?

All the best

Geoff

Offline

#2 2022-10-20 12:41:50

fsmithred
Administrator
Registered: 2016-11-25
Posts: 2,152  

Re: [SOLVED] libc6 bug fix has not reached chimaera-proposed-updates

I just did 'apt upgrade' and got the version from chimaera-proposed-updates. I'm actually surprised that I got it, because I thought that proposed-updates did not get installed automatically. In the past, I had to add '-t chimaera-proposed-updates' to the install command.  'apt policy' shows me that proposed-updates has a priority of 500 just like the rest of the repo.

Oh, maybe because you're running u3 and I've been running u4 so there's nothing in the chimaera main repo for me - just in proposed.

apt -t chimaera-proposed-updates install libc6

should do it.

Offline

#3 2022-10-20 15:29:41

Geoff 42
Member
Registered: 2016-12-15
Posts: 425  

Re: [SOLVED] libc6 bug fix has not reached chimaera-proposed-updates

Thank you. You are right that I am still on u3.

With chimaera-proposed-updates enabled apt policy reports that it has a priority of 500 like the rest of the repo, while for libc6 :-

apt policy libc6

libc6:
  Installed: 2.31-13+deb11u3
  Candidate: 2.31-13+deb11u4
  Version table:
     2.31-13+deb11u4 500
        500 http://deb.devuan.org/merged chimaera/main amd64 Packages
*** 2.31-13+deb11u3 100
        100 /var/lib/dpkg/status

When I ask for it as you suggest I get :-

apt -t chimaera-proposed-updates install libc6

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
  libc-dev-bin libc6:i386 libc6-dev
Suggested packages:
  glibc-doc glibc-doc:i386 locales:i386
Recommended packages:
  libc-devtools libnss-nis libnss-nisplus libnss-nis:i386 libnss-nisplus:i386
The following packages will be upgraded:
  libc-dev-bin libc6 libc6:i386 libc6-dev
4 upgraded, 0 newly installed, 0 to remove and 138 not upgraded.
Need to get 0 B/8,213 kB of archives.
After this operation, 229 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
critical bugs of libc6 (2.31-13+deb11u3 → 2.31-13+deb11u4) <Resolved in some Version>
b1 - #1019855 - Fwd: libc6: immediately crashes with SIGILL on 4th gen Intel Core CPUs (seems related to AVX2 instructions), bricking the whole system (Fixed: glibc/2.31-13+deb11u5 glibc/2.35-2)
critical bugs of libc6:i386 (2.31-13+deb11u3 → 2.31-13+deb11u4) <Resolved in some Version>
b2 - #1019855 - Fwd: libc6: immediately crashes with SIGILL on 4th gen Intel Core CPUs (seems related to AVX2 instructions), bricking the whole system (Fixed: glibc/2.31-13+deb11u5 glibc/2.35-2)
Summary:
libc6(1 bug), libc6:i386(1 bug)
Are you sure you want to install/upgrade the above packages? [Y/n/?/...] n

Offline

#4 2022-10-20 20:31:42

fsmithred
Administrator
Registered: 2016-11-25
Posts: 2,152  

Re: [SOLVED] libc6 bug fix has not reached chimaera-proposed-updates

Wow, that's weird and annoying. Try installing libc6=2.31-13+deb11u5 (with or without the -t...)

Offline

#5 2022-10-21 06:48:14

Geoff 42
Member
Registered: 2016-12-15
Posts: 425  

Re: [SOLVED] libc6 bug fix has not reached chimaera-proposed-updates

I thought that I should carefully check my sources.list.

I notice that I have :-

deb http://deb.devuan.org/devuan/ chimaera-proposed-updates main contrib non-free 

The important point being that it is using devuan rather than merged, which does follow the advice in :-

https://www.devuan.org/os/packages

but I thought that I should check that it really should be devuan rather than merged.

Offline

#6 2022-10-21 06:55:13

Geoff 42
Member
Registered: 2016-12-15
Posts: 425  

Re: [SOLVED] libc6 bug fix has not reached chimaera-proposed-updates

Indeed, if I change devuan for merged in sources.list, then following an update, I can see libc6 with version u5.

I presume that it is safe to proceed with that and that there is an error on the web page :-

https://www.devuan.org/os/packages

Geoff

Last edited by Geoff 42 (2022-10-21 06:57:52)

Offline

#7 2022-10-21 07:16:33

Geoff 42
Member
Registered: 2016-12-15
Posts: 425  

Re: [SOLVED] libc6 bug fix has not reached chimaera-proposed-updates

I have now upgraded my system and it seemed to go smoothly.

Geoff

Offline

#8 2022-10-21 07:21:24

Geoff 42
Member
Registered: 2016-12-15
Posts: 425  

Re: [SOLVED] libc6 bug fix has not reached chimaera-proposed-updates

And I have been able to reboot successfully.

Geoff

Offline

#9 2022-10-21 11:19:12

alexkemp
Member
Registered: 2018-05-14
Posts: 74  

Re: [SOLVED] libc6 bug fix has not reached chimaera-proposed-updates

Hi Geoff 42

It must be some other feature of your system that is preventing install of that version. I have the precise same sources.list as you, yet and have the 2.31-13+deb11u4 version for libc6 (note that my system is AMD, not intel):

$ sudo apt-cache policy
(snip)
500 http://deb.devuan.org/devuan chimaera-proposed-updates/main amd64 Packages
     release v=4.0.0,o=Devuan,a=chimaera-proposed-updates,n=chimaera-proposed-updates,l=Devuan,c=main,b=amd64
     origin deb.devuan.org
(snip)
$ apt search libc6 | head -n 3

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Sorting...
Full Text Search...
libc6/stable,now 2.31-13+deb11u4 amd64 [installed]

PS
I also wondered why that single line was different to all others in the wiki!

(update)
Realising that I made an error (the update you are talking of is 2.31-13+deb11u5, not u4) I changed the proposed-updates line to match all others, then re-ran the apt update that had already been ran 5 minutes before. The results were startling:

$ ~/.update
Hit:1 http://deb.devuan.org/merged chimaera InRelease
Hit:2 http://deb.devuan.org/merged chimaera-security InRelease
Hit:3 http://deb.devuan.org/merged chimaera-updates InRelease
Hit:4 https://josm.openstreetmap.de/apt alldist InRelease
Get:5 http://deb.devuan.org/merged chimaera-proposed-updates InRelease [26.6 kB]
Hit:6 http://deb.devuan.org/merged chimaera-backports InRelease
Get:7 http://deb.devuan.org/merged chimaera-proposed-updates/main amd64 Packages [70.3 kB]
Get:8 http://deb.devuan.org/merged chimaera-proposed-updates/main Translation-en [38.4 kB]
Get:9 http://deb.devuan.org/merged chimaera-proposed-updates/non-free Translation-en [10.9 kB]
Get:10 http://deb.devuan.org/merged chimaera-proposed-updates/contrib Translation-en [499 B]
Fetched 147 kB in 2s (94.0 kB/s)                          
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
10 packages can be upgraded. Run 'apt list --upgradable' to see them.
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 10 not upgraded.
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  libbluray2 libc-bin libc-dev-bin libc-l10n libc6 libc6-dev libc6-i386 locales shim-helpers-amd64-signed shim-unsigned
10 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
(snip)
$ apt search libc6 | head -n 3

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Sorting...
Full Text Search...
libc6/stable-proposed-updates,now 2.31-13+deb11u5 amd64 [installed]

Wow! I've been missing out on a lot of updates. Thanks.

Last edited by alexkemp (2022-10-21 11:40:25)

Offline

#10 2022-10-21 19:18:35

fsmithred
Administrator
Registered: 2016-11-25
Posts: 2,152  

Re: [SOLVED] libc6 bug fix has not reached chimaera-proposed-updates

I think the instructions on the website were written before *-proposed-updates were merged with debian. When I added it to sources.list recently, I forgot about the advice to use /devuan and I made it /merged like all the others. It seems to be working, but there is a potential problem.

*-proposed-updates is a place to put updates that may need additional testing. I think maybe it should have a lower priority so those packages don't get installed automatically.

Edit: We will most likely continue doing it the same way as debian.
https://wiki.debian.org/StableProposedUpdates

Offline

#11 2022-10-22 10:24:02

Geoff 42
Member
Registered: 2016-12-15
Posts: 425  

Re: [SOLVED] libc6 bug fix has not reached chimaera-proposed-updates

I now have proposed-updates enabled and have set its priority to 100, so that it will not pull in stuff from there without being told to!

My sources.list looks like this :-

cd /etc/apt
grep -v '#' sources.list | grep -v '^$'

deb http://deb.devuan.org/merged/ chimaera non-free contrib main
deb http://deb.devuan.org/merged/ chimaera-security non-free contrib main
deb http://deb.devuan.org/merged/ chimaera-updates non-free contrib main
deb http://deb.devuan.org/merged/ chimaera-proposed-updates non-free contrib main

cat preferences.d/99devuan-proposed-updates 

Package: *
Pin:  release o=Devuan, n=chimaera-proposed-updates
Pin-Priority: 100

apt policy libc6

libc6:
  Installed: 2.31-13+deb11u5
  Candidate: 2.31-13+deb11u5
  Version table:
*** 2.31-13+deb11u5 100
        100 http://deb.devuan.org/merged chimaera-proposed-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     2.31-13+deb11u4 500
        500 http://deb.devuan.org/merged chimaera/main amd64 Packages

I think that it is set up correctly and that I could, similarly, add in backports with a priority of 100.

Geoff

Offline

#12 2022-10-22 17:47:38

fsmithred
Administrator
Registered: 2016-11-25
Posts: 2,152  

Re: [SOLVED] libc6 bug fix has not reached chimaera-proposed-updates

You have:

Package: *
Pin:  release o=Devuan, n=chimaera-proposed-updates
Pin-Priority: 100

I have:

Package: *
Pin: release a=chimaera-proposed-updates
Pin-Priority: 100

Check to make sure n= works. I think I changed to a= because that was the only way it worked, but I could be wrong.

Also, using /merged and o=Devuan might mean you won't get proposed updates from Devuan unless you specify proposed-updates, but you will get them from Debian. I'm not sure. You might need to either switch /merged to /devuan or remove the o=Devuan.

Edit: I tested both ways. n=chimaera-proposed-updates is correct, and a=chimaera-proposed-updates does not change the priority.

Offline

#13 2022-10-23 14:35:11

Geoff 42
Member
Registered: 2016-12-15
Posts: 425  

Re: [SOLVED] libc6 bug fix has not reached chimaera-proposed-updates

I have now tried your version with :-

Package: *
Pin:  release a=chimaera-proposed-updates
Pin-Priority: 100

and it does not change the priority :-

apt policy libc6

libc6:
  Installed: 2.31-13+deb11u5
  Candidate: 2.31-13+deb11u5
  Version table:
*** 2.31-13+deb11u5 500
        500 http://deb.devuan.org/merged chimaera-proposed-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     2.31-13+deb11u4 500
        500 http://deb.devuan.org/merged chimaera/main amd64 Packages

while :-

Package: *
Pin:  release n=chimaera-proposed-updates
Pin-Priority: 100

does change the priority :-

apt policy libc6

libc6:
  Installed: 2.31-13+deb11u5
  Candidate: 2.31-13+deb11u5
  Version table:
*** 2.31-13+deb11u5 100
        100 http://deb.devuan.org/merged chimaera-proposed-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     2.31-13+deb11u4 500
        500 http://deb.devuan.org/merged chimaera/main amd64 Packages

My original version also included o=Devuan which also worked, as above.
I originally used n= rather than a= as the output from apt policy gave this :-

...
100 http://deb.devuan.org/merged chimaera-proposed-updates/main amd64 Packages
     release v=4.0.0,o=Devuan,a=stable-proposed-updates,n=chimaera-proposed-updates,l=Devuan,c=main,b=amd64
     origin deb.devuan.org
...

and I wanted to use chimaera rather than stable, which generally seems to be the recommended approach.

Offline

#14 2022-10-27 13:48:02

Geoff 42
Member
Registered: 2016-12-15
Posts: 425  

Re: [SOLVED] libc6 bug fix has not reached chimaera-proposed-updates

It would appear that libc6 version 2.31-13+deb11u5 has now reached chimaera-updates.

apt policy libc6

libc6:
  Installed: 2.31-13+deb11u5
  Candidate: 2.31-13+deb11u5
  Version table:
*** 2.31-13+deb11u5 500
        500 http://deb.devuan.org/merged chimaera-updates/main amd64 Packages
        100 http://deb.devuan.org/merged chimaera-proposed-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     2.31-13+deb11u4 500
        500 http://deb.devuan.org/merged chimaera/main amd64 Packages

hence solving the original query.

Geoff

Offline

Board footer