The officially official Devuan Forum!

You are not logged in.

#1 2021-04-25 00:29:22

nevderd
Member
Registered: 2021-04-25
Posts: 3  

Raspberry Pi 3B+ (Arm-64 image) boots but no GUI after setup

Hello all,

Sorry for being such a n00b but it's been a minute since I've done any Linux sysadminning and a lot has changed in the interim.

I've successfully booted beowulf 3.1 (arm-64) on an rpi-3b+ (kudos to the team for getting these builds, thank you so much!), gone through the run-setup tidbit, and have rebooted the system but no graphical login or gui comes up. `startx` is not found in the `pi` (default) user path, and I'm just a little bit at a loss here, though I'm sure I'm just forgetting some ordinary incantation or haven't done some setup step that I overlooked in the multitude of readme's along the way.

Can anybody get me a pointer to how to get the system booting with a (very light - cde-light) x display manager and graphical login?

Offline

#2 2021-04-25 01:37:09

tuxd3v
Member
Registered: 2019-11-14
Posts: 168  

Re: Raspberry Pi 3B+ (Arm-64 image) boots but no GUI after setup

hello nevderd,
The Images as far as I know come with no X, so that the user can choose what he wants smile

Perhaps the easy way would be to use tasksel?

bootup, login, then switch to root, and run:

tasksel

Chose the environment, you want, from the available ones, reboot, and you should be ok smile


Best Regards,
tux

Offline

#3 2021-04-25 02:07:59

nevderd
Member
Registered: 2021-04-25
Posts: 3  

Re: Raspberry Pi 3B+ (Arm-64 image) boots but no GUI after setup

Hi tux,

Thanks for the prompt response. I'll give that a shot - I've got a long-winded compilation task running right now (CDE) but in another session I tried running tasksel as root and got the cryptic `debconf failed to run`. I checked the --list-tasks option and it lists a few window managers that I could install - I'll try to setup lxqt, I suppose. Is this just a shortcut to apt-getting the task package or is there more magic to it than that?

Offline

#4 2021-04-25 02:35:25

nevderd
Member
Registered: 2021-04-25
Posts: 3  

Re: Raspberry Pi 3B+ (Arm-64 image) boots but no GUI after setup

Ah, I fixed it by running the /usr/share/debconf/fix_db.pl. Cheers!

Offline

#5 2021-04-27 08:32:37

zen253230
Member
Registered: 2021-04-26
Posts: 4  

Re: Raspberry Pi 3B+ (Arm-64 image) boots but no GUI after setup

Hello !
I'd like to benefit from your expertise.

I've not yet tried the way you described tux but I will

I tried before to install xfce4 by apt-get install
Then I stumbled on this error :
error ensuring dpkg/reassemble.deb doesn't exist. read only file system
Then it shows Ext4-fs error on and on.
Is it because of my SD Card? Very recently I could install last Ubuntu Mate on the same Raspberry without any problem.
Thank you in advance !

EDIT: I had the same error using tasksel while unpacking libsane-common.
It says apt-get failed (100).
It would look like a SD-Card failure but Ubuntu Mate I reinstalled functions perfectly
[screenshot ][https://i.postimg.cc/LsdT7VLn/Screensho … allery.jpg]

Last edited by zen253230 (2021-04-27 13:43:55)

Offline

#6 2021-04-27 19:46:44

tuxd3v
Member
Registered: 2019-11-14
Posts: 168  

Re: Raspberry Pi 3B+ (Arm-64 image) boots but no GUI after setup

zen253230 wrote:

Hello !
Then it shows Ext4-fs error on and on.
Is it because of my SD Card? Very recently I could install last Ubuntu Mate on the same Raspberry without any problem.
Thank you in advance !

EDIT: I had the same error using tasksel while unpacking libsane-common.
It says apt-get failed (100).
It would look like a SD-Card failure but Ubuntu Mate I reinstalled functions perfectly
[screenshot ][https://i.postimg.cc/LsdT7VLn/Screensho … allery.jpg]

hello zen253230,
yeah.. it seems your sdcard has bad sectors already sad

When you hit those zones, this errors appear..

Insert the sdcard into your main computer and run:

fsck /dev/your_sdcard

But I suspect that you already have bad sectors sad


Best Regards,
tux

Offline

Board footer