The officially official Devuan Forum!

You are not logged in.

#1 Re: Installation » ASCII package installation » 2021-03-02 19:54:25

Thank you both;
I have no issues with running NetBeans. It work on all projects I checked out, but I had to use external tool for repository management; which is far from elegant. Only feature I used not working is SVN CLI tools integration; it seems that NetBeans has hard coded versions because it recognizes 1.9.* and cannot recognize 1.10.* and claims it wants 1.5.* or newer. I tried to configure javahl, and svn but it does not work as well.

I am not fan of breaking system, prefer distro as is; far more people is involved in QA. I will try to build binaries and localize them to directory, if there are not endless dependencies.
C++ support for NetBeans is questionable, so it may be worth considering scrapping it and looking for something else; till then keep ASCII and enjoy while it works.

Thank you anyway.

#2 Installation » ASCII package installation » 2021-03-02 14:05:51

Replies: 3

Hello everyone,

I need subversion 1.9.* because NetBeans does not work with version 1.10.*. I have work station with ASCII installed and subversion 1.9.* works nice with NetBeans 8.2. C++ bundle.

Afer I installed Beowulf 3.1; NetBeans have weird errors; it claims it requires subversion 1.5 or higher which is nonsesne. Only difference I can spot is subversion release; so I would like to install 1.9.* from ASCII release. How to do that?
Any other ideas are welcome as well but please no javahl and svnkit; they also causes more problems then they are worth.

Thank you,

#3 Re: Installation » libssl-dev installation problem » 2018-07-26 08:39:09


It did work after I updated sources according to document and added security.
Will align code console output posts as requested. Thx for notification.


#4 Installation » libssl-dev installation problem » 2018-07-25 15:25:43

Replies: 2

Hi folks,
I'm trying to install libssl-dev and apt complains about broken dependency.

root@fermi:~# apt-get install libssl-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libssl-dev : Depends: zlib1g-dev but it is not installable
              Recommends: libssl-doc but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Any idea how to fix it?

My /etc/apt/sources.list contains only:

deb [url][/url] jessie-security main non-free
deb-src [url][/url] jessie-security main non-free

PS: I am actually trying to build stunnel-5.48 and it fails for TLS directory check; based on other systems where it passed it seems I have problem with headers and libs for openssl.


Board footer

Forum Software