The officially official Devuan Forum!

You are not logged in.

#1 2018-02-24 06:24:08

xD
Member
From: Cloud 9 ✾(〜 ☌ω☌)〜✾
Registered: 2017-11-29
Posts: 12  
Website

Intel HD Audio Is Not Working (Ceres)

Hello!

I know that issues like this tend to come along with running from unstable branches of anything, but I recently have noticed that my audio is no longer working. It was previously working and I haven't changed anything about my system, save for installing Steam. But most of Steam's dependencies are nVidia driver related. I am running Devuan Ceres amd64 on a Lenovo ThinkPad T420s 417429U. I have Intel HD Audio (I think) and the most relevant information I can find from lspci is
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series
Chipset Family High Definition Audio Controller (rev 04)

Binging this issue doesn't seem to provide me with information in the way of modules, and I cannot find anything on the De**an forums that are of any help; in fact, I haven't been able to find this issue at all! So I'm either looking in the wrong place or I'm just dumb. tongue

Anyways, has anyone experienced this issue before, or does anyone know a solution?

Thanks!!

P.S., when I click the mute button on the physical keyboard, it no longer lights up to indicate ataraxy as it does in Windows 10. I know that the system isn't malfunctioning because when I boot into Windows 10 the audio works just fine.

Last edited by xD (2018-03-04 21:05:05)


mmm mmmmm! (◡‿◡✿)

Offline

#2 2018-03-04 21:04:21

xD
Member
From: Cloud 9 ✾(〜 ☌ω☌)〜✾
Registered: 2017-11-29
Posts: 12  
Website

Re: Intel HD Audio Is Not Working (Ceres)

Solution to anyone experiencing a similar issue:

Apparently the issue lies within pulseaudio. For some reason, it isn't starting with the system as it should! I will have to further investigate this issue to determine why, but a dirty and quick way to fix this is to simply reinstall the package pulseaudio and to tell it to start with the system by preforming performing the steps as follows.

su
apt-get remove pulseaudio
apt-get install pulseaudio
exit
cd ~/
echo pulseaudio --start >> .profile

And to confirm that these steps worked:

sudo reboot
Wait for the system to reboot
cd ~/
cat .profile

And make sure that pulseaudio --start is at the end of the output displayed!


I do not endorse my solution; it is kinda messy and doesn't really solve the issue... it kinda just moves it somewhere else. But, for me it works because I backup all of my important files regularly and I don't mind reinstalling my system should something go wrong.
Also, my audio keys still aren't working, but at least I have audio!!

Should I find a solution for that, I will document it! smile


mmm mmmmm! (◡‿◡✿)

Offline

#3 2018-03-05 21:59:25

greenjeans
Member
Registered: 2017-04-07
Posts: 424  
Website

Re: Intel HD Audio Is Not Working (Ceres)

Or delete pulseaudio completely and use ALSA. wink


https://sourceforge.net/projects/vuu-do/
Vuu-do GNU/Linux, minimal 64 and 32 bit Devuan-based openbox and mate systems to build on, maximal versions if you prefer your linux fully-loaded.

Please donate to support Devuan and init freedom! https://devuan.org/os/donate

Offline

#4 2018-03-06 10:48:50

Geoff 42
Member
Registered: 2016-12-15
Posts: 187  

Re: Intel HD Audio Is Not Working (Ceres)

Yes, a lot of people would stop after the apt-get remove pulseaudio ;-)

It seems that many machines these days have an HDMI sound outlet, which is often shared with a normal outlet, using the snd-hda-intel kernel module. This seems to cause problems. If you don't need the HDMI sound then disabling it makes things simpler, using the enable option :-

http://forums.debian.net/viewtopic.php?t=110572#p525601

Geoff

Offline

#5 2018-03-06 20:46:39

greenjeans
Member
Registered: 2017-04-07
Posts: 424  
Website

Re: Intel HD Audio Is Not Working (Ceres)

You can do that in alsa as well, I see it fairly often as a lot of machines have an hdmi output in addition to the regular one and alsa defaults to using card 0 which is usually the HDMI output, simple solution is adding an .asoundrc file in your home folder:

pcm.!default {
        type hw
        card 1
 }

ctl.!default {
        type hw
        card 1
 }

(Note: I know you solved your problem, i'm just posting this additional info for other folks who might be looking for solutions and read this thread)

Geoff 42 wrote:

Yes, a lot of people would stop after the apt-get remove pulseaudio ;-)

It seems that many machines these days have an HDMI sound outlet, which is often shared with a normal outlet, using the snd-hda-intel kernel module. This seems to cause problems. If you don't need the HDMI sound then disabling it makes things simpler, using the enable option :-

http://forums.debian.net/viewtopic.php?t=110572#p525601

Geoff


https://sourceforge.net/projects/vuu-do/
Vuu-do GNU/Linux, minimal 64 and 32 bit Devuan-based openbox and mate systems to build on, maximal versions if you prefer your linux fully-loaded.

Please donate to support Devuan and init freedom! https://devuan.org/os/donate

Offline

#6 2018-10-02 03:07:53

bgstack15
Member
Registered: 2018-02-04
Posts: 3  

Re: Intel HD Audio Is Not Working (Ceres)

Thank you for sharing your solution. I was going to work on a .desktop file in the xdg startup location, and found that there was already a pulseaudio.desktop file there!

So I altered my Exec= line in /etc/xdg/autostart/pulseaudio.desktop:

Exec=pulseaudio --start

And that makes my audio work!

Offline

#7 2018-10-02 03:31:37

golinux
Administrator
Registered: 2016-11-25
Posts: 1,307  

Re: Intel HD Audio Is Not Working (Ceres)

But . . . but . . . but . . . it's pulseaudio . . . yikes

Offline

Board footer