The officially official Devuan Forum!

You are not logged in.

#1 2017-12-02 15:32:05

MiyoLinux
Member
Registered: 2016-12-05
Posts: 309

Tried an upgrade to Ascii today, and got this message...

This was from a Jessie netinstall of only the base system, changed the sources.list to "pkgmaster" and ascii, then tried an  update and dist-upgrade...

WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what your are doing!
     e2fsprogs util-linux (due to e2fsprogs) init sysvinit-core (due to init)
     sysvinit-utils initscripts (due to util-linux)
204 upgraded, 106 newly installed, 18 to remove and 0 not upgraded.
Need to get 91.9 MB of archives.
After this operation, 103 MB disk space will be freed.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'
?]

Think I'll hold off... tongue

Last edited by MiyoLinux (2017-12-02 17:59:45)


I have been Devuanated, and my practice in the art of Devuanism shall continue until my Devuanization is complete. Until then, I will strive to continue in my understanding of Devuanchology, Devuanprocity, and Devuanivity.

Veni, vidi, vici vdevuaned. I came, I saw, I Devuaned. wink

Offline

#2 2017-12-02 15:43:44

golinux
Administrator
Registered: 2016-11-25
Posts: 684

Re: Tried an upgrade to Ascii today, and got this message...

There are long standing issues with util-linux.  Though I'm not quite sure what they are, this package is a major roadblock to the release of ascii.  Hopefully will be rectified before or  during the ascii sprint coming in mid-December.

Offline

#3 2017-12-02 16:02:44

MiyoLinux
Member
Registered: 2016-12-05
Posts: 309

Re: Tried an upgrade to Ascii today, and got this message...

Thank you ma'am.

I was hoping it might help someone who was considering to try an upgrade.

Out of curiosity, I tried an upgrade on an already existing Ascii, and I got this...

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  bc gpsd jq libbluetooth3 libgps22 libgrits5 libhdf4-0 libjq1 libonig4
  librsl1
Use 'sudo apt autoremove' to remove them.
The following packages have been kept back:
  initscripts sysvinit-utils
The following packages will be upgraded:
  curl exim4-base exim4-config exim4-daemon-light ffmpeg libavcodec57
  libavdevice57 libavfilter6 libavformat57 libavresample3 libavutil55 libcurl3
  libcurl3-gnutls libpostproc54 libswresample2 libswscale4 sysv-rc sysvinit
  sysvinit-core

So things are still safe for exisiting installations. That warning in my opening post just happened today (I assume); I did an upgrade from Jessie to Ascii yesterday, and it went fine.


I have been Devuanated, and my practice in the art of Devuanism shall continue until my Devuanization is complete. Until then, I will strive to continue in my understanding of Devuanchology, Devuanprocity, and Devuanivity.

Veni, vidi, vici vdevuaned. I came, I saw, I Devuaned. wink

Offline

#4 2017-12-02 16:24:51

golinux
Administrator
Registered: 2016-11-25
Posts: 684

Re: Tried an upgrade to Ascii today, and got this message...

Good timing . . . there has been util-linux activity on https://ci.devuan.org/ this morning.  Some build success but a ways to go.

Offline

#5 2017-12-02 18:00:21

MiyoLinux
Member
Registered: 2016-12-05
Posts: 309

Re: Tried an upgrade to Ascii today, and got this message...

I edited the OP to give a little more information...


I have been Devuanated, and my practice in the art of Devuanism shall continue until my Devuanization is complete. Until then, I will strive to continue in my understanding of Devuanchology, Devuanprocity, and Devuanivity.

Veni, vidi, vici vdevuaned. I came, I saw, I Devuaned. wink

Offline

Board footer