The officially official Devuan Forum!

You are not logged in.

#1 2017-09-06 14:46:56

shwsh
Member
Registered: 2017-09-06
Posts: 2

Installing GNOME on Devuan Ceres

As you all gnow, GNOME, the pinnacle of desktop GUI design, is not available on Devuan. I've packaged elogind and gnome-settings-daemon, allowing you to install the GNOME core packages, minus the display manager.

Screenshot
screenshot

Step 1: install elogind

Go to the elogind package releases, and get the package according to your architecture. Then, open a terminal, and,

sudo apt install ./elogind_234-2.1_i386.deb

where i386 is your architecture.

If the service didn't start, start elogind by typing

sudo service elogind start

Step 2: install gnome-settings-daemon

Alternative solution for step 2

Go to the gnome-settings-daemon package releases, and get the package. Then, type in:

sudo apt install ./gnome-settings-daemon_3.24.3-1_i386.deb

where i386 is your architecture.

Step 3: install gnome-shell

sudo apt install gnome-shell

If you can log out, and log back in with the gnome session, you're gold. You can now install the rest of the GNOME apps.

Compiling elogind and gnome-settings-daemon yourself

To build these packages, you first need to:

sudo apt install git dpkg-dev build-essential

Compiling elogind

- Get build dependencies:

sudo apt install build-essential debhelper libudev-dev pkg-config docbook-xsl xsltproc automake autoconf libtool intltool gperf gtk-doc-tools intltool libcap-dev

- Get linux headers

sudo apt install linux-headers-$(uname -r)

- Build

mkdir elogind-tmp && cd elogind-tmp
git clone https://github.com/shwsh/elogind/
cd elogind
git checkout v234-stable
dpkg-buildpackage -uc -us

You may need to set the environment variable DEB_BUILD_OPTIONS=nocheck before the dpkg-buildpackage command because there's one test that keeps failing if elogind is already running.

deb packages will appear in the elogind-tmp dir and you may install them with apt.

Make sure you also install libelogind-dev for building gnome-settings-daemon.

Compiling gnome-settings-daemon

- Get build dependencies:

Insert a deb-src repository into your sources.list, i.e.

deb-src http://auto.mirror.devuan.org/merged ceres          main

, then

sudo apt update
sudo apt build-dep gnome-settings-daemon

gnome-settings-daemon requires libupower-glib-dev (>= 0.99.0), however that's not currently in Devuan's repository, so add this to your /etc/apt/sources.list

deb  http://ftp.tw.debian.org/debian         stretch         main

(Replace ftp.tw.debian.org with the fastest debian mirror)

Then,

sudo apt remove --auto-remove libupower-glib-dev
sudo apt install -t stretch libupower-glib-dev

Remove the last line you've added from /etc/apt/sources.list.

- Build

mkdir gsd-tmp && cd gsd-tmp
git clone https://github.com/shwsh/gnome-settings-daemon/
cd gnome-settings-daemon
git checkout gnome-3-24
dpkg-buildpackage -uc -us

deb packages should appear, and you may install them.

Issues

  • gdm3 doesn't run, and will probably never be packaged :(

  • network-manager-gnome won't install, as NetworkManager is a systemd thing

Fixing gnome-session exiting on startup

Fixing GNOME Tweak Tool

If you enter 'gnome-tweak-tool' on the command line, and it complains about complains about missing key 'disable-user-extensions', edit /usr/share/glib-2.0/schemas/org.gnome.shell.gschema.xml. Add these lines after the first "schema" tag:

    <key name="disable-user-extensions" type="b">
      <default>false</default>
      <summary>
      </summary>
      <description>
      </description>
    </key>

Save and quit your text editor, then compile the glib schema:

sudo glib-compile-schemas /usr/share/glib-2.0/schemas/org.gnome.shell.gschema.xml

After that, GNOME Tweak Tool should work.

GNOME Disks can't be installed

GNOME Disks version 3.25 in the Ceres repository requires udisks (version >= 2.7.2), however that's not in the Devuan repo. So, GNOME Disks must be installed with the ascii version. Add this to your sources.list:

deb http://auto.mirror.devuan.org/merged     ascii          main

, then:

sudo apt update
sudo apt install -t ascii gnome-disk-utility

gnome-color-manager can't be installed

First, install colord:

sudo apt update
sudo apt install colord

Add this to your sources.list:

deb http://auto.mirror.devuan.org/merged     jessie          main

, then:

sudo apt update
sudo apt install -t jessie gnome-color-manager

Last edited by shwsh (2017-09-19 13:21:05)

Offline

#2 2017-09-06 15:46:46

golinux
Administrator
Registered: 2016-11-25
Posts: 551

Re: Installing GNOME on Devuan Ceres

shwsh wrote:

As you all gnow, GNOME, the pinnacle of desktop GUI design . . .

All these years, I thought it was the default that was shoved down clueless user's throats.  wink  But to each his own  In any case, this is a useful contribution for those who want to go there so thank you for that.

*edit*  Maybe you could copy everything from your personal repo to git.devuan.org.  That way things could get packaged for devuan.

Online

#3 2017-09-06 18:41:36

fungus
Member
From: Any witch way
Registered: 2017-07-12
Posts: 262
Website

Re: Installing GNOME on Devuan Ceres

I once clicked on the wrong file, years and years ago, I think it was Jessie 8.2, and ended up with a live image with gnome.  It took about 10' and I shut it down, erased and downloaded something else.

Another time I tried Cinnamon just to see what all the hoopla was about.  It lasted a day and a half.  I've never seen so many hits and misses on a linux desktop, things crashing, things locking up, ever before.  Even windows vista was more stable than this thing.

With MATE and KDE, I could possibly live with but I don't like the way the work, but they do work.

LXQT is borderline as flaky as Gnome, it is like a gnome-tized LXDE.  I'll try it again in a few years or whenever lxde becomes obsolete.

But gnome the pinnacle, never again.  I'd rather not have a desktop at all.

Last edited by fungus (2017-09-06 18:42:53)

Offline

#4 2017-09-06 19:11:56

fsmithred
Administrator
Registered: 2016-11-25
Posts: 377

Re: Installing GNOME on Devuan Ceres

shwsh, did you do this on jessie, ascii or ceres?  3.24.3-1 is in buster/sid.

Offline

#5 2017-09-06 19:14:34

golinux
Administrator
Registered: 2016-11-25
Posts: 551

Re: Installing GNOME on Devuan Ceres

fsmithred wrote:

shwsh, did you do this on jessie, ascii or ceres?  3.24.3-1 is in buster/sid.

Info in the image's terminal says ceres

Online

#6 2017-09-07 20:26:25

greenjeans
Member
Registered: 2017-04-07
Posts: 278
Website

Re: Installing GNOME on Devuan Ceres

shwsh wrote:

As you all gnow, GNOME, the pinnacle of desktop GUI design,

LOLOLOLOL!!!

Nice! I literally LOL'ed out loud, people are looking at me funny in the coffeeshop. wink

Seriously though, nice work getting the bad tablet/phone-wannabe-interface to actually kinda work for a change, I gotta say that takes some serious skills, kudos!


https://sourceforge.net/projects/vuu-do/
Vuu-do GNU/Linux, minimal 64 and 32 bit Devuan-based openbox and mate systems to build on, maximal versions if you prefer your linux fully-loaded.

Refracta and Miyolinux had too many tequila shots one night...    ....9 months later a vuu-do chile was born.....;-)

Offline

#7 2017-09-19 12:27:50

shwsh
Member
Registered: 2017-09-06
Posts: 2

Re: Installing GNOME on Devuan Ceres

Fixing gnome-session exiting on startup

Sorry for the long delay there, but I've found a way to fix gnome-session crashing on startup. First, open a terminal or a root text editor, then paste this script:

#!/bin/bash
gnome-shell &
sleep 0.1
cd /usr/lib/gnome-settings-daemon
for i in *; do
    /usr/lib/gnome-settings-daemon/$i &
done
[ -x "$(which fbautostart)" ] && fbautostart
while [ 1 ]; do sleep 999d; done

And save it as /usr/local/bin/gnome-session. Change the file's attributes with:

sudo chmod 0755 /usr/local/bin/gnome-session

This will create a sort-of "shim" that will not exit if one of the gnome-settings-daemon applications fail to load.

If you want to autostart applications in your ~/.config/autostart directory, simply run:

sudo apt install fbautostart

And the script will autostart applications when the shell is loaded.

GNOME components fails to load due to XDG_RUNTIME_DIR

If GNOME components fails to load, and it says something like "XDG_RUNTIME_DIR not set in the environment", make an .xprofile file in your home directory if it doesn't exist, and add this:

#!/bin/bash

if [ "x$XDG_RUNTIME_DIR" = "x" ]; then
    export XDG_RUNTIME_DIR=/tmp/${UID}-runtime-dir
    if [ -d "$XDG_RUNTIME_DIR" ]; then
        mkdir -p "$XDG_RUNTIME_DIR"
        chmod 0700 "$XDG_RUNTIME_DIR"
    fi
fi

And chmod +x it, logout and log back in.

Script to auto-update gnome-settings-daemon

Sometimes, you're too lazy to get of your fat ass and compile a package and upload it to github. Luckily for you, you've made a script which will update an important GNOME component. This script will pull the gnome-settings-daemon package from the Devuan repository, strip the systemd part out of it, and install it.

#!/bin/bash
TIME="$(date +%s)"
mkdir /tmp/gsd-$TIME
apt download gnome-settings-daemon
NAME="$(find ./gnome-settings-daemon*.deb)"
ar x $NAME
tar xzf control.tar.gz
sed -i "s/libpam-systemd/elogind/g" control
tar c {post,pre}{inst,rm} md5sums control conffiles | gzip -c > control.tar.gz
ar rcs newpackage.deb debian-binary control.tar.gz data.tar.*
sudo apt install ./newpackage.deb
rm -rf /tmp/gsd-$TIME

Save it as update-gnome-settings-daemon.sh or something, chmod +x the file and run it to update/install the daemon.

Happy GNOMEing!

Last edited by shwsh (2017-09-19 13:20:19)

Offline

Board footer