The officially official Devuan Forum!

You are not logged in.

#1 2017-08-02 02:24:36

mtbvfr
Member
Registered: 2017-07-29
Posts: 21

Volume Up, Volume Down and Mute keys not working

Hi Folks,

Just doing some further testing before installing and I noticed that the Volume Up, Volume Down and Mute keys are not working.

When I press the Volume Up or Volume Down keys, the Volume Level Indicator appears at the top right of the display and the level bar increases or decreases but the Sound level is not affected.

Did some searching on the web but not sure what I should do (e.g. Adding commands to the Application Shortcuts tab of the Keyboard app).

xfce4-volumed is running.

Some further info; Task Manager indicates the following programs are running.

gvfs-udisks2-volume-monitor
pulseaudio --start
start-pulseaudio-x11

Whether or not they are associated with the problem I can't say but it may give someone else some clues as to what the solution may be.

xfce4-mixer is installed but not running but is the Command associated with the Desktop Configuration file for the application named as Audio Mixer.

Thanks, MTB.

Last edited by mtbvfr (2017-08-02 22:58:40)

Offline

#2 2017-08-02 13:23:53

fungus
Member
From: Any witch way
Registered: 2017-07-12
Posts: 263
Website

Re: Volume Up, Volume Down and Mute keys not working

On mine after an update 2 hours ago it says python-pygame pkg missing, can not play sound.
But volume works.  This is on desktop pc AMD65 running ceres

Offline

#3 2017-08-03 09:37:37

FOSSuser
Member
From: Surrey/Hants border UK
Registered: 2016-12-11
Posts: 149

Re: Volume Up, Volume Down and Mute keys not working

I believe pulseaudio uses pavcontrol to adjust sound levels

Offline

#4 2017-08-05 01:03:46

mtbvfr
Member
Registered: 2017-07-29
Posts: 21

Re: Volume Up, Volume Down and Mute keys not working

It appears that xfce4-volumed may be the likely culprit.

If I add the following, to the Application Shortcuts tab of the Keyboard configuration app, the keys function correctly but the Volume Level Indicator does not appear at the top right of the display.

amixer sset Master 5%+     XF86AudioRaiseVolume
amixer sset Master 5%-     XF86AudioLowerVolume
amixer sset Master toggle  XF86AudioMute

There are packages preinstalled for both ALSA and Pulse Audio.

Given that Pulse Audio was created by the same Rat responsible for systemd (vomit), should not we be using an ALSA based system for the management of Sound and associated devices?

Should I file a Bug report for this at https://bugs.devuan.org/ ?

I've installed Devuan Jessie to a Hard Drive partition and this fault exists in the installed environment also.

Thanks, MTB.

Last edited by mtbvfr (2017-08-05 01:31:03)

Offline

#5 2017-08-06 01:18:41

garyz.dev1
Member
Registered: 2017-06-15
Posts: 78

Re: Volume Up, Volume Down and Mute keys not working

Is xfce4-volumed updated to a devuan package or is it a debian package?

Offline

#6 2017-08-06 01:34:55

golinux
Administrator
Registered: 2016-11-25
Posts: 551

Re: Volume Up, Volume Down and Mute keys not working

mtbvfr wrote:

Given that Pulse Audio was created by the same Rat responsible for systemd (vomit), should not we be using an ALSA based system for the management of Sound and associated devices?

This has been debated since the beginning of the fork.   Since newer versions of Firefox require PA, our choice is to capitulate or devise a rock solid way to use apulse instead.

Should I file a Bug report for this at https://bugs.devuan.org/ ?

Sure, please do.

Offline

#7 2017-08-07 10:56:25

fsmithred
Administrator
Registered: 2016-11-25
Posts: 378

Re: Volume Up, Volume Down and Mute keys not working

What happens if you just remove pulseaudio? Will you lose anything?

I have an old dell laptop with jessie installed. No pulseaudio, no xfce4-volumed. I use volumeicon-alsa to control the volume, and it has the same XF86Audio settings as your amixer. I can change the volume with the buttons and the indicator is visible on screen.

Offline

#8 2017-08-07 17:27:35

fungus
Member
From: Any witch way
Registered: 2017-07-12
Posts: 263
Website

Re: Volume Up, Volume Down and Mute keys not working

I removed pulseaudio pulseaudio-control and pavuvolume
I have sound on everything and alsa controls and mixer work
But that is my box, I've heard some that really need it.
Mozilla?  What is that?

Last edited by fungus (2017-08-07 17:27:53)

Offline

#9 2017-08-08 01:39:16

mtbvfr
Member
Registered: 2017-07-29
Posts: 21

Re: Volume Up, Volume Down and Mute keys not working

fungus wrote:

Mozilla?  What is that?

Which browser are you using?

Offline

#10 2017-08-08 02:19:52

mtbvfr
Member
Registered: 2017-07-29
Posts: 21

Re: Volume Up, Volume Down and Mute keys not working

garyz.dev1 wrote:

Is xfce4-volumed updated to a devuan package or is it a debian package?

Looks to be a debian pkg.

Maintainer: Debian Xfce Maintainers

Installed and Latest Available are the same.
0.1.13-5 (stable)

Offline

#11 2017-08-08 02:51:21

mtbvfr
Member
Registered: 2017-07-29
Posts: 21

Re: Volume Up, Volume Down and Mute keys not working

fsmithred wrote:

What happens if you just remove pulseaudio? Will you lose anything?

I have an old dell laptop with jessie installed. No pulseaudio, no xfce4-volumed. I use volumeicon-alsa to control the volume, and it has the same XF86Audio settings as your amixer. I can change the volume with the buttons and the indicator is visible on screen.

Are you saying that volumeicon-alsa has the same entries for amixer in the Application Shortcuts tab of the Keyboard app?

There are 5 packages installed for pulseaudio as follows.

libpulse0
libpulsedsp
pulseaudio
pulseaudio-module-x11
pulseaudio-utils

I'll remove the above and test.

If no luck with that, I'll then remove xfce4-volumed.

If still no luck, I'll install volumeicon-alsa.

I've just noticed that there is a package named libasound2-plugins installed. This package depends on libpulse0 and pulseaudio depends on libasound2-plugins.

I guess I'll try removing libasound2-plugins also but I'm just stabbing in the dark with this stuff.

What a maze?!

There is also an entry for PulseAudio Sound System in the Application Autostart tab of the Session and Startup app.

I'll try disabling that first to see what happens.

Last edited by mtbvfr (2017-08-08 03:01:36)

Offline

#12 2017-08-08 02:55:32

mtbvfr
Member
Registered: 2017-07-29
Posts: 21

Re: Volume Up, Volume Down and Mute keys not working

Another note of info for you all to consider is that I am using a HDMI connection from my Laptop to my monitor for Audiovisual purposes.

Offline

#13 2017-08-08 11:07:03

fsmithred
Administrator
Registered: 2016-11-25
Posts: 378

Re: Volume Up, Volume Down and Mute keys not working

To disable pulseaudio, you need to turn it off in the config file in /etc. I don't recall the details. I have done it, but I ended up removing pulseaudio instead.

Don't remove libasound or libpulse0. (If you try, you will figure out real quick that you can't remove them without losing everything that can play a sound.)

I right-clicked on the volume icon and selected Settings or Preferences and a window came up that had those settings.

Offline

Board footer