The officially official Devuan Forum!

You are not logged in.

#1 2021-03-24 19:53:27

berni51
Member
From: Middle of Germany
Registered: 2018-12-20
Posts: 53  
Website

[SOLVED] Unmet dependencies with minimal-live image

Hi there,
as I need a small & fast system for an older notebook I fetched the minimal-live image with Beowulf 3.1 and begun an installation onto a nvme ssd. Everything went fine, the system booted and I could install some applications (mc, joe, nmap, sc, lynx, alpine etc.)
Next I installed xorg and fluxbox - no problems, it worked perfect.

But then I tried to install the xorg apps I need:
pcmanfm, claws-mail. firefox-esr,tilix, geany, shotwell, bluefie andsh, filezilla and some more. All of these failed with unmet dependencies. Trying to install these unmet dependencies ended also in an unmet dependencies failure.

I tried to solve that issue with apt update, upgrade and full-upgrade without success.

OK, I've read the warnings in the minimal-live doc that unexpected things may happen. My question is: Is this an issue which I cannot solve when using minimal-live?

Hints are highly appreciated.

Regards
Berni

Last edited by berni51 (2021-03-24 19:54:48)


The good ol' days will not return, and the rocks might smelt and the sea may burn.

Offline

#2 2021-03-24 19:54:37

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,542  
Website

Re: [SOLVED] Unmet dependencies with minimal-live image

What are your sources?

apt policy

Black Lives Matter

Offline

#3 2021-03-24 20:55:50

berni51
Member
From: Middle of Germany
Registered: 2018-12-20
Posts: 53  
Website

Re: [SOLVED] Unmet dependencies with minimal-live image

Head_on_a_Stick wrote:

What are your sources?

apt policy

Here we are:

Paketdateien:
 100 /var/lib/dpkg/status
     release a=now
 500 http://deb.devuan.org/merged beowulf-security/main amd64 Packages
     release v=3.0.0,o=Devuan,a=stable-security,n=beowulf-security,l=Devuan-Security,c=main,b=amd64
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf-updates/main amd64 Packages
     release v=3.0.0,o=Devuan,a=stable-updates,n=beowulf-updates,l=Devuan,c=main,b=amd64
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf/non-free amd64 Packages
     release v=3.0,o=Devuan,a=stable,n=beowulf,l=Devuan,c=non-free,b=amd64
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf/contrib amd64 Packages
     release v=3.0,o=Devuan,a=stable,n=beowulf,l=Devuan,c=contrib,b=amd64
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf/main amd64 Packages
     release v=3.0,o=Devuan,a=stable,n=beowulf,l=Devuan,c=main,b=amd64
     origin deb.devuan.org
Mit Pinning verwaltete Pakete:

My the "v=3.0" cause the issue?

Last edited by berni51 (2021-03-24 21:09:46)


The good ol' days will not return, and the rocks might smelt and the sea may burn.

Offline

#4 2021-03-24 21:17:26

golinux
Administrator
Registered: 2016-11-25
Posts: 2,171  

Re: [SOLVED] Unmet dependencies with minimal-live image

There is also a netboot mini.iso that might work better for you. The minimal-live is a "full-featured, console-based recovery tool with a focus on accessibility for visually-impaired and blind users".  Perhaps that is why some of the xorg stuff is not cooperating.

Online

#5 2021-03-24 21:48:22

berni51
Member
From: Middle of Germany
Registered: 2018-12-20
Posts: 53  
Website

Re: [SOLVED] Unmet dependencies with minimal-live image

I think you are right, thx. Will use the netboot-mini instead.


The good ol' days will not return, and the rocks might smelt and the sea may burn.

Offline

#6 2021-03-25 06:57:02

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,542  
Website

Re: [SOLVED] Unmet dependencies with minimal-live image

Your sources look fine, can we see an example of the actual errors?

apt -s install firefox-esr

Black Lives Matter

Offline

#7 2021-03-25 09:51:49

berni51
Member
From: Middle of Germany
Registered: 2018-12-20
Posts: 53  
Website

Re: [SOLVED] Unmet dependencies with minimal-live image

root@akoya # apt -s install firefox-esr
Paketlisten werden gelesen...
Abhängigkeitsbaum wird aufgebaut....
Statusinformationen werden eingelesen....
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
firefox-esr : Hängt ab von: libgtk-3-0 (>= 3.0.0) soll aber nicht installiert werden

E: Das Problem kann nicht korrigiert werden. Sie haben zurückgehaltene Pakete.

Last edited by berni51 (2021-03-25 09:54:44)


The good ol' days will not return, and the rocks might smelt and the sea may burn.

Offline

#8 2021-03-25 11:16:28

fsmithred
Administrator
Registered: 2016-11-25
Posts: 1,840  

Re: [SOLVED] Unmet dependencies with minimal-live image

I found the problem in the minimal-live. The fix is:

apt update
apt remove librsvg2-2
apt install librsvg2-2

That will drop the version from 2.44.10-2.1+deb10u3 to 2.44.10-2.1. And then you can install firefox-esr and the other stuff.

The problem is that the build process pulled in librsvg2-2 from beowulf-proposed-updates, but then that repo was removed from sources.list. I'll have to make a new set of isos.

Berni, if your last post is after a netinstall, then there may be another problem, too.

Offline

#9 2021-03-25 13:51:46

berni51
Member
From: Middle of Germany
Registered: 2018-12-20
Posts: 53  
Website

Re: [SOLVED] Unmet dependencies with minimal-live image

Great, many thx @fsmithred. Now the minimal-live machine works perfect and I can install what I need. Good job!

And no, my last post was not from the netinstall, but also from minimal-live.
The netinstall image was installed without any problems.  However I will keep the minimal-live on the old notebook as it is more slim and fast as the netinstall. The netinstall was installed this night on another machine.

Thx & regards
Berni


The good ol' days will not return, and the rocks might smelt and the sea may burn.

Offline

Board footer