The officially official Devuan Forum!

You are not logged in.

#1 2020-10-19 14:14:16

kropsu
Member
From: Finland
Registered: 2018-02-14
Posts: 12  

Cmus not starting on Devuan 3.0.0 Beowulf, Mate[ SOLVED]

Hello!

I am having issues with cmus player. The basic problem is that it doesn`t start.

What should I do?

I am using Devuan on Lenovo T420 laptop. The operation system is Devuan 3.0.0 Beowulf, with Mate.

Last edited by kropsu (2020-10-20 12:02:52)


It wasn`t me...

Offline

#2 2020-10-19 16:19:41

PedroReina
Member
From: Madrid, Spain
Registered: 2019-01-13
Posts: 157  
Website

Re: Cmus not starting on Devuan 3.0.0 Beowulf, Mate[ SOLVED]

kropsu wrote:

I am having issues with cmus player. The basic problem is that it doesn`t start.

What should I do?

May be if you start the program from a terminal you will see some error messages. If so, post that messages.

Offline

#3 2020-10-19 17:30:52

kropsu
Member
From: Finland
Registered: 2018-02-14
Posts: 12  

Re: Cmus not starting on Devuan 3.0.0 Beowulf, Mate[ SOLVED]

Cmus is driven In a terminal window.

Now when I try to run  cmus on terminal, basically nothing happens. It just doesn't start.

I googled this issue, and got similar results. People are having same problem.


It wasn`t me...

Offline

#4 2020-10-19 17:41:21

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,142  
Website

Re: Cmus not starting on Devuan 3.0.0 Beowulf, Mate[ SOLVED]

Have you checked ~/.xsession-errors?

Perhaps also try running this from a terminal:

x-terminal-emulator -e cmus

Not sure if it will return errors from cmus though.

And you should probably share your sources, a FrankenDevuan can result in strange problems:

apt policy

Black Lives Matter

Offline

#5 2020-10-19 17:55:39

kropsu
Member
From: Finland
Registered: 2018-02-14
Posts: 12  

Re: Cmus not starting on Devuan 3.0.0 Beowulf, Mate[ SOLVED]

apt policy below:

mp@Kokeilukone-ThinkPad-T420:~$ apt policy
Pakettitiedostot:
 100 /var/lib/dpkg/status
     release a=now
 500 http://repo.vivaldi.com/stable/deb stable/main amd64 Packages
     release o=Vivaldi Technologies,a=stable,l=Official Vivaldi package repository,c=main,b=amd64
     origin repo.vivaldi.com
 500 http://dl.google.com/linux/chrome/deb stable/main amd64 Packages
     release v=1.0,o=Google LLC,a=stable,n=stable,l=Google,c=main,b=amd64
     origin dl.google.com
 500 http://deb.devuan.org/merged beowulf-updates/non-free amd64 Packages
     release v=3.0.0,o=Devuan,a=stable-updates,n=beowulf-updates,l=Devuan,c=non-free,b=amd64
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf-updates/main amd64 Packages
     release v=3.0.0,o=Devuan,a=stable-updates,n=beowulf-updates,l=Devuan,c=main,b=amd64
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf-security/non-free amd64 Packages
     release v=3.0.0,o=Devuan,a=stable-security,n=beowulf-security,l=Devuan-Security,c=non-free,b=amd64
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf-security/main amd64 Packages
     release v=3.0.0,o=Devuan,a=stable-security,n=beowulf-security,l=Devuan-Security,c=main,b=amd64
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf/contrib amd64 Packages
     release v=3.0,o=Devuan,a=stable,n=beowulf,l=Devuan,c=contrib,b=amd64
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf/non-free amd64 Packages
     release v=3.0,o=Devuan,a=stable,n=beowulf,l=Devuan,c=non-free,b=amd64
     origin deb.devuan.org
 500 http://deb.devuan.org/merged beowulf/main amd64 Packages
     release v=3.0,o=Devuan,a=stable,n=beowulf,l=Devuan,c=main,b=amd64
     origin deb.devuan.org
Paketit joissa tunniste:

xsession-errors below:

(mate-terminal:20387): dbind-WARNING **: 20:48:14.556: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
x-terminal-emulator -e cmus

opened another window, but did not open cmus.


It wasn`t me...

Offline

#6 2020-10-19 19:01:32

golinux
Administrator
Registered: 2016-11-25
Posts: 2,076  

Re: Cmus not starting on Devuan 3.0.0 Beowulf, Mate[ SOLVED]

I have never seen a sources.list that looked like that.  Maybe have a look at https://devuan.org/os/packages

Offline

#7 2020-10-19 19:16:17

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,142  
Website

Re: Cmus not starting on Devuan 3.0.0 Beowulf, Mate[ SOLVED]

golinux wrote:

I have never seen a sources.list that looked like that.

That's an overview of the sources and pinning that APT sees, it is not the content of /etc/apt/sources.list.

The only suspect entry is repo.vivaldi.com, this should show us what has been installed from there:

aptitude search '?narrow(?installed, ?origin(repo.vivaldi.com))'
kropsu wrote:

xsession-errors below

That was the entire content of the file? Nothing relevant to cmus then.

kropsu wrote:

opened another window, but did not open cmus

Well no, I would not expect it to. The point of that suggestion was to see if any error messages from cmus showed up in the original terminal from which the command was run. Did you see anything in the original terminal?

FWIW cmus works just fine in my Debian buster box.


Black Lives Matter

Offline

#8 2020-10-19 19:37:03

kropsu
Member
From: Finland
Registered: 2018-02-14
Posts: 12  

Re: Cmus not starting on Devuan 3.0.0 Beowulf, Mate[ SOLVED]

Head_on_a_Stick wrote:
golinux wrote:

I have never seen a sources.list that looked like that.

That's an overview of the sources and pinning that APT sees, it is not the content of /etc/apt/sources.list.

The only suspect entry is repo.vivaldi.com, this should show us what has been installed from there:

aptitude search '?narrow(?installed, ?origin(repo.vivaldi.com))'
kropsu wrote:

xsession-errors below

That was the entire content of the file? Nothing relevant to cmus then.

kropsu wrote:

opened another window, but did not open cmus

Well no, I would not expect it to. The point of that suggestion was to see if any error messages from cmus showed up in the original terminal from which the command was run. Did you see anything in the original terminal?

FWIW cmus works just fine in my Debian buster box.

repo.vivaldi.com That is my Vivaldi-browser.

There was none output at x-terminal-emulator -e cmus

Here is full log from xsession-errors

Xsession: X session started for mp at ma 19.10.2020 16.50.18 +0300
localuser:mp being added to access control list
dbus-update-activation-environment: systemd --user not found, ignoring --systemd argument
dbus-update-activation-environment: setting GTK_MODULES=gail:atk-bridge
dbus-update-activation-environment: systemd --user not found, ignoring --systemd argument
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: systemd --user not found, ignoring --systemd argument
dbus-update-activation-environment: setting USER=mp
dbus-update-activation-environment: setting XDG_SESSION_TYPE=x11
dbus-update-activation-environment: setting HOME=/home/mp
dbus-update-activation-environment: setting DESKTOP_SESSION=lightdm-xsession
dbus-update-activation-environment: setting XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0
dbus-update-activation-environment: setting GTK_MODULES=gail:atk-bridge
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-HFBnzQq2JW,guid=4ec88cc3d303fa30c29a4a4a5f8d999a
dbus-update-activation-environment: setting LOGNAME=mp
dbus-update-activation-environment: setting XDG_SESSION_CLASS=user
dbus-update-activation-environment: setting GTK_OVERLAY_SCROLLING=0
dbus-update-activation-environment: setting LIBOVERLAY_SCROLLBAR=0
dbus-update-activation-environment: setting PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
dbus-update-activation-environment: setting XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session0
dbus-update-activation-environment: setting XDG_RUNTIME_DIR=/run/user/1000
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting LANG=fi_FI.UTF-8
dbus-update-activation-environment: setting XDG_SESSION_DESKTOP=lightdm-xsession
dbus-update-activation-environment: setting XAUTHORITY=/home/mp/.Xauthority
dbus-update-activation-environment: setting XDG_GREETER_DATA_DIR=/var/lib/lightdm/data/mp
dbus-update-activation-environment: setting SHELL=/bin/bash
dbus-update-activation-environment: setting GDMSESSION=lightdm-xsession
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting GPG_AGENT_INFO=/run/user/1000/gnupg/S.gpg-agent:0:1
dbus-update-activation-environment: setting PWD=/home/mp
dbus-update-activation-environment: setting XDG_DATA_DIRS=/usr/share/mate:/usr/local/share/:/usr/share/

(x-session-manager:2173): dbind-WARNING **: 16:50:19.405: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
x-session-manager[2173]: WARNING: Unable to find provider '' of required component 'dock'

(mate-settings-daemon:2251): dbind-WARNING **: 16:50:20.250: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(marco:2255): dbind-WARNING **: 16:50:21.379: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(mate-panel:2267): dbind-WARNING **: 16:50:21.699: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(caja:2284): dbind-WARNING **: 16:50:22.737: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
SSH_AUTH_SOCK=/run/user/1000/keyring/ssh
SSH_AUTH_SOCK=/run/user/1000/keyring/ssh
SSH_AUTH_SOCK=/run/user/1000/keyring/ssh
Yhteysvirhe: Yhteys hylätty
pa_context_connect() epäonnistui: Yhteys hylätty

(mate-power-manager:2296): dbind-WARNING **: 16:50:23.040: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(mate-volume-control-applet:2315): dbind-WARNING **: 16:50:23.226: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(mate-screensaver:2312): dbind-WARNING **: 16:50:23.231: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(polkit-mate-authentication-agent-1:2320): dbind-WARNING **: 16:50:23.745: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(wicd-client.py:2311): dbind-WARNING **: 16:50:26.053: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(mate-volume-control-applet:2315): Gtk-WARNING **: 16:50:28.720: Negative content width -5 (allocation 1, extents 3x3) while allocating gadget (node image, owner GtkImage)

(mate-volume-control-applet:2315): Gtk-WARNING **: 16:50:28.720: Negative content height -5 (allocation 1, extents 3x3) while allocating gadget (node image, owner GtkImage)

(mate-terminal:2465): dbind-WARNING **: 16:50:33.050: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
[7670:7670:1019/165218.941916:ERROR:chrome_content_client.cc(343)] Failed to locate and load the component updated flash plugin.
[7670:7670:1019/165219.755743:ERROR:browser_dm_token_storage_linux.cc(94)] Error: /etc/machine-id contains 0 characters (32 were expected).
[7703:7703:1019/165220.770590:ERROR:sandbox_linux.cc(374)] InitializeSandbox() called with multiple threads in process gpu-process.

(vivaldi-stable:7670): dbind-WARNING **: 16:52:25.706: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
[7670:7670:1019/165234.493077:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: The message port closed before a response was received.", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/165259.197886:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/165259.198260:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/165314.875737:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/165314.875955:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/165915.000291:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/165915.000475:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
IPDL protocol error: Handler returned error code!

###!!! [Parent][DispatchAsyncMessage] Error: PLayerTransaction::Msg_ReleaseLayer Processing error: message was deserialized, but the handler returned false (indicating failure)

IPDL protocol error: Handler returned error code!

###!!! [Parent][DispatchAsyncMessage] Error: PLayerTransaction::Msg_ReleaseLayer Processing error: message was deserialized, but the handler returned false (indicating failure)

[7670:7670:1019/170335.896762:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/170335.896902:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/170617.636492:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/170617.636576:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/171359.603350:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/171359.616684:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/171359.616976:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/171401.343233:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/171401.343323:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/171429.143285:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/171429.143351:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/172434.415698:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/172434.416011:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/172601.061441:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/172601.061624:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[11620:654:1019/172626.265279:ERROR:vivaldi_snapshot_page.cc(80)] empty visible content rect
[7670:7670:1019/172626.277572:ERROR:capture_page.cc(128)] no data from the renderer process
[7670:7670:1019/172626.283148:ERROR:thumbnails_api.cc(569)] Failed to capture tab http://www.rintamamiestalo.fi/search.php?search_id=newposts&sid=9d3deeb1a190e12196e16bb3a21564e0
[7670:7670:1019/172743.206212:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/172743.206294:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/172826.889985:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/172826.892569:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/173820.704195:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/173820.704963:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/173854.337687:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/173854.338011:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/173951.620564:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/173951.620819:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
Fontconfig error: Cannot load default config file: No such file: (null)
[7670:7670:1019/174152.763656:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/174152.763732:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)

(/usr/lib/mate-screensaver/mate-screensaver-gl-helper:15159): dbind-WARNING **: 18:34:58.167: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(mate-power-manager:2296): GLib-CRITICAL **: 19:44:31.229: Source ID 101 was not found when attempting to remove it

(mate-power-manager:2296): GLib-CRITICAL **: 20:43:51.187: Source ID 104 was not found when attempting to remove it

(pluma:20359): dbind-WARNING **: 20:47:46.335: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(mate-terminal:20387): dbind-WARNING **: 20:48:14.556: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(pluma:20408): dbind-WARNING **: 20:48:25.877: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(pluma:20498): dbind-WARNING **: 20:49:51.299: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(mate-terminal:20513): dbind-WARNING **: 20:50:09.505: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(pluma:20576): dbind-WARNING **: 20:51:10.869: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
[7670:7670:1019/205610.637342:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/205610.637425:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/213018.947751:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/213018.948729:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/213320.931362:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/213320.931716:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)

(mate-screensaver:2312): GLib-CRITICAL **: 22:04:06.685: Source ID 25 was not found when attempting to remove it

(/usr/lib/mate-screensaver/mate-screensaver-gl-helper:23665): dbind-WARNING **: 22:04:16.720: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(mate-power-manager:2296): GLib-CRITICAL **: 22:28:01.887: Source ID 112 was not found when attempting to remove it
[7670:7670:1019/222851.334419:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[7670:7670:1019/222851.334523:ERROR:CONSOLE(0)] "Unchecked runtime.lastError: Could not find guest", source: chrome-extension://mpognobbkildjkofajifpdfhcoklimli/browser.html (0)
[24651:1225:1019/222905.616867:ERROR:vivaldi_snapshot_page.cc(80)] empty visible content rect
[7670:7670:1019/222905.626167:ERROR:capture_page.cc(128)] no data from the renderer process
[7670:7670:1019/222905.628063:ERROR:thumbnails_api.cc(569)] Failed to capture tab http://dev1galaxy.org/index.php

(mate-terminal:24750): dbind-WARNING **: 22:29:55.192: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

** (mate-terminal:20387): CRITICAL **: 22:30:12.707: terminal_window_remove_screen: assertion 'gtk_widget_get_toplevel (GTK_WIDGET (screen)) == GTK_WIDGET (window)' failed

** (mate-terminal:20387): CRITICAL **: 22:30:21.514: terminal_window_remove_screen: assertion 'gtk_widget_get_toplevel (GTK_WIDGET (screen)) == GTK_WIDGET (window)' failed

(mate-terminal:24835): dbind-WARNING **: 22:30:48.927: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(pluma:25019): dbind-WARNING **: 22:35:03.361: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

It wasn`t me...

Offline

#9 2020-10-19 19:56:21

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,142  
Website

Re: Cmus not starting on Devuan 3.0.0 Beowulf, Mate[ SOLVED]

Please don't full quote unnecessarily, it degrades the readability of the thread.

kropsu wrote:

repo.vivaldi.com That is my Vivaldi-browser.

Well yes but my aptitude command will show if anything else has been dragged in along with it.

kropsu wrote:

Here is full log from xsession-errors

I can't see anything relevant there but just in case I've missed something you can delete the file and then try to start cmus again to see if anything new is added.

You can also try

strace -o strace.cmus cmus

Then share the content of strace.cmus but I can't really interpret that in any meaningful way, unfortunately.

Is PulseAudio running?

pgrep -a pulse

If it isn't running then try this command as root:

sed -i '/autospawn/s/^/#/' /etc/pulse/client.conf.d/00-disable-autospawn.conf

^ That should get PA running, which may fix things.

Alternatively if you prefer to run without PulseAudio try this command as your normal user:

mkdir ~/.cmus; echo 'set output_plugin=alsa' > ~/.cmus/rc

Reference: https://bugs.archlinux.org/task/46447


Black Lives Matter

Offline

#10 2020-10-19 20:06:23

MiyoLinux
Member
Registered: 2016-12-05
Posts: 1,066  

Re: Cmus not starting on Devuan 3.0.0 Beowulf, Mate[ SOLVED]

cmus works perfectly for me in beowulf. smile

Have you tried just entering...

cmus

...in the terminal instead of...

x-terminal-emulator -e cmus

?

I only enter...

cmus

...and it works. However, if I enter...

x-terminal-emulator -e cmus

...as you've shown, it opens another terminal window which does nothing, and promptly closes.


I have been Devuanated, and my practice in the art of Devuanism shall continue until my Devuanization is complete. Until then, I will strive to continue in my understanding of Devuanchology, Devuanprocity, and Devuanivity.

Veni, vidi, vici vdevuaned. I came, I saw, I Devuaned. wink

Offline

#11 2020-10-19 20:09:56

kapqa
Member
Registered: 2019-01-02
Posts: 214  

Re: Cmus not starting on Devuan 3.0.0 Beowulf, Mate[ SOLVED]

what i didd on powerpc probably or mac osx to compile it for newer version, you could always try that with help on github pages or wiki.

Offline

#12 2020-10-19 20:35:07

kropsu
Member
From: Finland
Registered: 2018-02-14
Posts: 12  

Re: Cmus not starting on Devuan 3.0.0 Beowulf, Mate[ SOLVED]

For head_on_a_stick

There was none output any of your suggestions. I am wondering if my terminal is broken?

For MiyoLinux

I have tried several times to run cmus, by typing cmus on a terminal and hitting the enter, no luck.


It wasn`t me...

Offline

#13 2020-10-19 21:35:18

MiyoLinux
Member
Registered: 2016-12-05
Posts: 1,066  

Re: Cmus not starting on Devuan 3.0.0 Beowulf, Mate[ SOLVED]

Hmmm...strange. Then again, I'm a window manager user without much experience at all with MATE. tongue

Perhaps a....

apt install --reinstall cmus

?

I don't know. Sorry.

Last edited by MiyoLinux (2020-10-19 21:35:43)


I have been Devuanated, and my practice in the art of Devuanism shall continue until my Devuanization is complete. Until then, I will strive to continue in my understanding of Devuanchology, Devuanprocity, and Devuanivity.

Veni, vidi, vici vdevuaned. I came, I saw, I Devuaned. wink

Offline

#14 2020-10-20 05:43:02

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,142  
Website

Re: Cmus not starting on Devuan 3.0.0 Beowulf, Mate[ SOLVED]

kropsu wrote:

There was none output any of your suggestions.

Of the four code blocks in my last post only the pgrep command was expected to produce any output. If it did not produce any output then that means that PulseAudio is not running in your system, in that case the sed command was intended to ensure that PulseAudio was started on the next login which may have got cmus working. Unfortunately the last command string would then have broken it again if you ran that as well. Sorry but I was expecting you to read and attempt to understand my post rather than just running the commands blindly like a child accepting food from a proffered spoon...

So in summary if the pgrep command now produces some output and you have a file at ~/.cmus/rc that contains the string set output_plugin=alsa then you need to delete ~/.cmus/rc then log out & back in again.

For the record the strace command was expected to create a log file called strace.cmus in whichever directory the command was run from.


Black Lives Matter

Offline

#15 2020-10-20 11:51:54

kapqa
Member
Registered: 2019-01-02
Posts: 214  

Re: Cmus not starting on Devuan 3.0.0 Beowulf, Mate[ SOLVED]

on beowulf i had to first fix pulseaudio , dont know if this sitll applies

https://www.youtube.com/watch?v=USnRcLF7gUk

Offline

#16 2020-10-20 12:01:24

kropsu
Member
From: Finland
Registered: 2018-02-14
Posts: 12  

Re: Cmus not starting on Devuan 3.0.0 Beowulf, Mate[ SOLVED]

I don`t know what happened, but now the cmus is working.

Maybe it was that pulseaudio.

Thank You for the advices. Everything is all good now.


It wasn`t me...

Offline

#17 2020-10-20 14:32:06

PedroReina
Member
From: Madrid, Spain
Registered: 2019-01-13
Posts: 157  
Website

Re: Cmus not starting on Devuan 3.0.0 Beowulf, Mate[ SOLVED]

kropsu wrote:

Everything is all good now.

Good to know. But may be developers should know about this problem: an user run the program but get no messages at all.

Offline

#18 2020-10-20 17:57:16

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,142  
Website

Re: Cmus not starting on Devuan 3.0.0 Beowulf, Mate[ SOLVED]

kropsu wrote:

Maybe it was that pulseaudio

So is PulseAudio running now? Use my pgrep command to find out.


Black Lives Matter

Offline

#19 2020-10-20 19:15:14

kropsu
Member
From: Finland
Registered: 2018-02-14
Posts: 12  

Re: Cmus not starting on Devuan 3.0.0 Beowulf, Mate[ SOLVED]

Head_on_a_Stick wrote:

So is PulseAudio running now? Use my pgrep command to find out.

mp@Kokeilukone-ThinkPad-T420:~$ pgrep -a pulse
2329 /usr/bin/pulseaudio --start --log-target=syslog

Yes I think it is.


It wasn`t me...

Offline

#20 2020-10-20 19:29:14

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,142  
Website

Re: Cmus not starting on Devuan 3.0.0 Beowulf, Mate[ SOLVED]

Okay, thanks for the feedback smile

We could now try a diagnostic test: disable PulseAudio to see if that breaks cmus again.

To stop PulseAudio from starting run this command as root:

sed -i '/autospawn/s/#//g' /etc/pulse/client.conf.d/00-disable-autospawn.conf

Then log out & back in again, check if PulseAudio is disabled (the pgrep command won't produce any output if PA isn't running) and then try to start cmus.

To re-enable PulseAudio again after the test re-apply the comment to the autospawn line by running this command as root:

sed -i '/autospawn/s/^/#/' /etc/pulse/client.conf.d/00-disable-autospawn.conf

Black Lives Matter

Offline

#21 2020-10-20 20:01:10

kropsu
Member
From: Finland
Registered: 2018-02-14
Posts: 12  

Re: Cmus not starting on Devuan 3.0.0 Beowulf, Mate[ SOLVED]

I did run the command

sed -i '/autospawn/s/#//g' /etc/pulse/client.conf.d/00-disable-autospawn.conf

but it did not stop the pulseaudio.

mp@Kokeilukone-ThinkPad-T420:~$ pgrep -a pulse
2447 /usr/bin/pulseaudio --start --log-target=syslog

It wasn`t me...

Offline

#22 2020-10-20 20:06:40

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 1,142  
Website

Re: Cmus not starting on Devuan 3.0.0 Beowulf, Mate[ SOLVED]

Hmm, did you try rebooting? You can kill it manually with:

# pkill pulseaudio

I don't think it will restart automatically as long as the autospawn line in /etc/pulse/client.conf.d/00-disable-autospawn.conf is commented-out but it might be started by other programs such as Firefox or Chromium.


Black Lives Matter

Offline

#23 2020-10-20 20:21:51

kropsu
Member
From: Finland
Registered: 2018-02-14
Posts: 12  

Re: Cmus not starting on Devuan 3.0.0 Beowulf, Mate[ SOLVED]

Hmm, did you try rebooting?

Yes I did.

You can kill it manually with:

# pkill pulseaudio

This kills pulseaudio, but the cmus is still working


I don't think it will restart automatically as long as the autospawn line in /etc/pulse/client.conf.d/00-disable-autospawn.conf

Here below is autospawn.conf

On linux systems, disable autospawn by default
# If you are not using systemd, comment out this line
autospawn=no

Last edited by kropsu (2020-10-20 20:48:41)


It wasn`t me...

Offline

#24 2020-10-20 21:57:38

GlennW
Member
Registered: 2019-07-18
Posts: 47  

Re: Cmus not starting on Devuan 3.0.0 Beowulf, Mate[ SOLVED]

It needs to look like this

#autospawn=no

I hope this helps.

Offline

Board footer