The officially official Devuan Forum!

You are not logged in.

#1 2020-09-15 21:33:59

thierrybo
Member
Registered: 2017-11-11
Posts: 62  

[SOLVED] ALSA (no pulseaudio) - sound card order changes on boot

Hi,

reading https://wiki.archlinux.org/index.php/Ad … le_options
I try to prevent random "card" index changes at boot. Arch wiki says to use

$ cat /proc/asound/modules

to get the loaded sound modules and their order, then disable modules that we do not use to prevent their use.

However on my system I get two snd_hda_intel :

 0 snd_hda_intel
 1 snd_hda_intel
 2 snd_usb_audio

Yesterday I get

 0 snd_hda_intel 
 1 snd_usb_audio
 2 snd_hda_intel

I already tried two disable snd_usb_audio, however I can't disable snd_hda_intel as it would disable both (disabling is done with module name).

I run out of ideas, it is very frustrating. I try to "resist" installing pulseaudio, however if I can't solve this issue I afraid I have to sad

Last edited by thierrybo (2020-09-16 17:53:02)

Offline

#2 2020-09-15 22:06:50

golinux
Administrator
Registered: 2016-11-25
Posts: 2,051  

Re: [SOLVED] ALSA (no pulseaudio) - sound card order changes on boot

If the fix in the Release Notes doesn't work, you might try an .asoundrc configuration.

Offline

#3 2020-09-16 12:48:44

Geoff 42
Member
Registered: 2016-12-15
Posts: 366  

Re: [SOLVED] ALSA (no pulseaudio) - sound card order changes on boot

If you have 2 cards sharing the same module, use the enable option. See :-

https://dev1galaxy.org/viewtopic.php?pid=23900#p23900

Geoff

Offline

#4 2020-09-16 17:37:43

thierrybo
Member
Registered: 2017-11-11
Posts: 62  

Re: [SOLVED] ALSA (no pulseaudio) - sound card order changes on boot

golinux wrote:

If the fix in the Release Notes doesn't work, you might try an .asoundrc configuration.

Do you mean Beowulf release notes? I read it again, it is a fix about PulseAudio.

I already use .asoundrc with

defaults.pcm.card 0  
defaults.ctl.card 0

The problem is the card number 0 that change to 1 or 2.

Last edited by thierrybo (2020-09-16 17:55:25)

Offline

#5 2020-09-16 17:52:22

thierrybo
Member
Registered: 2017-11-11
Posts: 62  

Re: [SOLVED] ALSA (no pulseaudio) - sound card order changes on boot

Geoff 42 wrote:

If you have 2 cards sharing the same module, use the enable option. See :-

https://dev1galaxy.org/viewtopic.php?pid=23900#p23900

Geoff


Ah, you make my day! For now it works. Before I could have :

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 11: HDMI 5 [HDMI 5]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 12: HDMI 6 [HDMI 6]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

or

&& aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 11: HDMI 5 [HDMI 5]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 12: HDMI 6 [HDMI 6]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

and now with

cat alsa-base.conf

options snd-usb-audio index=-2
options snd-hda-intel enable=0,1

I get

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Generic [HD-Audio Generic], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Thanks

Offline

Board footer