The officially official Devuan Forum!

You are not logged in.

#1 2020-06-08 15:25:44

seeker
Member
Registered: 2019-02-17
Posts: 12  

[Solved] ALSA for Dummies?

Beowulf blitzed my sound, and I am having difficulty getting it operational again. The line is commented out for Pulseaudio per the Release Notes. This command produces pink noise:

speaker-test -D default:PCH -c 2

alsamixergui lists HDA Intel HDMI as the "Card:", but there is no method to switch it. I think this has to be toggled somewhere, but I am not having any luck finding the correct place. Is there an ALSA for Dummies page somewhere that goes through setting it up and configuring it? I guess Pulseaudio was running the sound before.

Last edited by seeker (2020-06-08 17:50:01)

Offline

#2 2020-06-08 15:38:11

golinux
Administrator
Registered: 2016-11-25
Posts: 1,956  

Re: [Solved] ALSA for Dummies?

Not really for dummies but very informative.

https://wiki.archlinux.org/index.php/Ad … chitecture

Offline

#3 2020-06-08 17:05:29

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 780  
Website

Re: [Solved] ALSA for Dummies?

Do you have pulseaudio installed? If so just install and run pavucontrol to set the default output device.

If you don't have pulseaudio installed then golinux's link has all the information you need to configure pure ALSA to set the default device.

seeker wrote:

ALSA for Dummies

As you appear to have an Intel sound card you can try this, it works for all the laptops I have ever owned:

# tee /etc/modprobe.d/alsa.conf <<<'options snd-hda-intel index=1'
# update-initramfs -u -k all

Then reboot.

If that doesn't work remove /etc/modprobe.d/alsa.conf, rebuild the initramfs again and post the output of

aplay -Ll

^ That's two ells, one upper case and one lower case.


Black Lives Matter

Offline

#4 2020-06-08 17:31:10

seeker
Member
Registered: 2019-02-17
Posts: 12  

Re: [Solved] ALSA for Dummies?

I did try installing Pulseaudio, but it did not work either.

Found https://www.seehuhn.de/pages/alsa.html which mentions /etc/asound.conf. No such file existed so I created one with the following contents:

# Sound card informtion from 'aplay -l' :
# 
#**** List of PLAYBACK Hardware Devices ****
#card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
#  Subdevices: 1/1
#  Subdevice #0: subdevice #0
#card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
#  Subdevices: 1/1
#  Subdevice #0: subdevice #0
#card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
#  Subdevices: 1/1
#  Subdevice #0: subdevice #0
#card 0: HDMI [HDA Intel HDMI], device 9: HDMI 3 [HDMI 3]
#  Subdevices: 1/1
#  Subdevice #0: subdevice #0
#card 0: HDMI [HDA Intel HDMI], device 10: HDMI 4 [HDMI 4]
#  Subdevices: 1/1
#  Subdevice #0: subdevice #0
#card 1: PCH [HDA Intel PCH], device 0: ALC3235 Analog [ALC3235 Analog]
#  Subdevices: 0/1
#  Subdevice #0: subdevice #0



defaults.ctl.card 1
defaults.pcm.card 1
defaults.timer.card 1

Rebooted and now I have sound. My guess was correct that it was defaulting to Card 0, which is HDMI. Thank you golinux and Head_on_a_Stick.

Last edited by seeker (2020-06-08 17:51:42)

Offline

#5 2020-06-08 17:31:11

larsH
Member
Registered: 2020-05-05
Posts: 85  

Re: [Solved] ALSA for Dummies?

Hi

Or install volumeicon-alsa and add it to the desktop

Have a nice day
Lars H

P.S. Could we not have this more clear in release notes or in a header in a Sticky. This question is there again and agian and again. So i am repeating this over and over and over ;-)))

Offline

Board footer