The officially official Devuan Forum!

You are not logged in.

#1 2020-02-26 21:31:26

Ron
Member
Registered: 2018-04-22
Posts: 225  

Emojis don't show

I have a friend who uses emojis  in emails he sends me, but they don't show up on my computer. For example, I just got one today and instead of the emoji was this \uD83D\uDE42. I use Centurylink email mostly, so I forwarded this email to my Yahoo email, and again I got \uD83D\uDE42 instead of the emoji. I thought I may have needed to add a font, so without much to go on, I installed font-symbola, but that didn't help. If it matters my friend's emails are from Outlook. Any one got any ideas?

Offline

#2 2020-02-26 21:54:09

golinux
Administrator
Registered: 2016-11-25
Posts: 1,874  

Re: Emojis don't show

Get your friend off MS Outlook?

Offline

#3 2020-02-26 22:05:03

Ron
Member
Registered: 2018-04-22
Posts: 225  

Re: Emojis don't show

He doesn't care about things like that. But that shouldn't matter whether emojis show up on my computer, does it?

Offline

#4 2020-02-26 22:26:45

Ron
Member
Registered: 2018-04-22
Posts: 225  

Re: Emojis don't show

I wonder if uni2ascii would fix this? The description says UTF-8 to 7-bit ASCII and vice versa converter.

Offline

#5 2020-02-27 15:43:49

GNUser
Member
Registered: 2017-03-16
Posts: 518  

Re: Emojis don't show

Ron,

I don't think the fact that your friend's email client is proprietary has anything to do with it. Also, uni2ascii is unlikely to help. It sounds like an encoding issue.

The emoji in question is the "slightly smiling face" (formal Unicode notation: U+1F642, details about it here: https://www.iemoji.com/view/emoji/1112/ … ling-face). Here are the relevant details:
UTF-8 encoding: 0xf09f9982
UTF-16 encoding: 0xd83dde42 (notice this matches the "D83D "DE42" in your original post)

How are you viewing your friend's emails? In a web browser? If so, take a look at that emoji here:
https://unicode.org/emoji/charts/full-e … html#1f602

If you can see the "slightly smiling face" emoji there under the "Browser" column, we'll know it's not a browser or font issue on your end.

My best guess is that your friend's email client is using UTF-16 encoding, while your email client is expecting UTF-8 encoding. Different encodings agree on how to represent 7-bit ASCII characters but differ on how they represent wider characters such as emojis.

Have your friend check their outgoing mail encoding and change it to UTF-8 if it's currently something else.

Last edited by GNUser (2020-02-27 16:13:58)

Offline

#6 2020-02-27 20:20:55

Ron
Member
Registered: 2018-04-22
Posts: 225  

Re: Emojis don't show

GNUser wrote:

My best guess is that your friend's email client is using UTF-16 encoding, while your email client is expecting UTF-8 encoding.

Assuming that's true, is there anything on my end that can be done to fix it?

Offline

#7 2020-02-27 20:30:44

GNUser
Member
Registered: 2017-03-16
Posts: 518  

Re: Emojis don't show

If that's true, switching your email client to UTF-16 encoding would properly display the wide characters in your friend's emails--but would cause problems displaying wide characters in emails to you from people who use UTF-8 (the de facto standard encoding these days).

Offline

#8 2020-02-27 22:15:42

Ron
Member
Registered: 2018-04-22
Posts: 225  

Re: Emojis don't show

GNUser wrote:

If that's true, switching your email client to UTF-16 encoding would properly display the wide characters in your friend's emails--but would cause problems displaying wide characters in emails to you from people who use UTF-8 (the de facto standard encoding these days).

That doesn't seem to be an option in preferences. FTR I asked my friend to send me an email to my Yahoo address with some emojis, and Yahoo shows them just fine.

Offline

Board footer