The officially official Devuan Forum!

You are not logged in.

#1 2019-08-01 22:17:51

bgstack15
Member
Registered: 2018-02-04
Posts: 72  

[SOLVED] Ceres 64-bit and cannot install wine32:i386

I have a Devuan 3 (beowulf/ceres) am64 installation, and I've enabled multiarch.

When I apt-get update and apt-get install wine32:i386, I get this error:

[bgstack15@ltb-013|/home/bgstack15]$ sudo apt-get install wine32:i386 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine32:i386 : Depends: libwine:i386 (= 4.0-2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Chasing down all the things that it depends on results in this command:

[bgstack15@ltb-013|/home/bgstack15]$ sudo apt-get install wine32:i386 libwine:i386 libfontconfig1:i386 libglib2.0-0:i386 libgphoto2-6:i386 libgstreamer-plugins-base1.0-0:i386 libgstreamer1.0-0:i386 libpulse0:i386 libsdl2-2.0-0:i386 libasound2-plugins:i386 libuuid1:i386 libmount1:i386 libsm6:i386 libblkid1:i386

Full output: https://pastebin.com/bS0DTHQC
Tail end of output:

WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
  e2fsprogs libblkid1 (due to e2fsprogs) libuuid1 (due to e2fsprogs) fdisk
  libfdisk1 (due to fdisk) libmount1 (due to fdisk) init sysvinit-core (due to init) mount
  util-linux (due to mount) sysvinit-utils
0 upgraded, 204 newly installed, 571 to remove and 4 not upgraded.
Need to get 115 MB of archives.
After this operation, 2,053 MB disk space will be freed.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'
 ?] n
Abort.

Would you please help me figure out how to get my 32-bit wine binary so I can run my Wine-based game? I don't understand why I cannot install a lot of these in parallel. I know I've done this before, all on beowulf/ceres.

Last edited by bgstack15 (2019-08-10 16:58:51)

Offline

#2 2019-08-02 00:16:28

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 375  

Re: [SOLVED] Ceres 64-bit and cannot install wine32:i386

It seems like libuuid1 has an explicit "Replaces: e2fsprogs" declaration, which causes great havoc in the base set up. I haven't looked into the details, but that "Replaces" directive seems totally misplaced, since libuuid1 only provides a single library, whereas e2fsprogs provides more than a few useful and essential things, but not that library, nor (as far as I can see at a glance) anything conflicting with that library.

Thus, you don't ever want to install libuuid1. Well, I wouldn't.

Perhaps you can bypass this by using equivs, and (learning to) use it; it's a fairly simple way to tell your system that you have a package of a particular version installed without actually having it installed. In this case you would fool your system with an "equivs" installation of libuuid1:i386=2.33.1-0.1+devuan1, and that might be sufficient to get all else installed. I suppose, it might affect the audio (since this library is pulled in due to pulse0), so it might need additional hands-on later. But It is for instance, trivial to download that missing library /lib/i386-linux-gnu/libuuid.so.1.3.0 and "install" it manually.

Offline

#3 2019-08-02 01:18:36

bgstack15
Member
Registered: 2018-02-04
Posts: 72  

Re: [SOLVED] Ceres 64-bit and cannot install wine32:i386

Thank you, Ralph! I have now confirmed that at least one other beowulf/ceres instance is working correctly and I can install wine32:i386.

This is the second time someone has answered me with "check out equivs." I remembered that advice from last time (oh, it was you!), so now I will have to figure it out. I am concerned that something so low-level like libuuid is causing weird problems on my system, for something (high-level?) like Wine.

Offline

#4 2019-08-02 01:56:35

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 375  

Re: [SOLVED] Ceres 64-bit and cannot install wine32:i386

Yes, equivs is a powerful albeit dangerous scalpel for the tool belt. It lets you lobotomize the system to a hollow shell of nothingness and yet appear fine smile

And yes, it looks like something is wrong with libuuid. Maybe just a copy-and-paste mistake when rearranging things; the package was built from the util-linux source which includes several packages. I submitted a bug report to Debian (where this originated), and perhaps we can temporarily patch ascii/beowulf as well.

Offline

#5 2019-08-02 03:14:53

bgstack15
Member
Registered: 2018-02-04
Posts: 72  

Re: [SOLVED] Ceres 64-bit and cannot install wine32:i386

Ooh, I miscommunicated in my previous post.

Thank you, Ralph, for the advice.

I have another Devuan installation, where wine32:i386 is already installed and it works and all that.

My first one, is still messed up and I have not yet messed with equivs.

Would you please link to the bug report here? I am having trouble navigating the debian bugs site. I came from a Fedora world and all the debianized stuff is a learning curve for me.

Offline

#6 2019-08-02 04:18:35

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 375  

Re: [SOLVED] Ceres 64-bit and cannot install wine32:i386

Fair enough. Here's the bug tracking link:
https://bugs.debian.org/cgi-bin/bugrepo … bug=933697

Offline

#7 2019-08-02 11:08:36

bgstack15
Member
Registered: 2018-02-04
Posts: 72  

Re: [SOLVED] Ceres 64-bit and cannot install wine32:i386

Wow, thank you for going to bat for me! You must be in a different timezone, because your exchange with one of the kernel devs happened in the middle of my night.
I definitely expect my broken system to be non-pristine. I failed to share my sources.list and my list of installed packages. I am embarrassed to report that my system has a bunch of +devuan1 and +devuan2.1 packages.

[bgstack15@ltb-013|/etc/apt/apt.conf.d]$ dpkg -l | awk '{print $3}' | awk -F'+' '{print $2}' | sort | uniq -c | grep devuan
      8 devuan
     16 devuan1
      1 devuan1.0
      7 devuan1.1
      2 devuan1.3
      6 devuan2
     13 devuan2.1
      5 devuan3
      1 devuan3.0
      1 devuan3.1

With those being:

[bgstack15@ltb-013|/etc/apt/apt.conf.d]$ dpkg -l | grep -E -e '\+devuan'
ii  base-files                                                  10.3+devuan3.0                     all          Devuan base system miscellaneous files
ii  bsdutils                                                    1:2.32.1-0.1+devuan2.1             amd64        basic utilities from 4.4BSD-Lite
ii  colord                                                      1.4.3-3+devuan1                    amd64        system service to manage device colour profiles -- system daemon
ii  colord-data                                                 1.4.3-3+devuan1                    all          system service to manage device colour profiles -- data files
ii  dbus                                                        1.12.16-1+devuan2                  amd64        simple interprocess messaging system (daemon and utilities)
ii  dbus-x11                                                    1.12.16-1+devuan2                  amd64        simple interprocess messaging system (X11 deps)
ii  devuan-baseconf                                             0.6.4+devuan3.1                    all          Devuan base config files
ii  distro-info-data                                            0.39+devuan1.1                     all          information about the distributions' releases (data files)
ii  fdisk                                                       2.32.1-0.1+devuan2.1               amd64        collection of partitioning utilities
ii  freefilesync                                                10.14-2+devuan                     amd64        
ii  gir1.2-polkit-1.0                                           0.105-25+devuan3                   amd64        GObject introspection data for PolicyKit
ii  init                                                        1.56+devuan1                       amd64        metapackage ensuring an init system is installed
ii  init-system-helpers                                         1.56+devuan1                       all          helper tools for all init systems
ii  initscripts                                                 2.93-8+devuan1                     amd64        scripts for initializing and shutting down the system
rc  irfanview-bin32                                             4.53-1+devuan                      all          graphics viewer from a non-free OS
ii  irfanview-bin64                                             4.53-2+devuan                      all          graphics viewer from a non-free OS
ii  irfanview-common                                            4.53-2+devuan                      all          common elements for irfanview
ii  libblkid1:amd64                                             2.32.1-0.1+devuan2.1               amd64        block device ID library
ii  libcgmanager0:amd64                                         0.36-2+devuan1                     amd64        Central cgroup manager daemon (client library)
ii  libcolord2:amd64                                            1.4.3-3+devuan1                    amd64        system service to manage device colour profiles -- runtime
ii  libcolorhug2:amd64                                          1.4.3-3+devuan1                    amd64        library to access the ColorHug colourimeter -- runtime
ii  libdbus-1-3:amd64                                           1.12.16-1+devuan2                  amd64        simple interprocess messaging system (library)
ii  libfdisk1:amd64                                             2.32.1-0.1+devuan2.1               amd64        fdisk partitioning library
ii  libmount1:amd64                                             2.32.1-0.1+devuan2.1               amd64        device mounting library
ii  libpcsclite1:amd64                                          1.8.22-1+devuan2                   amd64        Middleware to access a smart card using PC/SC (library)
ii  libpolkit-agent-1-0:amd64                                   0.105-25+devuan3                   amd64        PolicyKit Authentication Agent API
ii  libpolkit-backend-consolekit-1-0:amd64                      0.105-25+devuan3                   amd64        PolicyKit backend API
ii  libpolkit-gobject-consolekit-1-0:amd64                      0.105-25+devuan3                   amd64        PolicyKit Authorization API
ii  libprocps4:amd64                                            2:3.3.10-4+devuan1.0               amd64        library for accessing process information from /proc
ii  libprocps6:amd64                                            2:3.3.12-3+devuan2.1               amd64        library for accessing process information from /proc
ii  libsmartcols1:amd64                                         2.32.1-0.1+devuan2.1               amd64        smart column output alignment library
ii  libudisks2-0:amd64                                          2.1.3-5+devuan2                    amd64        GObject based library to access udisks2
ii  libupower-glib1:amd64                                       1:0.9.23-2+devuan1.3               amd64        abstraction for power management - shared library
ii  libuuid1:amd64                                              2.32.1-0.1+devuan2.1               amd64        Universally Unique ID library
ii  mount                                                       2.32.1-0.1+devuan2.1               amd64        tools for mounting and manipulating filesystems
ii  net-tools                                                   1.60+git20180626.aebd88e-1+devuan1 amd64        NET-3 networking toolkit
ii  palemoon                                                    28.6.0.1-1+devuan                  amd64        Firefox-based, efficient and easy to use web browser
ii  palemoon-ublock-origin                                      1.16.4.8-2+devuan                  all          An efficient blocker for Chromium and Firefox. Fast and lean.
ii  policykit-1                                                 0.105-25+devuan3                   amd64        framework for managing administrative policies and privileges
ii  popularity-contest                                          1.67+devuan1                       all          Vote for your favourite packages automatically
ii  procps                                                      2:3.3.12-3+devuan2.1               amd64        /proc file system utilities
ii  python-wicd                                                 1.7.4+tb2-6+devuan1.1              all          wired and wireless network manager - Python module
ii  python3-reportbug                                           7.5.1+devuan1                      all          Python modules for interacting with bug tracking systems
ii  reportbug                                                   7.5.1+devuan1                      all          reports bugs in the Debian distribution
ii  rfkill                                                      2.32.1-0.1+devuan2.1               amd64        tool for enabling and disabling wireless devices
ii  rsyslog                                                     8.39.0-1+devuan1                   amd64        reliable system and kernel logging daemon
ii  sysv-rc                                                     2.93-8+devuan1                     all          System-V-like runlevel change mechanism
ii  sysvinit                                                    2.93-8+devuan1                     amd64        System-V-like init utilities - transitional package
ii  sysvinit-core                                               2.93-8+devuan1                     amd64        System-V-like init utilities
ii  sysvinit-utils                                              2.93-8+devuan1                     amd64        System-V-like utilities
ii  task-english                                                3.48+devuan1.1                     all          General English environment
ii  task-laptop                                                 3.48+devuan1.1                     all          laptop
ii  task-ssh-server                                             3.48+devuan1.1                     all          SSH server
ii  tasksel                                                     3.48+devuan1.1                     all          tool for selecting tasks for installation on Devuan systems
ii  tasksel-data                                                3.48+devuan1.1                     all          official tasks used for installation of Devuan systems
ii  udev                                                        1:3.2.7+devuan1.1                  amd64        Transitional package for eudev
ii  udisks2                                                     2.1.3-5+devuan2                    amd64        D-Bus service to access and manipulate storage devices
ii  upower                                                      1:0.9.23-2+devuan1.3               amd64        abstraction for power management
ii  util-linux                                                  2.32.1-0.1+devuan2.1               amd64        miscellaneous system utilities
ii  util-linux-locales                                          2.32.1-0.1+devuan2.1               all          locales files for util-linux
ii  veracrypt                                                   1.23-2+devuan                      amd64        Cross-platform on-the-fly encryption
ii  waterfox                                                    56.2.12-1+devuan                   amd64        Free, open and private browser
ii  wicd                                                        1.7.4+tb2-6+devuan1.1              all          wired and wireless network manager - metapackage
ii  wicd-cli                                                    1.7.4+tb2-6+devuan1.1              all          wired and wireless network manager - scriptable console client
ii  wicd-daemon                                                 1.7.4+tb2-6+devuan1.1              all          wired and wireless network manager - daemon
ii  wicd-gtk                                                    1.7.4+tb2-6+devuan1.1              all          wired and wireless network manager - GTK+ client

My sources.list contents:

[bgstack15@ltb-013|/etc/apt/sources.list.d]$ grep -hviE '^(#|$)' /etc/apt/sources.list /etc/apt/sources.list.d/*
deb http://packages.devuan.org/merged ceres main contrib non-free
deb-src http://packages.devuan.org/merged ceres main contrib non-free
deb http://albion320.no-ip.biz/smith122/repo/devuan-deb/ /
deb http://packages.devuan.org/devuan ceres main contrib non-free
deb http://download.opensuse.org/repositories/home:/bgstack15/Debian_Unstable/ /
deb http://albion320.no-ip.biz/smith122/repo/deb/ /
deb http://linux.teamviewer.com/deb stable main

I will chalk this up to a non-pristine system, and that I should reinstall soon. Thank you so much for your help, Ralph!

Offline

#8 2019-08-02 11:12:02

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 375  

Re: [SOLVED] Ceres 64-bit and cannot install wine32:i386

After some experiments, I've come to believe that the reason for this problem (that libuuid1 installation causes havoc) is something else than what I suggested. I'm not sure exactly what the issue is, but it seems to come up following the plain upgrade from ascii to beowulf.

Offline

#9 2019-08-03 08:23:47

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 375  

Re: [SOLVED] Ceres 64-bit and cannot install wine32:i386

Eventually I worked something out. smile

The cause of this problem is simply that apt does not see different dependency chains for different architectures. Therefore, where a package (like libuuid1) has different version codes for amd64 and i386, then, in a multi-architecture setting, the attempt to install the one will "knock out" the other, with all its ramifications.

libuuid1:amd64 and libuuid1:i386 have different version codes in Devuan beowulf.

A smaller and safer example to experiment with would be xfsdump, where also xfsdump:amd64 and xfsdump:i386 have different version codes. It's easy to see that installing the one will knock out the other (without a total system havoc). (This package is similar in Debian buster, with two different version codes for the different architectures)

Offline

#10 2019-08-03 14:00:14

bgstack15
Member
Registered: 2018-02-04
Posts: 72  

Re: [SOLVED] Ceres 64-bit and cannot install wine32:i386

I had noticed it was referring to a "libuuid1:amd64 2.32.1-0.1+devuan2.1" but the i386 was "libuuid1:i386=2.33.1-0.1+devuan1." I realize I'm using the unstable, release, so it can have more problems like this. I think the multiarch page or another page about it talked about how the versions need to match across architectures.
So perhaps it's a temporary issue until the i386 and amd64 packages are at the same version number. What doesn't make sense is my second Devuan system was able to apt-get dist-upgrade and wine32 was still there, and everything.

Offline

#11 2019-08-03 15:18:25

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 319  
Website

Re: [SOLVED] Ceres 64-bit and cannot install wine32:i386

ralph.ronnquist wrote:

libuuid1:amd64 and libuuid1:i386 have different version codes in Devuan beowulf.

FWIW, I'm not seeing that in my Debian buster system. Both versions of libuuid1 are co-installable and e2fsprogs is not uninstalled in the process:

E485:~$ apt policy libuuid1{,:i386} e2fsprogs
libuuid1:
  Installed: 2.33.1-0.1
  Candidate: 2.33.1-0.1
  Version table:
 *** 2.33.1-0.1 500
        500 https://cdn-aws.deb.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status
libuuid1:i386:
  Installed: 2.33.1-0.1
  Candidate: 2.33.1-0.1
  Version table:
 *** 2.33.1-0.1 500
        500 https://cdn-aws.deb.debian.org/debian buster/main i386 Packages
        100 /var/lib/dpkg/status
e2fsprogs:
  Installed: 1.44.5-1
  Candidate: 1.44.5-1
  Version table:
 *** 1.44.5-1 500
        500 https://cdn-aws.deb.debian.org/debian buster/main amd64 Packages
        100 /var/lib/dpkg/status
E485:~$

The xfsdump amd64 package had a version bump to deal with https://bugs.debian.org/cgi-bin/bugrepo … =%23837581 but the other architectures didn't, I think this may be worth a bug report.


Fabricando fit faber

Offline

#12 2019-08-03 16:12:39

juic3
Member
Registered: 2018-11-27
Posts: 5  

Re: [SOLVED] Ceres 64-bit and cannot install wine32:i386

I have same problem (cant install wine32). Only Beowulf sources.

apt policy libuuid1{,:i386} e2fsprogs
libuuid1:
  Installed: 2.32.1-0.1+devuan2.1
  Candidate: 2.32.1-0.1+devuan2.1
  Version table:
 *** 2.32.1-0.1+devuan2.1 500
        500 http://deb.devuan.org/merged beowulf/main amd64 Packages
        100 /var/lib/dpkg/status
libuuid1:i386:
  Installed: (none)
  Candidate: 2.33.1-0.1+devuan1
  Version table:
     2.33.1-0.1+devuan1 500
        500 http://deb.devuan.org/merged beowulf/main i386 Packages
e2fsprogs:
  Installed: 1.44.5-1
  Candidate: 1.44.5-1
  Version table:
 *** 1.44.5-1 500
        500 http://deb.devuan.org/merged beowulf/main amd64 Packages
        100 /var/lib/dpkg/status

(edited copy paste error)

Last edited by juic3 (2019-08-03 16:17:26)

Offline

#13 2019-08-04 17:41:12

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 319  
Website

Re: [SOLVED] Ceres 64-bit and cannot install wine32:i386

juic3 wrote:

I have same problem (cant install wine32).

What does this say

aptitude why-not wine32

Fabricando fit faber

Offline

#14 2019-08-04 18:23:37

juic3
Member
Registered: 2018-11-27
Posts: 5  

Re: [SOLVED] Ceres 64-bit and cannot install wine32:i386

$ aptitude why-not wine32
Not currently installed
No dependencies require to remove wine32

Offline

#15 2019-08-04 18:29:47

juic3
Member
Registered: 2018-11-27
Posts: 5  

Re: [SOLVED] Ceres 64-bit and cannot install wine32:i386

Aptitude simulation gives this:

$ aptitude -s -y install wine32
Note: selecting "wine32:i386" instead of the virtual package "wine32"
The following NEW packages will be installed:
  gcc-8-base:i386{a} gstreamer1.0-plugins-base:i386{a} 
  i965-va-driver:i386{a} intel-media-va-driver:i386{a} libaom0:i386{a} 
  libasound2:i386{a} libasound2-plugins:i386{a} libasyncns0:i386{a} 
  libatomic1:i386{a} libavahi-client3:i386{a} libavahi-common-data:i386{a} 
  libavahi-common3:i386{a} libavcodec58:i386{a} libavresample4:i386{a} 
  libavutil56:i386{a} libblkid1:i386{ab} libbsd0:i386{a} libc6:i386{a} 
  libcairo2:i386{a} libcap2:i386{a} libcapi20-3:i386{a} 
  libcdparanoia0:i386{a} libcodec2-0.8.1:i386{a} libcom-err2:i386{a} 
  libcroco3:i386{a} libcrystalhd3:i386{a} libcups2:i386{a} 
  libdatrie1:i386{a} libdb5.3:i386{a} libdbus-1-3:i386{a} 
  libdrm-amdgpu1:i386{a} libdrm-intel1:i386{a} libdrm-nouveau2:i386{a} 
  libdrm-radeon1:i386{a} libdrm2:i386{a} libedit2:i386{a} libelf1:i386{a} 
  libelogind0:i386{ab} libeudev1:i386{a} libexif12:i386{a} 
  libexpat1:i386{a} libffi6:i386{a} libflac8:i386{a} libfontconfig1:i386{a} 
  libfreetype6:i386{a} libfribidi0:i386{a} libgcc1:i386{a} 
  libgcrypt20:i386{a} libgd3:i386{a} libgdk-pixbuf2.0-0:i386{a} 
  libgl1:i386{a} libgl1-mesa-dri:i386{a} libglapi-mesa:i386{a} 
  libglib2.0-0:i386{a} libglu1-mesa:i386{a} libglvnd0:i386{a} 
  libglx-mesa0:i386{a} libglx0:i386{a} libgmp10:i386{a} libgnutls30:i386{a} 
  libgomp1:i386{a} libgpg-error0:i386{a} libgphoto2-6:i386{a} 
  libgphoto2-port12:i386{a} libgpm2:i386{a} libgraphite2-3:i386{a} 
  libgsm1:i386{a} libgssapi-krb5-2:i386{a} 
  libgstreamer-plugins-base1.0-0:i386{a} libgstreamer1.0-0:i386{a} 
  libharfbuzz0b:i386{a} libhogweed4:i386{a} libice6:i386{a} 
  libicu63:i386{a} libidn2-0:i386{a} libigdgmm5:i386{a} 
  libjack-jackd2-0:i386{a} libjbig0:i386{a} libjpeg62-turbo:i386{a} 
  libk5crypto3:i386{a} libkeyutils1:i386{a} libkrb5-3:i386{a} 
  libkrb5support0:i386{a} liblcms2-2:i386{a} libldap-2.4-2:i386{a} 
  libllvm7:i386{a} libltdl7:i386{a} liblzma5:i386{a} libmount1:i386{ab} 
  libmp3lame0:i386{a} libmpg123-0:i386{a} libncurses6:i386{a} 
  libnettle6:i386{a} libnuma1:i386{a} libodbc1:i386{a} libogg0:i386{a} 
  libopenal1:i386{a} libopenjp2-7:i386{a} libopus0:i386{a} 
  liborc-0.4-0:i386{a} libosmesa6:i386{a} libp11-kit0:i386{a} 
  libpango-1.0-0:i386{a} libpangocairo-1.0-0:i386{a} 
  libpangoft2-1.0-0:i386{a} libpcap0.8:i386{a} libpciaccess0:i386{a} 
  libpcre3:i386{a} libpixman-1-0:i386{a} libpng16-16:i386{a} 
  libpulse0:i386{a} librsvg2-2:i386{a} librsvg2-common:i386{a} 
  libsamplerate0:i386{a} libsasl2-2:i386{a} libsasl2-modules:i386{a} 
  libsasl2-modules-db:i386{a} libsdl2-2.0-0:i386{a} libselinux1:i386{a} 
  libsensors5:i386{a} libshine3:i386{a} libsm6:i386{a} libsnappy1v5:i386{a} 
  libsndfile1:i386{a} libsndio7.0:i386{a} libsoxr0:i386{a} 
  libspeex1:i386{a} libssl1.1:i386{a} libstdc++6:i386{a} 
  libswresample3:i386{a} libtasn1-6:i386{a} libthai0:i386{a} 
  libtheora0:i386{a} libtiff5:i386{a} libtinfo6:i386{a} libtwolame0:i386{a} 
  libunistring2:i386{a} libusb-1.0-0:i386{a} libuuid1:i386{ab} 
  libv4l-0:i386{a} libv4lconvert0:i386{a} libva-drm2:i386{a} 
  libva-x11-2:i386{a} libva2:i386{a} libvdpau-va-gl1:i386{a} 
  libvdpau1:i386{a} libvisual-0.4-0:i386{a} libvkd3d1:i386{a} 
  libvorbis0a:i386{a} libvorbisenc2:i386{a} libvpx5:i386{a} 
  libvulkan1:i386{a} libwavpack1:i386{a} libwayland-client0:i386{a} 
  libwayland-cursor0:i386{a} libwayland-egl1:i386{a} libwebp6:i386{a} 
  libwebpmux3:i386{a} libwine:i386{a} libwrap0:i386{a} libx11-6:i386{a} 
  libx11-xcb1:i386{a} libx264-155:i386{a} libx265-165:i386{a} 
  libxau6:i386{a} libxcb-dri2-0:i386{a} libxcb-dri3-0:i386{a} 
  libxcb-glx0:i386{a} libxcb-present0:i386{a} libxcb-render0:i386{a} 
  libxcb-shm0:i386{a} libxcb-sync1:i386{a} libxcb-xfixes0:i386{a} 
  libxcb1:i386{a} libxcomposite1:i386{a} libxcursor1:i386{a} 
  libxdamage1:i386{a} libxdmcp6:i386{a} libxext6:i386{a} libxfixes3:i386{a} 
  libxi6:i386{a} libxinerama1:i386{a} libxkbcommon0:i386{a} libxml2:i386{a} 
  libxpm4:i386{a} libxrandr2:i386{a} libxrender1:i386{a} 
  libxshmfence1:i386{a} libxslt1.1:i386{a} libxss1:i386{a} libxtst6:i386{a} 
  libxvidcore4:i386{a} libxxf86vm1:i386{a} libzstd1:i386{a} 
  libzvbi0:i386{a} mesa-va-drivers:i386{a} mesa-vdpau-drivers:i386{a} 
  ocl-icd-libopencl1:i386{a} va-driver-all:i386{a} vdpau-driver-all:i386{a} 
  wine32:i386 zlib1g:i386{a} 
0 packages upgraded, 202 newly installed, 0 to remove and 0 not upgraded.
Need to get 42.6 MB/110 MB of archives. After unpacking 673 MB will be used.
The following packages have unmet dependencies:
 libmount1 : Breaks: libmount1:i386 (!= 2.32.1-0.1+devuan2.1) but 2.33.1-0.1+devuan1 is to be installed
 libmount1:i386 : Breaks: libmount1 (!= 2.33.1-0.1+devuan1) but 2.32.1-0.1+devuan2.1 is installed
 libblkid1 : Breaks: libblkid1:i386 (!= 2.32.1-0.1+devuan2.1) but 2.33.1-0.1+devuan1 is to be installed
 libblkid1:i386 : Breaks: libblkid1 (!= 2.33.1-0.1+devuan1) but 2.32.1-0.1+devuan2.1 is installed
 libuuid1 : Breaks: libuuid1:i386 (!= 2.32.1-0.1+devuan2.1) but 2.33.1-0.1+devuan1 is to be installed
 libuuid1:i386 : Breaks: libuuid1 (!= 2.33.1-0.1+devuan1) but 2.32.1-0.1+devuan2.1 is installed
 libelogind0 : Breaks: libelogind0:i386 (!= 241.3-1) but 241.1-1 is to be installed
 libelogind0:i386 : Breaks: libelogind0 (!= 241.1-1) but 241.3-1 is installed
The following actions will resolve these dependencies:

      Keep the following packages at their current version:                     
1)      gstreamer1.0-plugins-base:i386 [Not Installed]                          
2)      libasound2-plugins:i386 [Not Installed]                                 
3)      libavcodec58:i386 [Not Installed]                                       
4)      libblkid1:i386 [Not Installed]                                          
5)      libcairo2:i386 [Not Installed]                                          
6)      libcroco3:i386 [Not Installed]                                          
7)      libelogind0:i386 [Not Installed]                                        
8)      libfontconfig1:i386 [Not Installed]                                     
9)      libgd3:i386 [Not Installed]                                             
10)     libgdk-pixbuf2.0-0:i386 [Not Installed]                                 
11)     libglib2.0-0:i386 [Not Installed]                                       
12)     libgphoto2-6:i386 [Not Installed]                                       
13)     libgstreamer-plugins-base1.0-0:i386 [Not Installed]                     
14)     libgstreamer1.0-0:i386 [Not Installed]                                  
15)     libharfbuzz0b:i386 [Not Installed]                                      
16)     libmount1:i386 [Not Installed]                                          
17)     libpango-1.0-0:i386 [Not Installed]                                     
18)     libpangocairo-1.0-0:i386 [Not Installed]                                
19)     libpangoft2-1.0-0:i386 [Not Installed]                                  
20)     libpulse0:i386 [Not Installed]                                          
21)     librsvg2-2:i386 [Not Installed]                                         
22)     librsvg2-common:i386 [Not Installed]                                    
23)     libsdl2-2.0-0:i386 [Not Installed]                                      
24)     libsm6:i386 [Not Installed]                                             
25)     libtheora0:i386 [Not Installed]                                         
26)     libuuid1:i386 [Not Installed]                                           
27)     libwine:i386 [Not Installed]                                            
28)     wine32:i386 [Not Installed]                                             

      Leave the following dependencies unresolved:                              
29)     libgstreamer-plugins-base1.0-0:i386 recommends gstreamer1.0-plugins-base
30)     libopenal1:i386 recommends libpulse0:i386 (>= 0.99.1)                   



No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
Would download/install/remove packages.

Offline

#16 2019-08-04 18:57:11

Head_on_a_Stick
Member
From: London
Registered: 2019-03-24
Posts: 319  
Website

Re: [SOLVED] Ceres 64-bit and cannot install wine32:i386

juic3 wrote:
The following packages have unmet dependencies:
 libmount1 : Breaks: libmount1:i386 (!= 2.32.1-0.1+devuan2.1) but 2.33.1-0.1+devuan1 is to be installed
 libmount1:i386 : Breaks: libmount1 (!= 2.33.1-0.1+devuan1) but 2.32.1-0.1+devuan2.1 is installed
 libblkid1 : Breaks: libblkid1:i386 (!= 2.32.1-0.1+devuan2.1) but 2.33.1-0.1+devuan1 is to be installed
 libblkid1:i386 : Breaks: libblkid1 (!= 2.33.1-0.1+devuan1) but 2.32.1-0.1+devuan2.1 is installed
 libuuid1 : Breaks: libuuid1:i386 (!= 2.32.1-0.1+devuan2.1) but 2.33.1-0.1+devuan1 is to be installed
 libuuid1:i386 : Breaks: libuuid1 (!= 2.33.1-0.1+devuan1) but 2.32.1-0.1+devuan2.1 is installed
 libelogind0 : Breaks: libelogind0:i386 (!= 241.3-1) but 241.1-1 is to be installed
 libelogind0:i386 : Breaks: libelogind0 (!= 241.1-1) but 241.3-1 is installed

Looks like beowulf has different versions of those packages for i386 & amd64, this can also be seen in your apt policy output.

No idea why, the Debian buster repositories have the same versions for both i386 & amd64 (apart from xfsdump).


Fabricando fit faber

Offline

#17 2019-08-04 22:15:27

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 375  

Re: [SOLVED] Ceres 64-bit and cannot install wine32:i386

Yeah, the "problem" is also found in Debian buster; I got a count of some ~120 packages with different version codes between amd64 and i386, and some ~30 more cases added for Devuan beowulf alone. It would appear to be some weakness in the automatic build pipeline, except of course were it is on purpose (if any).

I'm not sure why I had thought that there would be separate "version planes" for the different architectures. Obviously I have just been lucky at my multi-arch excursions smile

TL;DR; I compared various distributions by looking at their Packages files, which get downloaded into /var/lib/apt/lists/ when the repositories are in the sources list. Each of those files include the meta information about the packages of the distribution, where e.g. deb.devuan.org_merged_dists_beowulf_main_binary-amd64_Packages tells the story about the binary packages in beowulf's main section for the amd64 architecture.

The Packages files are also manually downloadable over HTTP from the repositories, e.g. for comparing distribution sections for other reasons.

From there, it's a matter of some scripting to compare package versions between a pair of such files. That comparison gets a bit fiddly since there are packages that only belong to the one or the other, as well as common packages with meta data differences other than version codes. But that's where your newlisp skills get a freshening (or you might choose to use some lesser scripting language) smile

Offline

#18 2019-08-10 16:18:18

bgstack15
Member
Registered: 2018-02-04
Posts: 72  

Re: [SOLVED] Ceres 64-bit and cannot install wine32:i386

The original is now happening on a pristine install of Devuan 2.0 which was dist-upgraded to ceres.
Here are my sources:

[root@ltb-005|/root]# grep -h -viE '^\s*($|#)' /etc/apt/sources.list /etc/apt/sources.list.d/*
deb http://us.deb.devuan.org/merged ceres main contrib non-free
deb-src http://us.deb.devuan.org/merged ceres main
deb http://albion320.no-ip.biz/smith122/repo/devuan-deb/ /
deb http://download.opensuse.org/repositories/home:/bgstack15/Debian_Unstable/ /
deb http://albion320.no-ip.biz/smith122/repo/deb/ /
deb https://dl.winehq.org/wine-builds/debian/ sid main

After setting the "ceres" in the files, I did the upgrade and then dist-upgrade.

Is this process wrong? I really want wine32 present on my system, and I feel that this weird arrangement of underlying packages is not a legitimate reason to not get wine32 somehow on my systems.

Offline

#19 2019-08-10 16:58:18

bgstack15
Member
Registered: 2018-02-04
Posts: 72  

Re: [SOLVED] Ceres 64-bit and cannot install wine32:i386

I've traced it down to the fact that there's an extra libuuid1 package, with a higher version number, at http://deb.devuan.org//devuan/pool/main/u/util-linux/. (And two other low-level packages with higher version numbers).

I am now installing winehq-staging right now, and here are the steps I used to get around the problems encountered earlier:

wget http://deb.devuan.org/devuan/pool/main/u/util-linux/libuuid1_2.32.1-0.1+devuan2.1_i386.deb
sudo apt-get -o Dpkg::Options::="--force-overwrite" install ./libuuid1_2.32.1-0.1+devuan2.1_i386.deb
# syntax from bugs.debian.org 768651
wget http://deb.devuan.org/devuan/pool/main/u/util-linux/libblkid1_2.32.1-0.1+devuan2.1_i386.deb
sudo apt-get  install ./libblkid1_2.32.1-0.1+devuan2.1_i386.deb
wget http://deb.devuan.org/devuan/pool/main/u/util-linux/libmount1_2.32.1-0.1+devuan2.1_i386.deb
sudo apt-get install ./libmount1_2.32.1-0.1+devuan2.1_i386.deb

I know the steps can be cleaned up, but the above is the order I took them in.
Here is the cleaned up version:

wget http://deb.devuan.org/devuan/pool/main/u/util-linux/libuuid1_2.32.1-0.1+devuan2.1_i386.deb http://deb.devuan.org/devuan/pool/main/u/util-linux/libblkid1_2.32.1-0.1+devuan2.1_i386.deb http://deb.devuan.org/devuan/pool/main/u/util-linux/libmount1_2.32.1-0.1+devuan2.1_i386.deb
sudo apt-get -o Dpkg::Options::="--force-overwrite" install ./libuuid1_2.32.1-0.1+devuan2.1_i386.deb 
# syntax from bugs.debian.org 768651
sudo apt-get install ./libblkid1_2.32.1-0.1+devuan2.1_i386.deb ./libmount1_2.32.1-0.1+devuan2.1_i386.deb

Offline

#20 2019-08-10 16:58:31

golinux
Administrator
Registered: 2016-11-25
Posts: 1,734  

Re: [SOLVED] Ceres 64-bit and cannot install wine32:i386

OT observation . . . I don't think that there is a pkg mirror in the US

Online

#21 2019-08-14 04:03:23

fanfoue70
Member
Registered: 2018-04-23
Posts: 15  

Re: [SOLVED] Ceres 64-bit and cannot install wine32:i386

Hello,
I can't install winehq (added a /etc/apt/sources.list.d/winehq.list file with deb https://dl.winehq.org/wine-builds/debian/ buster main).
There's a libelogind0 version problem : installed amd64 version is 241.3-1, installable i386 is 241.1-1 (no other version available).
What can I do ?
Thank you !

Offline

#22 2019-08-17 13:52:52

yusdacra
Member
Registered: 2019-08-17
Posts: 1  

Re: [SOLVED] Ceres 64-bit and cannot install wine32:i386

I'm having the same problem too. Any ETA on when this will be fixed, or can i fix this myself? I have tried that "equivs" thing but for some reason i can't build? I just wanted to play some games...

Offline

#23 2019-08-19 08:16:16

fanfoue70
Member
Registered: 2018-04-23
Posts: 15  

Re: [SOLVED] Ceres 64-bit and cannot install wine32:i386

I answer to myself.
To make a 241.3-1 i386 deb, I downloaded it from debian website (http://ftp.de.debian.org/debian/pool/ma … 1_i386.deb for example).
It is not installable as is since the version includes "+debian1". To modify the version :

mkdir tmp
dpkg-deb -R libelogind0_241.3-1+debian1_i386.deb tmp
cd tmp/DEBIAN
# edit DEBIAN/control : modify "Version:" line : remove "+debian1"
cd ../..
dpkg-deb -b tmp libelogind0_241.3-1_i386.deb

Install modified deb, then follow bgstack15 post (https://dev1galaxy.org/viewtopic.php?pid=17389#p17389) to install libblkid1/libmount1/libuuid1 dependencies as needed.

Offline

#24 2019-10-06 15:22:59

tlapicka
Member
Registered: 2017-12-19
Posts: 1  

Re: [SOLVED] Ceres 64-bit and cannot install wine32:i386

In this time (October 2019) I must install/downgrade this packages:

    elogind_241.1-1_amd64.deb
    libelogind0_241.1-1_amd64.deb
    libpam-elogind_241.1-1_amd64.deb
    libblkid1_2.32.1-0.1+devuan2.1_i386.deb
    libmount1_2.32.1-0.1+devuan2.1_i386.deb
    libuuid1_2.32.1-0.1+devuan2.1_i386.deb

My solution is add ascii repositories for installation time and downgrade this packages.

Offline

#25 2019-10-18 22:03:01

geki
Member
Registered: 2019-02-04
Posts: 23  

Re: [SOLVED] Ceres 64-bit and cannot install wine32:i386

Current state here with Beowulf is this:

 libblkid1 : Beschädigt: libblkid1:i386 (!= 2.33.1-0.1+devuan1~beowulf1) aber 2.33.1-0.1+devuan1 soll installiert werden
 libblkid1:i386 : Beschädigt: libblkid1 (!= 2.33.1-0.1+devuan1) aber 2.33.1-0.1+devuan1~beowulf1 soll installiert werden
 libmount1 : Beschädigt: libmount1:i386 (!= 2.33.1-0.1+devuan1~beowulf1) aber 2.33.1-0.1+devuan1 soll installiert werden
 libmount1:i386 : Beschädigt: libmount1 (!= 2.33.1-0.1+devuan1) aber 2.33.1-0.1+devuan1~beowulf1 soll installiert werden
 libuuid1 : Beschädigt: libuuid1:i386 (!= 2.33.1-0.1+devuan1~beowulf1) aber 2.33.1-0.1+devuan1 soll installiert werden
 libuuid1:i386 : Beschädigt: libuuid1 (!= 2.33.1-0.1+devuan1) aber 2.33.1-0.1+devuan1~beowulf1 soll installiert werden

Got around that by downloading the packages with the superfluous '~beowulf1' suffix. If you do it the first time, you do not need the version tag with the package names.

apt-get download libblkid-dev=2.33.1-0.1+devuan1~beowulf1 libblkid1=2.33.1-0.1+devuan1~beowulf1 libmount-dev=2.33.1-0.1+devuan1~beowulf1 libmount1=2.33.1-0.1+devuan1~beowulf1 libuuid1=2.33.1-0.1+devuan1~beowulf1 mount=2.33.1-0.1+devuan1~beowulf1 uuid-dev=2.33.1-0.1+devuan1~beowulf1

And removing that version suffix with this bash script by executing: ./pkg_remove_version_suffix.sh '~beowulf1'
Make sure to have the necessary helper binaries installed!

#!/bin/bash

remove_suffix()
{
	local dpkg
	for dpkg in *${1}*.deb
	do
		mkdir temp_${dpkg}

		dpkg-deb -R ${dpkg} temp_${dpkg}

		sed -e "s/${1}//g" -i temp_${dpkg}/DEBIAN/control

		dpkg-deb -b temp_${dpkg} ${dpkg/${1}}

		rm -rf ${dpkg} temp_${dpkg}
	done
}

if [ -z ${1} ]
then
	echo "no suffix passed to remove"
	exit 1
fi

remove_suffix ${1}

apt-get -o Dpkg::Options::="--force-overwrite" install ./*.deb

exit ${?}

Last edited by geki (2019-10-18 22:08:28)

Offline

Board footer