The officially official Devuan Forum!

You are not logged in.

#1 2018-10-29 21:35:27

willbprogz227
Member
Registered: 2018-09-06
Posts: 23  

System is brought down by surf-git running performance site

Hey folks,

I was cruising along fine yesterday on Devuan when I compiled the git version of the surf browser git clone https://git.suckless.org/surf.  I then visited the browserbench.com site and ran MotionMark with the newly compiled surf binary.  When it got to the 'soft orbs' part of the test, the screen turns off suddenly, Devuan just vanishes then the computer reboots but there is no video.

I almost said some discouraging words, thinking my brand new Radeon card was toast, but after shutting down the computer, then turning it back on again the video was back, but now things were taking longer to boot (not counting the journal recovery time on my drives the boot afterward).  Weird.

I have mounted the Devuan system partition read-only from another distro and there is not one clue as to what happened.  I looked in Xorg.0.log, dmesg, debug, messages, kern.log and other logs and everything looks like a normal system startup but without the typical shut-down messages.

If there's anyone who is adventurous enough to reproduce this for me, I'd appreciate it, so I can submit a bug (but on what package??).  I reproduced it myself, so it's not some one-off thing.  An app in userspace should not have the ability to crash the whole computer and confuzzle the video card.  Very very unusual.

* ASUS M5A78L-M PLUS/USB3 motherboard, latest BIOS
* AMD FX-6300 Six-Core Processor
* ASRock Radeon RX 460 PCI-E video card
* amdgpu Xorg driver
* JWM window manager
* Mate components such as: Caja, Atril and Mate terminal


No longer using Devuan.  No longer using this forum.  No longer trying to help... sad

Offline

#2 2018-10-30 20:27:45

willbprogz227
Member
Registered: 2018-09-06
Posts: 23  

Re: System is brought down by surf-git running performance site

I have tried this exact sequence in a VM running Devuan Ascii and while it freezes the display for a few, it becomes unfrozen and finishes the performance test.  So it's either a driver issue or maybe an issue with the Devuan-provided AMD firmware.

Last edited by willbprogz227 (2018-10-30 20:28:26)


No longer using Devuan.  No longer using this forum.  No longer trying to help... sad

Offline

#3 2018-10-31 04:23:59

willbprogz227
Member
Registered: 2018-09-06
Posts: 23  

Re: System is brought down by surf-git running performance site

I nuked Devuan and installed the current Debian in its place.  I then did the steps to reproduce the problem and it happens on Debian, as well.  On Debian, I was able to uninstall firmware-amd-graphics rebooted, then tried the steps again and it did NOT crash the system, so it appears firmware-amd-graphics is the culprit.

I used reportbug on Debian and filled everything out, only for reportbug to eat my report! yikes

I will see what Devuan uses for bug reporting and give that a shot...


No longer using Devuan.  No longer using this forum.  No longer trying to help... sad

Offline

#4 2018-10-31 15:12:31

golinux
Administrator
Registered: 2016-11-25
Posts: 1,371  

Re: System is brought down by surf-git running performance site

Try submitting by email rather than reportbug

Online

#5 2018-10-31 15:45:51

willbprogz227
Member
Registered: 2018-09-06
Posts: 23  

Re: System is brought down by surf-git running performance site

golinux wrote:

Try submitting by email rather than reportbug

@golinux, thanks for that.  I was able to finally submit it, although the feedback from my bug report is already not very encouraging.


No longer using Devuan.  No longer using this forum.  No longer trying to help... sad

Offline

Board footer