The officially official Devuan Forum!

You are not logged in.

#1 2018-10-25 14:04:48

James1138
Member
Registered: 2018-09-27
Posts: 16  

How to upgrade Claws Mail client to Stretch backport

I first added the Stretch backports to the sources list but when I then installed Claws Mail email client - I found version 3.14 installed instead of the 3.17 in the backport.

Help,

Thanks,
James
Indiana/USA

Offline

#2 2018-10-25 14:51:07

ilargi
Member
Registered: 2017-06-23
Posts: 8  

Re: How to upgrade Claws Mail client to Stretch backport

You may want to try adding this to /etc/apt/sources.list instead of stretch-backports:

deb http://deb.devuan.org/merged ascii-backports main

Update your sources:

apt-get update

And now install claws-mail-3.17

apt-get install -t ascii-backports claws-mail

Hope this helps|

Offline

#3 2018-10-25 15:15:13

golinux
Administrator
Registered: 2016-11-25
Posts: 1,371  

Re: How to upgrade Claws Mail client to Stretch backport

@James1138 . . . never use Debian repos directly.  Our Devuan mirror(s) filter unwanted packages that are incompatible with Devuan.

Online

#4 2018-10-26 14:28:07

James1138
Member
Registered: 2018-09-27
Posts: 16  

Re: How to upgrade Claws Mail client to Stretch backport

Thanks for the tip. Did that but found I shall stay with 3.14 because 3.17 forces a person to install Dillo.

James
Indiana/USA

Offline

#5 2018-10-26 15:18:31

ilargi
Member
Registered: 2017-06-23
Posts: 8  

Re: How to upgrade Claws Mail client to Stretch backport

claws-mail 3.17 wanting to drag dillo is most likely just because you are also trying to install claws-mail-dillo-viewer or claws-mail-extra-plugins. These two have dillo as a dependency, but not claws-mail itself.
You can check dependencies here:
https://pkginfo.devuan.org/

Last edited by ilargi (2018-10-26 15:35:31)

Offline

Board footer