The officially official Devuan Forum!

You are not logged in.

#1 2018-09-21 18:10:31

VH
Member
Registered: 2018-07-31
Posts: 12  

Tried to Install libav-tools then I got this message

I got this message while trying to install libav-tools

user@localhost:~$ sudo aptitude install libav-tools
[sudo] password for user: 
The following NEW packages will be installed:
  libav-tools libavdevice55{a} libavfilter5{a} libopencv-core2.4{a} 
  libopencv-imgproc2.4{a} libtbb2{a} 
0 packages upgraded, 6 newly installed, 0 to remove and 1 not upgraded.
Need to get 2,225 kB of archives. After unpacking 8,557 kB will be used.
Do you want to continue? [Y/n/?] Y
WARNING: untrusted versions of the following packages will be installed!

Untrusted packages could compromise your system's security.
You should only proceed with the installation if you are certain that
this is what you want to do.

  libopencv-core2.4 libavfilter5 libopencv-imgproc2.4 libav-tools 
  libavdevice55 libtbb2 

Do you want to ignore this warning and proceed anyway?
To continue, enter "Yes"; to abort, enter "No":

Is this has to do with all the packages not being devuanized?  Or is this has to do with sources.list?

Above all, is this safe to go ahead with "Yes" and install everything it wants?

Thanks.

Offline

#2 2018-09-21 18:54:07

GNUser
Member
Registered: 2017-03-16
Posts: 420  

Re: Tried to Install libav-tools then I got this message

You must have at least one unofficial repository in /etc/apt/sources.list, since most of these packages (libopencv-core2.4 libavfilter5 libopencv-imgproc2.4 libavdevice55) are not in Devuan's main, contrib, or non-free repositories. Two of the packages (libav-tools libtbb2) are in the Devuan repositories, but the unofficial repository you are using must have a more recent version, which is why apt is trying to install unofficial/untrusted versions of these packages as well.

If what you need is libav-tools, disable the unofficial repository and install the package from Devuan's repository. (I'd stay away from third-party repositories in general--in addition to the trust issue, it can cause dependency hell down the road.)

Last edited by GNUser (2018-09-21 19:02:43)

Offline

#3 2018-10-03 20:01:44

VH
Member
Registered: 2018-07-31
Posts: 12  

Re: Tried to Install libav-tools then I got this message

Sorry for the late reply. 

You must have at least one unofficial repository in /etc/apt/sources.list, since most of these packages (libopencv-core2.4 libavfilter5 libopencv-imgproc2.4 libavdevice55) are not in Devuan's main, contrib, or non-free repositories. Two of the packages (libav-tools libtbb2) are in the Devuan repositories, but the unofficial repository you are using must have a more recent version, which is why apt is trying to install unofficial/untrusted versions of these packages as well.

If what you need is libav-tools, disable the unofficial repository and install the package from Devuan's repository. (I'd stay away from third-party repositories in general--in addition to the trust issue, it can cause dependency hell down the road.)

I don't understand this no matter how many times I read this.  You mean I have to have "at least one unofficial repository in /etc/apt/sources.list"  But you also said "If what you need is libav-tools, disable the unofficial repository and install the package from Devuan's repository." 

I really don't get it.  You said I need at list one unofficial repository.   I need libav-tools, but why disable unofficial repository and install the package from Devuan's repository when Devuan's repository don't seem to have those packages?

My sources.list look like below

# Devuan Jessie Main
deb http://pkgmaster.devuan.org/merged jessie main
deb-src http://pkgmaster.devuan.org/merged jessie main

# jessie-security
deb http://pkgmaster.devuan.org/merged/ jessie-security main non-free
deb-src http://pkgmaster.devuan.org/merged/ jessie-security main non-free

# jessie-updates
deb http://pkgmaster.devuan.org/merged/ jessie-updates main non-free
deb-src http://pkgmaster.devuan.org/merged/ jessie-updates main non-free

# jessie contrib & non-free repository
# deb http://pkgmaster.devuan.org/merged jessie main contrib non-free
# deb-src http://pkgmaster.devuan.org/merged jessie main contrib non-free

Should I remove the hash tags from the last two lines?

Thanks in advance.

Offline

#4 2018-10-05 08:00:43

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 276  

Re: Tried to Install libav-tools then I got this message

No, you don't need to access contrib and/or non-free for this; all those packages (libopencv-core2.4, libavfilter5, libopencv-imgproc2.4, libav-tools, libavdevice55 and libtbb2) are available in jessie/main, and some of them also have upgrades in jessie-security/main.

Your OP warning probably relates to devuan-keyring, and it may help if you (re-)install that first, and then try again to install libav-tools.

Then as an aside: the current advice is that you should use deb.devuan.org instead of pkgmaster.devuan.org in your sources.list, so as to take advantage of the mirroring. But that's a different thing.

Online

#5 2018-10-05 20:20:27

HextorBRX
Member
Registered: 2017-08-20
Posts: 98  

Re: Tried to Install libav-tools then I got this message

ralph.ronnquist: could you explain why we should use deb.devuan.org instead of pkgmaster.devuan.org? This is useful information but I do not understand what you mean. Thanks.

Offline

#6 2018-10-05 20:56:00

golinux
Administrator
Registered: 2016-11-25
Posts: 1,339  

Re: Tried to Install libav-tools then I got this message

deb.devuan.org is a round-robin of these mirrors - http://pkgmaster.devuan.org/mirror_list.txt - that rsync with pkgmaster.devuan.org.

Online

#7 2018-10-07 23:28:19

VH
Member
Registered: 2018-07-31
Posts: 12  

Re: Tried to Install libav-tools then I got this message

I changed pkgmaster to deb in the file sources.list and the error messages are gone. 

Although I don't understand how this works, this must have been the devuan-keyring problem as ralph.ronnquist mentioned. 

Also, I thought read somewhere in Devuan official site that deb.devuan.org or something else (auto.mirror?) was getting depreciated.  Can anyone tell me which one is getting depreciated so I would not use the one that is being taken down.

I am using Jessie (old stable) btw. 

Problem is solved, but anybody who is willing help with my ignorance would be greatly appreciated. 

Thanks everyone.

Last edited by VH (2018-10-08 01:52:36)

Offline

#8 2018-10-08 09:32:50

HextorBRX
Member
Registered: 2017-08-20
Posts: 98  

Re: Tried to Install libav-tools then I got this message

I changed pkgmaster to deb in the file sources.list and the error messages are gone.

Good to know, thanks for sharing. No problem with pkgmaster on ascii: https://ibb.co/ef66KU

Also, I thought read somewhere in Devuan official site that deb.devuan.org or something else (auto.mirror?) was getting depreciated.  Can anyone tell me which one is getting depreciated so I would not use the one that is being taken down.

auto.mirror is depreciated and it does not appear in the ascii installer.

Last edited by HextorBRX (2018-10-08 14:50:11)

Offline

#9 2018-10-08 14:48:28

golinux
Administrator
Registered: 2016-11-25
Posts: 1,339  

Re: Tried to Install libav-tools then I got this message

auto.mirror was deprecated but then this happened a few weeks ago and now announced again after an oversight:

https://webmail.dyne.org/?_task=mail&_mbox=INBOX

Please consider joining the DNG mail list to keep current.

Online

#10 2018-10-08 22:58:25

VH
Member
Registered: 2018-07-31
Posts: 12  

Re: Tried to Install libav-tools then I got this message

After I changed from pkgmaster to deb, several softwares such as wicd and ibus has been disappeared from my taskbar.  When I checked with

aptitiude search

they were installed but I could not start.  What I did was purge them then reinstalled them. 

Also the "Printer Setting" icon from "Menu --> Settings" has disappeared.  Just like wicd and ibus, all the printer related software are in place, I had to reinstall system-config-printer. 

Any ideas why?

Thanks.

Offline

Board footer