The officially official Devuan Forum!

You are not logged in.

#1 2018-08-17 13:57:08

ismohaa
Member
Registered: 2018-08-17
Posts: 5  

VLC and Kaffeine won't install on Ascii [SOLVED]

I have a problem that I can't install VLC (actually it's Kaffeine that I really want to install, but it depends on some VLC-libraries).

# apt-get install vlc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 vlc : Depends: vlc-plugin-base (= 3.0.3-1-0+deb9u1) but 2.2.7-1~deb9u1 is to be installed
       Depends: vlc-plugin-video-output (= 3.0.3-1-0+deb9u1) but 2.2.7-1~deb9u1 is to be installed
       Depends: vlc-l10n (= 3.0.3-1-0+deb9u1) but it is not going to be installed
       Recommends: vlc-plugin-notify (= 3.0.3-1-0+deb9u1) but it is not going to be installed
       Recommends: vlc-plugin-samba (= 3.0.3-1-0+deb9u1) but it is not going to be installed
       Recommends: vlc-plugin-skins2 (= 3.0.3-1-0+deb9u1) but it is not going to be installed
       Recommends: vlc-plugin-video-splitter (= 3.0.3-1-0+deb9u1) but it is not going to be installed
       Recommends: vlc-plugin-visualization (= 3.0.3-1-0+deb9u1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

When I do a dist-upgrade it informs me that the following packages are held back: vlc-data vlc-plugin-video-output
I've tried to set those packages to be manually installed, but...

# apt-get install vlc-data vlc-plugin-video-output
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  accountsservice appstream bluez-obexd breeze-cursor-theme breeze-icon-theme catdoc
  cracklib-runtime fonts-hack-ttf fonts-lato fonts-oxygen gir1.2-packagekitglib-1.0
  gtk3-engines-breeze ieee-data javascript-common kactivities-bin kde-cli-tools-data
  kde-style-breeze kde-style-breeze-qt4 kde-style-qtcurve-qt4 kded5 kdegames-card-data-kf5
  kdegames-mahjongg-data-kf5 kdepasswd kdoctools5 khotkeys-data kio-extras-data kpackagetool5
  ksysguard-data ksysguardd ktexteditor-data kwin-data kwin-style-breeze libaccountsservice0
  libappstream4 libappstreamqt2 libbasicusageenvironment1 libbluetooth3 libcln6 libcrack2
  libdbusmenu-qt5-2 libdolphinvcs5 libdvbpsi10 libdvbv5-0 libebml4v5 libepub0 libgit2-24
  libgles1-mesa libglib2.0-bin libgpgmepp6 libgps22 libgrantlee-templates5 libgroupsock8
  libhttp-parser2.1 libical2 libiso9660-8 libjs-jquery libjs-underscore libkdecorations2-5v5
  libkdecorations2private5v5 libkf5activities5 libkf5activitiesstats1 libkf5archive5 libkf5attica5
  libkf5auth-data libkf5auth5 libkf5baloo5 libkf5balooengine5 libkf5baloowidgets-bin
  libkf5bluezqt-data libkf5bluezqt6 libkf5bookmarks-data libkf5bookmarks5 libkf5calendarevents5
  libkf5codecs-data libkf5codecs5 libkf5completion-data libkf5completion5 libkf5config-bin
  libkf5config-data libkf5configcore5 libkf5configgui5 libkf5configwidgets-data
  libkf5configwidgets5 libkf5coreaddons-data libkf5coreaddons5 libkf5crash5 libkf5dbusaddons-bin
  libkf5dbusaddons-data libkf5dbusaddons5 libkf5declarative-data libkf5dnssd-data libkf5dnssd5
  libkf5emoticons-bin libkf5emoticons-data libkf5emoticons5 libkf5filemetadata-bin
  libkf5filemetadata-data libkf5filemetadata3 libkf5globalaccel-bin libkf5globalaccel-data
  libkf5globalaccel5 libkf5globalaccelprivate5 libkf5guiaddons5 libkf5holidays-data
  libkf5holidays5 libkf5i18n-data libkf5i18n5 libkf5iconthemes-bin libkf5iconthemes-data
  libkf5iconthemes5 libkf5idletime5 libkf5itemmodels5 libkf5itemviews-data libkf5itemviews5
  libkf5jobwidgets-data libkf5jobwidgets5 libkf5js5 libkf5jsembed-data libkf5jsembed5
  libkf5kcmutils-data libkf5kdcraw5 libkf5kdelibs4support-data libkf5khtml-data libkf5kiocore5
  libkf5kiofilewidgets5 libkf5kiontlm5 libkf5kiowidgets5 libkf5kipi-data libkf5kipi31.0.0
  libkf5kmahjongglib5 libkf5networkmanagerqt6 libkf5newstuff-data libkf5notifications-data
  libkf5notifyconfig-data libkf5package-data libkf5package5 libkf5parts-data libkf5people-data
  libkf5people5 libkf5peoplebackend5 libkf5peoplewidgets5 libkf5pty-data libkf5pty5
  libkf5screen-bin libkf5screen7 libkf5service-bin libkf5service-data libkf5service5 libkf5solid5
  libkf5solid5-data libkf5sonnet5-data libkf5sonnetcore5 libkf5sonnetui5 libkf5style5 libkf5su-bin
  libkf5su-data libkf5su5 libkf5sysguard-bin libkf5sysguard-data libkf5textwidgets-data
  libkf5textwidgets5 libkf5threadweaver5 libkf5wallet-data libkf5waylandclient5
  libkf5waylandserver5 libkf5widgetsaddons-data libkf5widgetsaddons5 libkf5windowsystem-data
  libkf5windowsystem5 libkf5xmlgui-bin libkf5xmlgui-data libkf5xmlgui5 libkf5xmlrpcclient-data
  libkfontinst5 libkfontinstui5 libksgrd7 libksignalplotter7 libkwineffects9 libkwinglutils9
  libkwinxrenderutils9 libkworkspace5-5 liblivemedia57 liblmdb0 liblua5.2-0 libmatroska6v5
  libmtp-common libmtp-runtime libmtp9 libopenmpt-modplug1 liboxygenstyle5-5
  liboxygenstyleconfig5-5 libpackagekit-glib2-18 libpackagekitqt5-0 libphonon4qt5-4
  libplasma-geolocation-interface5 libpolkit-qt5-1-1 libpoppler-qt5-1 libpowerdevilui5
  libprocesscore7 libprocessui7 libpwquality-common libpwquality1 libqalculate5-data
  libqalculate5v5 libqgsttools-p1 libqt5clucene5 libqt5concurrent5 libqt5designer5
  libqt5designercomponents5 libqt5help5 libqt5multimedia5-plugins libqt5multimediaquick-p5
  libqt5multimediawidgets5 libqt5printsupport5 libqt5quickwidgets5 libqt5script5 libqt5sql5
  libqt5sql5-sqlite libqt5test5 libqt5webkit5 libqtcurve-utils2 libresid-builder0c2a libruby2.3
  libscim8v5 libsdl-image1.2 libsidplay2 libssh-4 libstemmer0d libupnp6 libusageenvironment3
  libvcdinfo0 libvlc-bin libvlc5 libvlccore8 libxcb-composite0 libxcb-cursor0 libxcb-damage0
  libxcb-dpms0 libxcb-record0 libzip4 oxygen-sounds packagekit packagekit-tools
  plasma-desktop-data plasma-discover-common polkit-kde-agent-1 powerdevil-data
  pulseaudio-module-gconf python3-dbus python3-pyqt5 python3-sip python3-software-properties
  qdbus-qt5 qml-module-org-kde-activities qml-module-org-kde-bluezqt
  qml-module-org-kde-extensionplugin qml-module-org-kde-kholidays qml-module-org-kde-solid
  qml-module-qt-labs-folderlistmodel qml-module-qt-labs-settings qml-module-qtgraphicaleffects
  qml-module-qtmultimedia qml-module-qtqml-models2 qml-module-qtquick-controls
  qml-module-qtquick-controls-styles-breeze qml-module-qtquick-dialogs qml-module-qtquick-layouts
  qml-module-qtquick-privatewidgets qml-module-qtquick-window2 qttools5-dev-tools rake ruby
  ruby-did-you-mean ruby-minitest ruby-net-telnet ruby-power-assert ruby-test-unit ruby2.3
  rubygems-integration sni-qt software-properties-common software-properties-kde sonnet-plugins
  unattended-upgrades
Use 'apt autoremove' to remove them.
The following additional packages will be installed:
  libva-wayland1 xbitmaps xterm
Suggested packages:
  xfonts-cyrillic
The following packages will be REMOVED:
  baloo-kf5 bluedevil bovo breeze dolphin frameworkintegration gwenview kactivitymanagerd
  kamera kde-baseapps kde-cli-tools kde-config-gtk-style kde-config-screenlocker kde-config-sddm
  kde-plasma-desktop kde-spectacle kde-style-oxygen-qt5 kde-style-qtcurve-qt5 kgamma5 khelpcenter
  khotkeys kinfocenter kinit kio kio-extras kiriki klickety kmahjongg kmenuedit konsole
  konsole-kpart kpackagelauncherqml kpat kscreen kshisen ksshaskpass ksysguard
  ktexteditor-katepart kwalletmanager kwin-common kwin-x11 kwrite kwrited libkf5baloowidgets5
  libkf5declarative5 libkf5kcmutils5 libkf5kdegames7 libkf5kdelibs4support5
  libkf5kdelibs4support5-bin libkf5khtml-bin libkf5khtml5 libkf5newstuff5 libkf5notifications5
  libkf5notifyconfig5 libkf5parts-plugins libkf5parts5 libkf5plasma5 libkf5plasmaquick5
  libkf5quickaddons5 libkf5runner5 libkf5texteditor5 libkf5wallet-bin libkf5wallet5
  libkf5xmlrpcclient5 libkscreenlocker5 libkwalletbackend5-5 libkwin4-effect-builtins1
  libpowerdevilcore2 libtaskmanager6 libweather-ion7 milou phonon4qt5 phonon4qt5-backend-vlc
  plasma-desktop plasma-discover plasma-framework plasma-integration plasma-pa plasma-workspace
  powerdevil qml-module-org-kde-draganddrop qml-module-org-kde-kcoreaddons qml-module-org-kde-kio
  qml-module-org-kde-kirigami qml-module-org-kde-kquickcontrols
  qml-module-org-kde-kquickcontrolsaddons qml-module-org-kde-kwindowsystem
  qml-module-org-kde-runnermodel systemsettings user-manager vlc-plugin-base
The following NEW packages will be installed:
  libva-wayland1 xbitmaps xterm
The following packages will be upgraded:
  vlc-data vlc-plugin-video-output
2 upgraded, 3 newly installed, 92 to remove and 0 not upgraded.
Need to get 1409 kB of archives.
After this operation, 224 MB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.

AAARGH! It wants to nuke my entire (KDE) desktop. How about no?

Any ideas on how I could get Kaffeine running? It's easily the best TV software on Linux.

Last edited by ismohaa (2018-08-19 06:05:16)

Offline

#2 2018-08-17 14:33:24

GNUser
Member
Registered: 2017-03-16
Posts: 418  

Re: VLC and Kaffeine won't install on Ascii [SOLVED]

What's the output of $ apt-cache policy vlc?

Also, apt-get is trying to fetch an old version of some dependencies (version 2.2.7-x) that's not in the repository anymore. What happens if you run # apt-get update && apt-get install vlc, any difference? My apologies if this is too obvious and you already tried it.

FYI this is what I see when I try to install vlc:

root@thinkpad:/home/bruno# apt-get update && apt-get -s install vlc
Hit:1 http://deb.devuan.org/merged ascii InRelease
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  vlc-bin vlc-l10n vlc-plugin-notify vlc-plugin-qt vlc-plugin-samba
  vlc-plugin-skins2 vlc-plugin-video-splitter vlc-plugin-visualization
The following NEW packages will be installed:
  vlc vlc-bin vlc-l10n vlc-plugin-notify vlc-plugin-qt vlc-plugin-samba
  vlc-plugin-skins2 vlc-plugin-video-splitter vlc-plugin-visualization
0 upgraded, 9 newly installed, 0 to remove and 0 not upgraded.
Inst vlc-bin (3.0.2-0+deb9u1 Devuan:2.0/stable [amd64])
Inst vlc-plugin-qt (3.0.2-0+deb9u1 Devuan:2.0/stable [amd64])
Inst vlc-l10n (3.0.2-0+deb9u1 Devuan:2.0/stable [all])
Inst vlc (3.0.2-0+deb9u1 Devuan:2.0/stable [amd64])
Inst vlc-plugin-notify (3.0.2-0+deb9u1 Devuan:2.0/stable [amd64])
Inst vlc-plugin-samba (3.0.2-0+deb9u1 Devuan:2.0/stable [amd64])
Inst vlc-plugin-skins2 (3.0.2-0+deb9u1 Devuan:2.0/stable [amd64])
Inst vlc-plugin-video-splitter (3.0.2-0+deb9u1 Devuan:2.0/stable [amd64])
Inst vlc-plugin-visualization (3.0.2-0+deb9u1 Devuan:2.0/stable [amd64])
Conf vlc-bin (3.0.2-0+deb9u1 Devuan:2.0/stable [amd64])
Conf vlc-plugin-qt (3.0.2-0+deb9u1 Devuan:2.0/stable [amd64])
Conf vlc-l10n (3.0.2-0+deb9u1 Devuan:2.0/stable [all])
Conf vlc (3.0.2-0+deb9u1 Devuan:2.0/stable [amd64])
Conf vlc-plugin-notify (3.0.2-0+deb9u1 Devuan:2.0/stable [amd64])
Conf vlc-plugin-samba (3.0.2-0+deb9u1 Devuan:2.0/stable [amd64])
Conf vlc-plugin-skins2 (3.0.2-0+deb9u1 Devuan:2.0/stable [amd64])
Conf vlc-plugin-video-splitter (3.0.2-0+deb9u1 Devuan:2.0/stable [amd64])
Conf vlc-plugin-visualization (3.0.2-0+deb9u1 Devuan:2.0/stable [amd64])

Last edited by GNUser (2018-08-17 14:54:09)

Offline

#3 2018-08-17 14:44:26

GNUser
Member
Registered: 2017-03-16
Posts: 418  

Re: VLC and Kaffeine won't install on Ascii [SOLVED]

Also, what does your /etc/apt/sources.list look like?

Last edited by GNUser (2018-08-17 14:57:55)

Offline

#4 2018-08-17 15:04:00

golinux
Administrator
Registered: 2016-11-25
Posts: 1,309  

Re: VLC and Kaffeine won't install on Ascii [SOLVED]

You might want to have a look at the recommended sources.

Offline

#5 2018-08-17 17:35:39

fsmithred
Administrator
Registered: 2016-11-25
Posts: 912  

Re: VLC and Kaffeine won't install on Ascii [SOLVED]

Once you get your sources straightened out, just install kaffeine. You should not need to tell it to install vlc - the package manager will pull in any dependencies automatically.

Offline

#6 2018-08-19 04:42:41

ismohaa
Member
Registered: 2018-08-17
Posts: 5  

Re: VLC and Kaffeine won't install on Ascii [SOLVED]

What happens if you run # apt-get update && apt-get install vlc, any difference?

No. What I copy-pasted above is the result I'm getting after doing apt-get update.

What's the output of $ apt-cache policy vlc?

vlc:
  Installed: (none)
  Candidate: 3.0.3-1-0+deb9u1
  Version table:
     3.0.3-1-0+deb9u1 500
        500 http://46.105.191.77/merged ascii-security/main amd64 Packages
     3.0.2-0+deb9u1 500
        500 http://46.105.191.77/merged ascii/main amd64 Packages
        500 http://packages.devuan.org/merged ascii/main amd64 Packages
     2.2.7-1~deb9u1 -1
        100 /var/lib/dpkg/status

As you can see, the package manager is quite aware of the newer version of vlc, but if you look at the original error messages I posted, you'll see that it for some reason I can't figure out shits itself when asked to install vlc. Kaffeine actually installs, but it's broken - apparently due to the old vlc version.

Also, what does your /etc/apt/sources.list look like?

deb http://46.105.191.77/merged/ ascii main
deb-src http://46.105.191.77/merged/ ascii main

# ascii-security, previously known as 'volatile'
deb http://46.105.191.77/merged/ ascii-security main non-free
deb-src http://46.105.191.77/merged/ ascii-security main non-free

# ascii-updates, previously known as 'volatile'
deb http://46.105.191.77/merged/ ascii-updates main non-free
deb-src http://46.105.191.77/merged/ ascii-updates main non-free

# Devuan repositories
deb http://packages.devuan.org/merged ascii main contrib non-free
deb-src http://packages.devuan.org/merged ascii main contrib non-free

#Seamonkey
deb http://downloads.sourceforge.net/project/ubuntuzilla/mozilla/apt all main

#Eddie
deb http://eddie.website/repository/apt stable main

#Spotify
deb http://repository.spotify.com stable non-free

If you're wondering about the hard coded IP, I had some weird DNS issues at some point, and had to replace packages.devuan.org with the IP-address, but nslookup still shows the address to be the same.

Offline

#7 2018-08-19 05:02:03

golinux
Administrator
Registered: 2016-11-25
Posts: 1,309  

Re: VLC and Kaffeine won't install on Ascii [SOLVED]

Your sources are outdated.  I posted a link above that should have clued you in about that.   packages.devuan.org (that served jessie) uses the old amprolla but is now deprecated and will be decommissioned when jessie reaches EOL.   deb.devuan.org, a round-robin of package mirrors, pulls from pkgmaster.devuan.org which is built with the new amprolla3 and has many additional features.

Please refer to the ASCII Release Notes for further clarification.

Offline

#8 2018-08-19 06:04:37

ismohaa
Member
Registered: 2018-08-17
Posts: 5  

Re: VLC and Kaffeine won't install on Ascii [SOLVED]

Your sources are outdated.

I managed to solve the problem, but the root of the issue wasn't really the sources being outdated (although I have updated them since you're right about them being deprecated). The real troublemaker turned out to be spotify, which pulled in the outdated vlc-libraries and didn't update because their repository key had changed. Importing the new key and updating spotify allowed the vlc-libraries to update, and kaffeine to run. There still seems to be some version issue with vlc, but I wasn't really that interested in vlc to begin with. It seems to be an issue of having to choose between spotify and vlc (or having to do some nasty hand compiling outside the package manager) but as far as I'm concerned the issue is solved. Thanks to everyone who provided pointers.

Offline

Board footer