The officially official Devuan Forum!

You are not logged in.

#1 2018-04-05 20:41:32

GNUser
Member
Registered: 2017-03-16
Posts: 333  

trailing artifact when moving icons around MATE's desktop [SOLVED]

I've been squashing bugs on my ascii partition for a few weeks and have finally gotten to the last obvious one. This is just a  cosmetic issue, but it irritates me.

I use my desktop as a workbench and frequently have multiple files on it when I'm working on a project. Part of my workflow often involves rearranging the icons so that files are grouped in ways that make sense to me. Unfortunately, on ASCII with MATE 1.16.2 and caja 1.16.6-1+deb9u1 it is a bit freaky to drag an icon to a different location of the desktop because most of the time it leaves a ghostly trailing artifact behind it. Here is a video that shows what I'm talking about:

http://files.dantas.airpost.net/public/ … tifact.mp4

The issue occurs on all kernels I've tried. I tried upgrading just caja to the version in ascii-backports (1.18.5-2~bpo9+1) and the issue was still there. I'm back on the default version now (1.16.6-1+deb9u1). This issue did not occur in Devuan Jessie with MATE.

Is anyone else having this issue with their desktop icons? Any idea how to begin troubleshooting this?

Last edited by GNUser (2018-04-06 01:02:50)

Offline

#2 2018-04-05 20:51:47

golinux
Administrator
Registered: 2016-11-25
Posts: 1,062  

Re: trailing artifact when moving icons around MATE's desktop [SOLVED]

That's the way desktop icons work here on Xfce.  Old icon remains until new positioning is completed.

Offline

#3 2018-04-05 20:57:29

GNUser
Member
Registered: 2017-03-16
Posts: 333  

Re: trailing artifact when moving icons around MATE's desktop [SOLVED]

I'm talking about the weird, ghostly icon that moves between the original location and new location. It happens when I drop the icon at the new location. You can see it in the video.

This is definitely not something I've seen in MATE before. Given the erratic nature of this (only part of the icon shows up in the blur, bits and pieces of the desktop background fly away and back, sometimes it does not happen at all) I'm pretty sure this is a bug.

This is not a big deal, of course, but if one of you smart guys has an instinct of what could be causing this (or know for a fact what is causing it), I'd like to try fixing it.

Last edited by GNUser (2018-04-06 19:52:19)

Offline

#4 2018-04-05 21:52:30

golinux
Administrator
Registered: 2016-11-25
Posts: 1,062  

Re: trailing artifact when moving icons around MATE's desktop [SOLVED]

Maybe a compositing issue?

Offline

#5 2018-04-06 00:55:33

GNUser
Member
Registered: 2017-03-16
Posts: 333  

Re: trailing artifact when moving icons around MATE's desktop [SOLVED]

Right on, golinux!

If I turn on marco's compositing, issue gets much better. If I leave marco's compositing off, install compton, and add compton to my startup applications (command=compton -bCG), problem goes away completely.

This is strange because in Devuan Jessie I run marco with compositing off and have no issues.

(This is yet another way in which MATE is dropping the ball. I shouldn't have to turn on anything special in order to avoid weird glitches when doing something as simple as moving an icon on the desktop...)

Last edited by GNUser (2018-04-06 00:56:36)

Offline

Board footer