The officially official Devuan Forum!

You are not logged in.

#1 2018-02-23 01:39:52

GNUser
Member
Registered: 2017-03-16
Posts: 420  

in ASCII, libpolkit-agent-1-0 and policykit-1 held back? [SOLVED]

I thought I'd give ASCII a try and installed it using the Miyo live desktop. Then I installed mate-desktop-environment-extras. Everything works well, but trying to upgrade the system leaves two packages behind:

bruno@thinkpad:~$ sudo apt-get dist-upgrade
[sudo] password for bruno: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  libpolkit-agent-1-0 policykit-1
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

Does anybody know why? The two package versions are version 0.105-9+devuan1.

Last edited by GNUser (2018-02-25 03:59:27)

Offline

#2 2018-02-23 02:56:48

GNUser
Member
Registered: 2017-03-16
Posts: 420  

Re: in ASCII, libpolkit-agent-1-0 and policykit-1 held back? [SOLVED]

I'm not sure about the answer to my question, but installing these two packages made the issue go away:
libpolkit-backend-1-0-elogind libpolkit-gobject-1-0-elogind

Also, I was having problems mounting/unmounting USB drives (little boxes pop up saying I didn't have permission) and shutdown/rebooting (would take me to login screen) via the GUI. These problems went away when I installed the two packages above.

Last edited by GNUser (2018-02-23 02:57:13)

Offline

#3 2018-02-23 04:20:15

golinux
Administrator
Registered: 2016-11-25
Posts: 1,348  

Re: in ASCII, libpolkit-agent-1-0 and policykit-1 held back? [SOLVED]

This has been discussed on the dng mail list and the irc channels and even this forum.  Unfortunately I don't understand it well enough to explain it.   IIRC it only happens on an upgrade, not a new install.  The devs are working hard to sort things so that the needed files are deleted/delivered under every possible circumstance.

Offline

#4 2018-02-23 09:40:09

Geoff 42
Member
Registered: 2016-12-15
Posts: 187  

Re: in ASCII, libpolkit-agent-1-0 and policykit-1 held back? [SOLVED]

Yes, if you follow golinux' link you will see that installing the elogind backends replaces the packages causing the problem. You will need to ignore some worrying looking warnings though...

Geoff

Offline

#5 2018-02-23 14:40:01

GNUser
Member
Registered: 2017-03-16
Posts: 420  

Re: in ASCII, libpolkit-agent-1-0 and policykit-1 held back? [SOLVED]

Thank you both. I have not been following ASCII's development as closely as I should sad

Offline

Board footer