The officially official Devuan Forum!

You are not logged in.

#1 2017-07-17 12:58:10

zenkaon
Member
Registered: 2017-07-17
Posts: 9

Can I use Debian multimedia?

Hi all,

Long time Debian user here considering taking the plunge into Devuan. Interesting project and I admire the principled stand against systemd.

Can anyone advise if I can use the repos at http://www.deb-multimedia.org/

Cheers

Offline

#2 2017-07-17 13:13:08

golinux
Administrator
Registered: 2016-11-25
Posts: 551

Re: Can I use Debian multimedia?

Yes you can but at your own risk, of course.  dmo is outside the scope of Devuan intervention so check dependencies carefully . . .

Offline

#3 2017-07-17 13:31:45

zenkaon
Member
Registered: 2017-07-17
Posts: 9

Re: Can I use Debian multimedia?

Thanks - I'll spin up an instance of devuan and have a play around.

Offline

#4 2017-07-17 13:51:48

golinux
Administrator
Registered: 2016-11-25
Posts: 551

Re: Can I use Debian multimedia?

Please log your observations here.  I have a few things from dmo installed but that was from nearly two years ago and things change . . .

Offline

#5 2017-07-18 22:01:37

zenkaon
Member
Registered: 2017-07-17
Posts: 9

Re: Can I use Debian multimedia?

Hello, Observations below.

I need my Linux distro to:
play: audio CD, mp3, h264, DVD, Blu-Ray
Encode: audio CD -> mp3, DVD / Blu-Ray -> h264

I can do this on Debian stretch. Can I do it on Devuan ascii?
I (thought I needed to) rely on deb-multimedia.
Does deb-multimedia work on Devuan ascii?

out-of-the-box Devuan ascii
Play audio CD: Yes - vlc
Play mp3: Yes - vlc
Play h264: Yes - vlc
Play DVD: No
Play Blu-Ray: No
Encode audio CD to mp3: No
Encode DVD to h264: No
Encode Blu-Ray to h264: No

Encode audio CD:
sudo apt-get install asunder lame

Metadata manager for mp3s that is better (IMHO) than Ex Falso
sudo apt-get install easytag libid3-tools

Play DVDs via vlc:
sudo apt-get install libdvd-pkg
sudo dpkg-reconfigure libdvd-pkg
(not sure why I needed to do this, but I did)

Play Blu-Ray via vlc:
mkdir ~/.config/aacs
cd ~/.config/aacs
wget http://vlc-bluray.whoknowsmy.name/files/KEYDB.cfg

All good so far, and no deb-multimedia!!

I encode to h264 via handbrake.
sudo apt-get install handbrake

This will work for DVDs if you have libdvdcss2
For Blu-Ray there is an extra step using http://www.makemkv.com/
Then handbrake the output of MakeMKV for a much better file size

MakeMKV is of dubious legalilty and is not in any repos
It's old-skool './configure && make && sudo make install'
and comes with a non-FOSS binary. It's beta so they post
a new trial key every month or so. It's been beta for a loooong time wink
This may offend your principals and I totally respect that.
On the other hand, it does rip Blu-Rays.... wink

All successful. I can play audio CDs, mp3s, h264, DVDs and Blu-Rays
I can encode audio CD to mp3, DVD and Blu-Ray to h264
I did not need deb-multimedia at all.

I am a happy bunny.

.....However, as this thread started about deb-multimedia,
even though I don't really need it, I'll just plough on
regardless and see if I can brake anything, just for fun.

I'll justify this by saying that the handbrake version in
the ascii repo is slightly old. But really I just want to
see what happens.....

Assuming that ascii is stretch I've added to:
/etc/apt/sources.list
deb http://www.deb-multimedia.org stretch main non-free

Short story is that it all worked fine and a lot of stuff got replaced.

Long story is the terminal output below so you can see the affected packages.

sudo apt-get update
...normal GPG error...
sudo apt-get install deb-multimedia-keyring 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  deb-multimedia-keyring
0 upgraded, 1 newly installed, 0 to remove and 49 not upgraded.
Need to get 10.7 kB of archives.
After this operation, 25.6 kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  deb-multimedia-keyring
Install these packages without verification? [y/N] y
Get:1 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 deb-multimedia-keyring all 2016.8.1 [10.7 kB]
Fetched 10.7 kB in 1s (8,700 B/s)           
Selecting previously unselected package deb-multimedia-keyring.
(Reading database ... 125973 files and directories currently installed.)
Preparing to unpack .../deb-multimedia-keyring_2016.8.1_all.deb ...
Unpacking deb-multimedia-keyring (2016.8.1) ...
Setting up deb-multimedia-keyring (2016.8.1) ...

sudo apt-get update
Hit:1 [url]http://gb.mirror.devuan.org/merged[/url] ascii InRelease
Hit:3 [url]http://gb.mirror.devuan.org/merged[/url] ascii-updates InRelease
Hit:4 [url]http://packages.devuan.org/merged[/url] ascii InRelease
Get:5 [url]http://www.deb-multimedia.org[/url] stretch InRelease [33.4 kB]                                        
Hit:2 [url]http://amprolla.devuan.org/merged[/url] ascii-security InRelease                        
Fetched 33.4 kB in 2s (14.8 kB/s)
Reading package lists... Done
john@heplt036:~$ sudo apt-get dist-upgrade 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  gnome-user-guide libass5 libavfilter6 libavresample3 libbdplus0 libbs2b0 libdouble-conversion1
  libebur128-1 libflite1 libgles1-mesa liblept5 liblivemedia57 libopencv-core2.4v5
  libopencv-imgproc2.4v5 libopenmpt-modplug1 libpcre16-3 libpgm-5.2-0 libqt5core5a libqt5dbus5
  libqt5gui5 libqt5network5 libqt5svg5 libqt5widgets5 libqt5x11extras5 librubberband2 libsodium18
  libssh-gcrypt-4 libtbb2 libtesseract-data libtesseract3 libvidstab1.0 libx264-148 libx265-95
  libxcb-icccm4 libxcb-image0 libxcb-render-util0 libxcb-xinerama0 libxcb-xkb1 libxkbcommon-x11-0
  libyelp0 libzmq5 qt5-gtk-platformtheme qttranslations5-l10n yelp yelp-xsl
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  libdvdcss2-dbgsym
The following NEW packages will be installed:
  handbrake-cli libass9 libbluray2 libfdk-aac1 libilbc2 libjansson4 libkvazaar3 liblept5 liblivemedia58
  libmfx0 libopenh264-2 libqt4-dbus libqt4-xml libqtcore4 libqtdbus4 libqtgui4 libtag-extras1
  libtesseract-data libtesseract3 libvidstab1.0 libvo-amrwbenc0 libx264-150 libx265-116 qdbus qt-at-spi
  qtchooser qtcore4-l10n
The following packages will be upgraded:
  easytag gstreamer1.0-libav gstreamer1.0-plugins-ugly handbrake lame libaacs0 libasound2-plugins
  libavcodec57 libavfilter6 libavformat57 libavresample3 libavutil55 libbabl-0.1-0
  libbasicusageenvironment1 libbdplus0 libchromaprint1 libdca0 libdvbpsi10 libdvdcss-dev libdvdcss2
  libebml4v5 libgegl-0.3-0 libgroupsock8 libmatroska6v5 libmp3lame0 libpostproc54 librtmp1
  libswresample2 libswscale4 libtwolame0 libusageenvironment3 libvlc-bin libvlc5 libvlccore8
  libxvidcore4 vdpau-va-driver vlc vlc-bin vlc-data vlc-l10n vlc-plugin-base vlc-plugin-notify
  vlc-plugin-qt vlc-plugin-samba vlc-plugin-skins2 vlc-plugin-video-output vlc-plugin-video-splitter
  vlc-plugin-visualization
48 upgraded, 27 newly installed, 1 to remove and 0 not upgraded.
Need to get 37.3 MB/44.3 MB of archives.
After this operation, 35.0 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:7 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libdca0 amd64 0.0.5-dmo2+deb8u1 [98.2 kB]
Get:1 [url]http://gb.mirror.devuan.org/merged[/url] ascii/main amd64 libvo-amrwbenc0 amd64 0.1.3-1 [59.4 kB]
Get:8 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 vlc-plugin-visualization amd64 1:2.2.6-dmo2+deb9u1 [26.1 kB]
Get:9 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 vlc-plugin-video-splitter amd64 1:2.2.6-dmo2+deb9u1 [17.9 kB]
Get:10 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 vlc-plugin-video-output amd64 1:2.2.6-dmo2+deb9u1 [53.3 kB]
Get:11 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 vlc-plugin-samba amd64 1:2.2.6-dmo2+deb9u1 [5,076 B]
Get:12 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 vlc amd64 1:2.2.6-dmo2+deb9u1 [119 kB]
Get:2 [url]http://gb.mirror.devuan.org/merged[/url] ascii/main amd64 libtag-extras1 amd64 1.0.1-3.1 [19.0 kB]
Get:13 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 vlc-plugin-qt amd64 1:2.2.6-dmo2+deb9u1 [1,047 kB]
Get:3 [url]http://gb.mirror.devuan.org/merged[/url] ascii/main amd64 libtesseract-data all 3.04.01-5 [12.3 kB]
Get:4 [url]http://gb.mirror.devuan.org/merged[/url] ascii/main amd64 liblept5 amd64 1.74.1-1 [923 kB]
Get:14 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 vlc-plugin-notify amd64 1:2.2.6-dmo2+deb9u1 [5,456 B]
Get:15 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 vlc-plugin-base amd64 1:2.2.6-dmo2+deb9u1 [2,280 kB]
Get:16 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libvlccore8 amd64 1:2.2.6-dmo2+deb9u1 [485 kB]
Get:17 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 vlc-data all 1:2.2.6-dmo2+deb9u1 [417 kB]
Get:5 [url]http://gb.mirror.devuan.org/merged[/url] ascii/main amd64 libtesseract3 amd64 3.04.01-5 [1,123 kB]
Get:18 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 vlc-plugin-skins2 amd64 1:2.2.6-dmo2+deb9u1 [455 kB]
Get:19 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 vlc-l10n all 1:2.2.6-dmo2+deb9u1 [5,551 kB]
Get:6 [url]http://gb.mirror.devuan.org/merged[/url] ascii/main amd64 libjansson4 amd64 2.9-1 [28.1 kB]             
Get:20 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libass9 amd64 2:0.13.7-dmo1 [91.4 kB]           
Get:21 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libmfx0 amd64 1.21-dmo1 [25.3 kB]               
Get:22 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libavutil55 amd64 10:3.3.2-dmo1 [219 kB]        
Get:23 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libfdk-aac1 amd64 1:0.1.5-dmo2 [354 kB]         
Get:24 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libilbc2 amd64 2.0.2-dmo4 [49.9 kB]             
Get:25 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libkvazaar3 amd64 1:1.1.0-dmo1 [181 kB]         
Get:26 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libmp3lame0 amd64 1:3.99.5-dmo6 [405 kB]        
Get:27 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libopenh264-2 amd64 1.6.0-dmo3 [338 kB]         
Get:28 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libswresample2 amd64 10:3.3.2-dmo1 [89.7 kB]    
Get:29 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libx264-150 amd64 3:0.150.2833+gitdf79067-dmo1 [794 kB]
Get:30 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libx265-116 amd64 1:2.4-dmo1 [758 kB]           
Get:31 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libxvidcore4 amd64 3:1.3.4-dmo1 [243 kB]        
Get:32 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libavcodec57 amd64 10:3.3.2-dmo1 [4,515 kB]     
Get:33 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libbluray2 amd64 2:1.0.0-dmo1 [131 kB]          
Get:34 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libchromaprint1 amd64 1:1.4.2-dmo1 [43.3 kB]    
Get:35 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libavformat57 amd64 10:3.3.2-dmo1 [944 kB]      
Get:36 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libbasicusageenvironment1 amd64 2:2017.04.26-dmo1 [120 kB]
Get:37 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libdvbpsi10 amd64 1:1.3.1-dmo1 [52.8 kB]        
Get:38 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libebml4v5 amd64 1:1.3.4-dmo1 [58.6 kB]         
Get:39 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libgroupsock8 amd64 2:2017.04.26-dmo1 [125 kB]  
Get:40 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 liblivemedia58 amd64 2:2017.04.26-dmo1 [408 kB] 
Get:41 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libmatroska6v5 amd64 1:1.4.5-dmo1 [133 kB]      
Get:42 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libpostproc54 amd64 10:3.3.2-dmo1 [86.7 kB]     
Get:43 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libswscale4 amd64 10:3.3.2-dmo1 [184 kB]        
Get:44 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libtwolame0 amd64 1:0.3.13-dmo3 [50.5 kB]       
Get:45 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libusageenvironment3 amd64 2:2017.04.26-dmo1 [111 kB]
Get:46 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 vlc-bin amd64 1:2.2.6-dmo2+deb9u1 [141 kB]      
Get:47 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libvlc-bin amd64 1:2.2.6-dmo2+deb9u1 [105 kB]   
Get:48 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libvlc5 amd64 1:2.2.6-dmo2+deb9u1 [146 kB]      
Get:49 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 easytag amd64 1:2.4.3-dmo1 [742 kB]             
Get:50 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 gstreamer1.0-libav amd64 1:1.10.4-dmo1 [5,305 kB]
Get:51 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 gstreamer1.0-plugins-ugly amd64 1:1.10.4-dmo1 [421 kB]
Get:52 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 lame amd64 1:3.99.5-dmo6 [339 kB]               
Get:53 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libaacs0 amd64 0.9.0-dmo1 [52.3 kB]             
Get:54 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libasound2-plugins amd64 1:1.1.4-dmo1 [77.3 kB] 
Get:55 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libavresample3 amd64 10:3.3.2-dmo1 [87.0 kB]    
Get:56 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libvidstab1.0 amd64 2:0.98b-dmo1+deb8u1 [39.1 kB]
Get:57 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libavfilter6 amd64 10:3.3.2-dmo1 [839 kB]       
Get:58 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libbabl-0.1-0 amd64 1:0.1.28-dmo1 [223 kB]      
Get:59 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libbdplus0 amd64 0.1.2-dmo1+deb8u1 [44.1 kB]    
Get:60 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libdvdcss-dev amd64 1.4.0-dmo1 [57.8 kB]        
Get:61 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libdvdcss2 amd64 1.4.0-dmo1 [55.8 kB]           
Get:62 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 libgegl-0.3-0 amd64 1:0.3.18-dmo1 [1,210 kB]    
Get:63 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 vdpau-va-driver amd64 0.7.4-dmo7 [40.0 kB]      
Get:64 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 handbrake-cli amd64 1:1.0.7-dmo3 [4,081 kB]     
Get:65 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 handbrake all 1:1.0.7-dmo3 [31.7 kB]            
Get:66 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 librtmp1 amd64 2:2.4~20160119.gitfa8646dae-dmo5 [59.3 kB]
Fetched 37.3 MB in 16s (2,259 kB/s)                                                                     
Reading changelogs... Done
Extracting templates from packages: 100%
(Reading database ... 125976 files and directories currently installed.)
Removing libdvdcss2-dbgsym:amd64 (1.4.0-1~local) ...
(Reading database ... 125972 files and directories currently installed.)
Preparing to unpack .../00-libdca0_0.0.5-dmo2+deb8u1_amd64.deb ...
Unpacking libdca0:amd64 (0.0.5-dmo2+deb8u1) over (0.0.5-10) ...
Preparing to unpack .../01-vlc-plugin-visualization_1%3a2.2.6-dmo2+deb9u1_amd64.deb ...
Unpacking vlc-plugin-visualization:amd64 (1:2.2.6-dmo2+deb9u1) over (2.2.6-1~deb9u1) ...
Preparing to unpack .../02-vlc-plugin-video-splitter_1%3a2.2.6-dmo2+deb9u1_amd64.deb ...
Unpacking vlc-plugin-video-splitter:amd64 (1:2.2.6-dmo2+deb9u1) over (2.2.6-1~deb9u1) ...
Preparing to unpack .../03-vlc-plugin-video-output_1%3a2.2.6-dmo2+deb9u1_amd64.deb ...
Unpacking vlc-plugin-video-output:amd64 (1:2.2.6-dmo2+deb9u1) over (2.2.6-1~deb9u1) ...
Preparing to unpack .../04-vlc-plugin-samba_1%3a2.2.6-dmo2+deb9u1_amd64.deb ...
Unpacking vlc-plugin-samba:amd64 (1:2.2.6-dmo2+deb9u1) over (2.2.6-1~deb9u1) ...
Preparing to unpack .../05-vlc_1%3a2.2.6-dmo2+deb9u1_amd64.deb ...
Unpacking vlc (1:2.2.6-dmo2+deb9u1) over (2.2.6-1~deb9u1) ...
Preparing to unpack .../06-vlc-plugin-qt_1%3a2.2.6-dmo2+deb9u1_amd64.deb ...
Unpacking vlc-plugin-qt:amd64 (1:2.2.6-dmo2+deb9u1) over (2.2.6-1~deb9u1) ...
Preparing to unpack .../07-vlc-plugin-notify_1%3a2.2.6-dmo2+deb9u1_amd64.deb ...
Unpacking vlc-plugin-notify:amd64 (1:2.2.6-dmo2+deb9u1) over (2.2.6-1~deb9u1) ...
Preparing to unpack .../08-vlc-plugin-base_1%3a2.2.6-dmo2+deb9u1_amd64.deb ...
Unpacking vlc-plugin-base:amd64 (1:2.2.6-dmo2+deb9u1) over (2.2.6-1~deb9u1) ...
Preparing to unpack .../09-libvlccore8_1%3a2.2.6-dmo2+deb9u1_amd64.deb ...
Unpacking libvlccore8:amd64 (1:2.2.6-dmo2+deb9u1) over (2.2.6-1~deb9u1) ...
Preparing to unpack .../10-vlc-data_1%3a2.2.6-dmo2+deb9u1_all.deb ...
Unpacking vlc-data (1:2.2.6-dmo2+deb9u1) over (2.2.6-1~deb9u1) ...
Preparing to unpack .../11-vlc-plugin-skins2_1%3a2.2.6-dmo2+deb9u1_amd64.deb ...
Unpacking vlc-plugin-skins2:amd64 (1:2.2.6-dmo2+deb9u1) over (2.2.6-1~deb9u1) ...
Preparing to unpack .../12-vlc-l10n_1%3a2.2.6-dmo2+deb9u1_all.deb ...
Unpacking vlc-l10n (1:2.2.6-dmo2+deb9u1) over (2.2.6-1~deb9u1) ...
Selecting previously unselected package libass9:amd64.
Preparing to unpack .../13-libass9_2%3a0.13.7-dmo1_amd64.deb ...
Unpacking libass9:amd64 (2:0.13.7-dmo1) ...
Selecting previously unselected package libmfx0:amd64.
Preparing to unpack .../14-libmfx0_1.21-dmo1_amd64.deb ...
Unpacking libmfx0:amd64 (1.21-dmo1) ...
Preparing to unpack .../15-libavutil55_10%3a3.3.2-dmo1_amd64.deb ...
Unpacking libavutil55:amd64 (10:3.3.2-dmo1) over (7:3.2.5-1) ...
Selecting previously unselected package libfdk-aac1:amd64.
Preparing to unpack .../16-libfdk-aac1_1%3a0.1.5-dmo2_amd64.deb ...
Unpacking libfdk-aac1:amd64 (1:0.1.5-dmo2) ...
Selecting previously unselected package libilbc2:amd64.
Preparing to unpack .../17-libilbc2_2.0.2-dmo4_amd64.deb ...
Unpacking libilbc2:amd64 (2.0.2-dmo4) ...
Selecting previously unselected package libkvazaar3:amd64.
Preparing to unpack .../18-libkvazaar3_1%3a1.1.0-dmo1_amd64.deb ...
Unpacking libkvazaar3:amd64 (1:1.1.0-dmo1) ...
Preparing to unpack .../19-libmp3lame0_1%3a3.99.5-dmo6_amd64.deb ...
Unpacking libmp3lame0:amd64 (1:3.99.5-dmo6) over (3.99.5+repack1-9+b2) ...
Selecting previously unselected package libopenh264-2:amd64.
Preparing to unpack .../20-libopenh264-2_1.6.0-dmo3_amd64.deb ...
Unpacking libopenh264-2:amd64 (1.6.0-dmo3) ...
Preparing to unpack .../21-libswresample2_10%3a3.3.2-dmo1_amd64.deb ...
Unpacking libswresample2:amd64 (10:3.3.2-dmo1) over (7:3.2.5-1) ...
Selecting previously unselected package libvo-amrwbenc0:amd64.
Preparing to unpack .../22-libvo-amrwbenc0_0.1.3-1_amd64.deb ...
Unpacking libvo-amrwbenc0:amd64 (0.1.3-1) ...
Selecting previously unselected package libx264-150:amd64.
Preparing to unpack .../23-libx264-150_3%3a0.150.2833+gitdf79067-dmo1_amd64.deb ...
Unpacking libx264-150:amd64 (3:0.150.2833+gitdf79067-dmo1) ...
Selecting previously unselected package libx265-116:amd64.
Preparing to unpack .../24-libx265-116_1%3a2.4-dmo1_amd64.deb ...
Unpacking libx265-116:amd64 (1:2.4-dmo1) ...
Preparing to unpack .../25-libxvidcore4_3%3a1.3.4-dmo1_amd64.deb ...
Unpacking libxvidcore4:amd64 (3:1.3.4-dmo1) over (2:1.3.4-1+b2) ...
Preparing to unpack .../26-libavcodec57_10%3a3.3.2-dmo1_amd64.deb ...
Unpacking libavcodec57:amd64 (10:3.3.2-dmo1) over (7:3.2.5-1) ...
Selecting previously unselected package libbluray2:amd64.
Preparing to unpack .../27-libbluray2_2%3a1.0.0-dmo1_amd64.deb ...
Unpacking libbluray2:amd64 (2:1.0.0-dmo1) ...
Preparing to unpack .../28-libchromaprint1_1%3a1.4.2-dmo1_amd64.deb ...
Unpacking libchromaprint1:amd64 (1:1.4.2-dmo1) over (1.4.2-1) ...
Preparing to unpack .../29-libavformat57_10%3a3.3.2-dmo1_amd64.deb ...
Unpacking libavformat57:amd64 (10:3.3.2-dmo1) over (7:3.2.5-1) ...
Preparing to unpack .../30-libbasicusageenvironment1_2%3a2017.04.26-dmo1_amd64.deb ...
Unpacking libbasicusageenvironment1 (2:2017.04.26-dmo1) over (2016.11.28-1) ...
Preparing to unpack .../31-libdvbpsi10_1%3a1.3.1-dmo1_amd64.deb ...
Unpacking libdvbpsi10:amd64 (1:1.3.1-dmo1) over (1.3.0-5) ...
Preparing to unpack .../32-libebml4v5_1%3a1.3.4-dmo1_amd64.deb ...
Unpacking libebml4v5:amd64 (1:1.3.4-dmo1) over (1.3.4-1) ...
Preparing to unpack .../33-libgroupsock8_2%3a2017.04.26-dmo1_amd64.deb ...
Unpacking libgroupsock8 (2:2017.04.26-dmo1) over (2016.11.28-1) ...
Selecting previously unselected package liblivemedia58.
Preparing to unpack .../34-liblivemedia58_2%3a2017.04.26-dmo1_amd64.deb ...
Unpacking liblivemedia58 (2:2017.04.26-dmo1) ...
Preparing to unpack .../35-libmatroska6v5_1%3a1.4.5-dmo1_amd64.deb ...
Unpacking libmatroska6v5:amd64 (1:1.4.5-dmo1) over (1.4.5-2) ...
Preparing to unpack .../36-libpostproc54_10%3a3.3.2-dmo1_amd64.deb ...
Unpacking libpostproc54:amd64 (10:3.3.2-dmo1) over (7:3.2.5-1) ...
Preparing to unpack .../37-libswscale4_10%3a3.3.2-dmo1_amd64.deb ...
Unpacking libswscale4:amd64 (10:3.3.2-dmo1) over (7:3.2.5-1) ...
Preparing to unpack .../38-libtwolame0_1%3a0.3.13-dmo3_amd64.deb ...
Unpacking libtwolame0:amd64 (1:0.3.13-dmo3) over (0.3.13-2) ...
Preparing to unpack .../39-libusageenvironment3_2%3a2017.04.26-dmo1_amd64.deb ...
Unpacking libusageenvironment3 (2:2017.04.26-dmo1) over (2016.11.28-1) ...
Selecting previously unselected package qtcore4-l10n.
Preparing to unpack .../40-qtcore4-l10n_4%3a4.8.7+dfsg-11_all.deb ...
Unpacking qtcore4-l10n (4:4.8.7+dfsg-11) ...
Selecting previously unselected package libqtcore4:amd64.
Preparing to unpack .../41-libqtcore4_4%3a4.8.7+dfsg-11_amd64.deb ...
Unpacking libqtcore4:amd64 (4:4.8.7+dfsg-11) ...
Selecting previously unselected package libqtgui4:amd64.
Preparing to unpack .../42-libqtgui4_4%3a4.8.7+dfsg-11_amd64.deb ...
Unpacking libqtgui4:amd64 (4:4.8.7+dfsg-11) ...
Preparing to unpack .../43-vlc-bin_1%3a2.2.6-dmo2+deb9u1_amd64.deb ...
Unpacking vlc-bin (1:2.2.6-dmo2+deb9u1) over (2.2.6-1~deb9u1) ...
Preparing to unpack .../44-libvlc-bin_1%3a2.2.6-dmo2+deb9u1_amd64.deb ...
Unpacking libvlc-bin:amd64 (1:2.2.6-dmo2+deb9u1) over (2.2.6-1~deb9u1) ...
Preparing to unpack .../45-libvlc5_1%3a2.2.6-dmo2+deb9u1_amd64.deb ...
Unpacking libvlc5:amd64 (1:2.2.6-dmo2+deb9u1) over (2.2.6-1~deb9u1) ...
Selecting previously unselected package libtag-extras1.
Preparing to unpack .../46-libtag-extras1_1.0.1-3.1_amd64.deb ...
Unpacking libtag-extras1 (1.0.1-3.1) ...
Preparing to unpack .../47-easytag_1%3a2.4.3-dmo1_amd64.deb ...
Unpacking easytag (1:2.4.3-dmo1) over (2.4.3-1) ...
Preparing to unpack .../48-gstreamer1.0-libav_1%3a1.10.4-dmo1_amd64.deb ...
Unpacking gstreamer1.0-libav:amd64 (1:1.10.4-dmo1) over (1.10.4-1) ...
Preparing to unpack .../49-gstreamer1.0-plugins-ugly_1%3a1.10.4-dmo1_amd64.deb ...
Unpacking gstreamer1.0-plugins-ugly:amd64 (1:1.10.4-dmo1) over (1.10.4-1) ...
Preparing to unpack .../50-lame_1%3a3.99.5-dmo6_amd64.deb ...
Unpacking lame (1:3.99.5-dmo6) over (3.99.5+repack1-9+b2) ...
Preparing to unpack .../51-libaacs0_0.9.0-dmo1_amd64.deb ...
Unpacking libaacs0:amd64 (0.9.0-dmo1) over (0.8.1-2) ...
Preparing to unpack .../52-libasound2-plugins_1%3a1.1.4-dmo1_amd64.deb ...
Unpacking libasound2-plugins:amd64 (1:1.1.4-dmo1) over (1.1.1-1) ...
Preparing to unpack .../53-libavresample3_10%3a3.3.2-dmo1_amd64.deb ...
Unpacking libavresample3:amd64 (10:3.3.2-dmo1) over (7:3.2.5-1) ...
Selecting previously unselected package libtesseract-data.
Preparing to unpack .../54-libtesseract-data_3.04.01-5_all.deb ...
Unpacking libtesseract-data (3.04.01-5) ...
Selecting previously unselected package liblept5.
Preparing to unpack .../55-liblept5_1.74.1-1_amd64.deb ...
Unpacking liblept5 (1.74.1-1) ...
Selecting previously unselected package libtesseract3.
Preparing to unpack .../56-libtesseract3_3.04.01-5_amd64.deb ...
Unpacking libtesseract3 (3.04.01-5) ...
Selecting previously unselected package libvidstab1.0.
Preparing to unpack .../57-libvidstab1.0_2%3a0.98b-dmo1+deb8u1_amd64.deb ...
Unpacking libvidstab1.0 (2:0.98b-dmo1+deb8u1) ...
Preparing to unpack .../58-libavfilter6_10%3a3.3.2-dmo1_amd64.deb ...
Unpacking libavfilter6:amd64 (10:3.3.2-dmo1) over (7:3.2.5-1) ...
Preparing to unpack .../59-libbabl-0.1-0_1%3a0.1.28-dmo1_amd64.deb ...
Unpacking libbabl-0.1-0:amd64 (1:0.1.28-dmo1) over (0.1.18-1) ...
Preparing to unpack .../60-libbdplus0_0.1.2-dmo1+deb8u1_amd64.deb ...
Unpacking libbdplus0 (0.1.2-dmo1+deb8u1) over (0.1.2-2) ...
Preparing to unpack .../61-libdvdcss-dev_1.4.0-dmo1_amd64.deb ...
Unpacking libdvdcss-dev:amd64 (1.4.0-dmo1) over (1.4.0-1~local) ...
Preparing to unpack .../62-libdvdcss2_1.4.0-dmo1_amd64.deb ...
Unpacking libdvdcss2:amd64 (1.4.0-dmo1) over (1.4.0-1~local) ...
Preparing to unpack .../63-libgegl-0.3-0_1%3a0.3.18-dmo1_amd64.deb ...
Unpacking libgegl-0.3-0:amd64 (1:0.3.18-dmo1) over (0.3.8-4) ...
Selecting previously unselected package libjansson4:amd64.
Preparing to unpack .../64-libjansson4_2.9-1_amd64.deb ...
Unpacking libjansson4:amd64 (2.9-1) ...
Selecting previously unselected package libqt4-xml:amd64.
Preparing to unpack .../65-libqt4-xml_4%3a4.8.7+dfsg-11_amd64.deb ...
Unpacking libqt4-xml:amd64 (4:4.8.7+dfsg-11) ...
Selecting previously unselected package libqtdbus4:amd64.
Preparing to unpack .../66-libqtdbus4_4%3a4.8.7+dfsg-11_amd64.deb ...
Unpacking libqtdbus4:amd64 (4:4.8.7+dfsg-11) ...
Selecting previously unselected package qtchooser.
Preparing to unpack .../67-qtchooser_63-g13a3d08-1_amd64.deb ...
Unpacking qtchooser (63-g13a3d08-1) ...
Selecting previously unselected package qdbus.
Preparing to unpack .../68-qdbus_4%3a4.8.7+dfsg-11_amd64.deb ...
Unpacking qdbus (4:4.8.7+dfsg-11) ...
Selecting previously unselected package libqt4-dbus:amd64.
Preparing to unpack .../69-libqt4-dbus_4%3a4.8.7+dfsg-11_amd64.deb ...
Unpacking libqt4-dbus:amd64 (4:4.8.7+dfsg-11) ...
Selecting previously unselected package qt-at-spi:amd64.
Preparing to unpack .../70-qt-at-spi_0.4.0-5_amd64.deb ...
Unpacking qt-at-spi:amd64 (0.4.0-5) ...
Preparing to unpack .../71-vdpau-va-driver_0.7.4-dmo7_amd64.deb ...
Unpacking vdpau-va-driver:amd64 (0.7.4-dmo7) over (0.7.4-6) ...
Selecting previously unselected package handbrake-cli.
Preparing to unpack .../72-handbrake-cli_1%3a1.0.7-dmo3_amd64.deb ...
Unpacking handbrake-cli (1:1.0.7-dmo3) ...
Preparing to unpack .../73-handbrake_1%3a1.0.7-dmo3_all.deb ...
Unpacking handbrake (1:1.0.7-dmo3) over (0.10.5+ds1-2+b3) ...
Preparing to unpack .../74-librtmp1_2%3a2.4~20160119.gitfa8646dae-dmo5_amd64.deb ...
Unpacking librtmp1:amd64 (2:2.4~20160119.gitfa8646dae-dmo5) over (2.4+20151223.gitfa8646d.1-1+b1) ...
Setting up libx265-116:amd64 (1:2.4-dmo1) ...
Setting up gstreamer1.0-libav:amd64 (1:1.10.4-dmo1) ...
Setting up libtwolame0:amd64 (1:0.3.13-dmo3) ...
Setting up libusageenvironment3 (2:2017.04.26-dmo1) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for desktop-file-utils (0.23-1) ...
Setting up vlc-data (1:2.2.6-dmo2+deb9u1) ...
Setting up libdvbpsi10:amd64 (1:1.3.1-dmo1) ...
Setting up libbasicusageenvironment1 (2:2017.04.26-dmo1) ...
Setting up libaacs0:amd64 (0.9.0-dmo1) ...
Setting up qtcore4-l10n (4:4.8.7+dfsg-11) ...
Processing triggers for libglib2.0-0:amd64 (2.50.3-2) ...
Setting up libebml4v5:amd64 (1:1.3.4-dmo1) ...
Setting up libbabl-0.1-0:amd64 (1:0.1.28-dmo1) ...
Setting up libvlccore8:amd64 (1:2.2.6-dmo2+deb9u1) ...
Setting up qtchooser (63-g13a3d08-1) ...
Setting up libjansson4:amd64 (2.9-1) ...
Setting up libass9:amd64 (2:0.13.7-dmo1) ...
Setting up libvidstab1.0 (2:0.98b-dmo1+deb8u1) ...
Setting up libilbc2:amd64 (2.0.2-dmo4) ...
Setting up libbluray2:amd64 (2:1.0.0-dmo1) ...
Setting up liblivemedia58 (2:2017.04.26-dmo1) ...
Setting up librtmp1:amd64 (2:2.4~20160119.gitfa8646dae-dmo5) ...
Setting up libxvidcore4:amd64 (3:1.3.4-dmo1) ...
Setting up vlc-l10n (1:2.2.6-dmo2+deb9u1) ...
Setting up libx264-150:amd64 (3:0.150.2833+gitdf79067-dmo1) ...
Setting up vdpau-va-driver:amd64 (0.7.4-dmo7) ...
Setting up liblept5 (1.74.1-1) ...
Setting up libtesseract-data (3.04.01-5) ...
Setting up vlc-plugin-video-output:amd64 (1:2.2.6-dmo2+deb9u1) ...
Setting up libmp3lame0:amd64 (1:3.99.5-dmo6) ...
Setting up libdvdcss2:amd64 (1.4.0-dmo1) ...
Setting up libvo-amrwbenc0:amd64 (0.1.3-1) ...
Processing triggers for libc-bin (2.24-11) ...
Setting up libqtcore4:amd64 (4:4.8.7+dfsg-11) ...
Setting up libmfx0:amd64 (1.21-dmo1) ...
Setting up vlc-plugin-video-splitter:amd64 (1:2.2.6-dmo2+deb9u1) ...
Setting up libgroupsock8 (2:2017.04.26-dmo1) ...
Processing triggers for man-db (2.7.6.1-2) ...
Setting up vlc-plugin-visualization:amd64 (1:2.2.6-dmo2+deb9u1) ...
Setting up gstreamer1.0-plugins-ugly:amd64 (1:1.10.4-dmo1) ...
Setting up libfdk-aac1:amd64 (1:0.1.5-dmo2) ...
Setting up libkvazaar3:amd64 (1:1.1.0-dmo1) ...
Setting up libbdplus0 (0.1.2-dmo1+deb8u1) ...
Setting up vlc-plugin-notify:amd64 (1:2.2.6-dmo2+deb9u1) ...
Setting up libdca0:amd64 (0.0.5-dmo2+deb8u1) ...
Setting up libopenh264-2:amd64 (1.6.0-dmo3) ...
Setting up libtesseract3 (3.04.01-5) ...
Processing triggers for hicolor-icon-theme (0.15-1) ...
Setting up libqt4-xml:amd64 (4:4.8.7+dfsg-11) ...
Setting up libtag-extras1 (1.0.1-3.1) ...
Setting up libdvdcss-dev:amd64 (1.4.0-dmo1) ...
Setting up easytag (1:2.4.3-dmo1) ...
Setting up libqtgui4:amd64 (4:4.8.7+dfsg-11) ...
Setting up libmatroska6v5:amd64 (1:1.4.5-dmo1) ...
Setting up libvlc5:amd64 (1:2.2.6-dmo2+deb9u1) ...
Setting up libavutil55:amd64 (10:3.3.2-dmo1) ...
Setting up vlc-plugin-samba:amd64 (1:2.2.6-dmo2+deb9u1) ...
Setting up vlc-plugin-qt:amd64 (1:2.2.6-dmo2+deb9u1) ...
Setting up handbrake-cli (1:1.0.7-dmo3) ...
Setting up libswresample2:amd64 (10:3.3.2-dmo1) ...
Setting up lame (1:3.99.5-dmo6) ...
Setting up libvlc-bin:amd64 (1:2.2.6-dmo2+deb9u1) ...
Setting up libswscale4:amd64 (10:3.3.2-dmo1) ...
Setting up libpostproc54:amd64 (10:3.3.2-dmo1) ...
Setting up vlc-plugin-skins2:amd64 (1:2.2.6-dmo2+deb9u1) ...
Setting up libqtdbus4:amd64 (4:4.8.7+dfsg-11) ...
Setting up vlc-bin (1:2.2.6-dmo2+deb9u1) ...
Setting up handbrake (1:1.0.7-dmo3) ...
Setting up libavresample3:amd64 (10:3.3.2-dmo1) ...
Setting up libavcodec57:amd64 (10:3.3.2-dmo1) ...
Setting up libasound2-plugins:amd64 (1:1.1.4-dmo1) ...
Setting up qdbus (4:4.8.7+dfsg-11) ...
Setting up libqt4-dbus:amd64 (4:4.8.7+dfsg-11) ...
Setting up libchromaprint1:amd64 (1:1.4.2-dmo1) ...
Setting up qt-at-spi:amd64 (0.4.0-5) ...
Setting up libavformat57:amd64 (10:3.3.2-dmo1) ...
Setting up vlc-plugin-base:amd64 (1:2.2.6-dmo2+deb9u1) ...
Setting up libgegl-0.3-0:amd64 (1:0.3.18-dmo1) ...
Setting up libavfilter6:amd64 (10:3.3.2-dmo1) ...
Setting up vlc (1:2.2.6-dmo2+deb9u1) ...
Processing triggers for libc-bin (2.24-11) ...
Processing triggers for libvlc-bin:amd64 (1:2.2.6-dmo2+deb9u1) ...

In case you missed it, handbrake has lost it's gui and has gone cli
I want my gui back...

sudo apt-get install handbrake-gtk 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  geoclue-2.0 libgeoclue-2-0 libjavascriptcoregtk-3.0-0 libmbim-glib4 libmbim-proxy libmm-glib0
  libqmi-glib5 libqmi-proxy libwebkitgtk-3.0-0 modemmanager
Recommended packages:
  iio-sensor-proxy
The following NEW packages will be installed:
  geoclue-2.0 handbrake-gtk libgeoclue-2-0 libjavascriptcoregtk-3.0-0 libmbim-glib4 libmbim-proxy
  libmm-glib0 libqmi-glib5 libqmi-proxy libwebkitgtk-3.0-0 modemmanager
0 upgraded, 11 newly installed, 0 to remove and 1 not upgraded.
Need to get 18.1 MB of archives.
After this operation, 69.6 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 [url]http://gb.mirror.devuan.org/merged[/url] ascii/main amd64 libgeoclue-2-0 amd64 2.4.5-1 [29.2 kB]
Get:11 [url]http://www.deb-multimedia.org[/url] stretch/main amd64 handbrake-gtk amd64 1:1.0.7-dmo3 [6,773 kB]
Get:2 [url]http://gb.mirror.devuan.org/merged[/url] ascii/main amd64 libmm-glib0 amd64 1.6.4-1 [180 kB]
Get:3 [url]http://gb.mirror.devuan.org/merged[/url] ascii/main amd64 geoclue-2.0 amd64 2.4.5-1 [84.6 kB]
Get:4 [url]http://gb.mirror.devuan.org/merged[/url] ascii/main amd64 libjavascriptcoregtk-3.0-0 amd64 2.4.11-3 [1,948 kB]
Get:5 [url]http://gb.mirror.devuan.org/merged[/url] ascii/main amd64 libmbim-glib4 amd64 1.14.0-1+b1 [66.7 kB]
Get:6 [url]http://gb.mirror.devuan.org/merged[/url] ascii/main amd64 libmbim-proxy amd64 1.14.0-1+b1 [7,466 B]
Get:7 [url]http://gb.mirror.devuan.org/merged[/url] ascii/main amd64 libqmi-glib5 amd64 1.16.2-1 [365 kB]
Get:8 [url]http://gb.mirror.devuan.org/merged[/url] ascii/main amd64 libqmi-proxy amd64 1.16.2-1 [8,620 B]
Get:9 [url]http://gb.mirror.devuan.org/merged[/url] ascii/main amd64 libwebkitgtk-3.0-0 amd64 2.4.11-3 [8,057 kB]
Get:10 [url]http://gb.mirror.devuan.org/merged[/url] ascii/main amd64 modemmanager amd64 1.6.4-1 [629 kB]          
Fetched 18.1 MB in 6s (2,820 kB/s)                                                                      
Selecting previously unselected package libgeoclue-2-0:amd64.
(Reading database ... 112653 files and directories currently installed.)
Preparing to unpack .../00-libgeoclue-2-0_2.4.5-1_amd64.deb ...
Unpacking libgeoclue-2-0:amd64 (2.4.5-1) ...
Selecting previously unselected package libmm-glib0:amd64.
Preparing to unpack .../01-libmm-glib0_1.6.4-1_amd64.deb ...
Unpacking libmm-glib0:amd64 (1.6.4-1) ...
Selecting previously unselected package geoclue-2.0.
Preparing to unpack .../02-geoclue-2.0_2.4.5-1_amd64.deb ...
Unpacking geoclue-2.0 (2.4.5-1) ...
Selecting previously unselected package libjavascriptcoregtk-3.0-0:amd64.
Preparing to unpack .../03-libjavascriptcoregtk-3.0-0_2.4.11-3_amd64.deb ...
Unpacking libjavascriptcoregtk-3.0-0:amd64 (2.4.11-3) ...
Selecting previously unselected package libmbim-glib4:amd64.
Preparing to unpack .../04-libmbim-glib4_1.14.0-1+b1_amd64.deb ...
Unpacking libmbim-glib4:amd64 (1.14.0-1+b1) ...
Selecting previously unselected package libmbim-proxy.
Preparing to unpack .../05-libmbim-proxy_1.14.0-1+b1_amd64.deb ...
Unpacking libmbim-proxy (1.14.0-1+b1) ...
Selecting previously unselected package libqmi-glib5:amd64.
Preparing to unpack .../06-libqmi-glib5_1.16.2-1_amd64.deb ...
Unpacking libqmi-glib5:amd64 (1.16.2-1) ...
Selecting previously unselected package libqmi-proxy.
Preparing to unpack .../07-libqmi-proxy_1.16.2-1_amd64.deb ...
Unpacking libqmi-proxy (1.16.2-1) ...
Selecting previously unselected package libwebkitgtk-3.0-0:amd64.
Preparing to unpack .../08-libwebkitgtk-3.0-0_2.4.11-3_amd64.deb ...
Unpacking libwebkitgtk-3.0-0:amd64 (2.4.11-3) ...
Selecting previously unselected package modemmanager.
Preparing to unpack .../09-modemmanager_1.6.4-1_amd64.deb ...
Unpacking modemmanager (1.6.4-1) ...
Selecting previously unselected package handbrake-gtk.
Preparing to unpack .../10-handbrake-gtk_1%3a1.0.7-dmo3_amd64.deb ...
Unpacking handbrake-gtk (1:1.0.7-dmo3) ...
Setting up libmbim-glib4:amd64 (1.14.0-1+b1) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for desktop-file-utils (0.23-1) ...
Setting up libgeoclue-2-0:amd64 (2.4.5-1) ...
Setting up libjavascriptcoregtk-3.0-0:amd64 (2.4.11-3) ...
Setting up libmbim-proxy (1.14.0-1+b1) ...
Processing triggers for libc-bin (2.24-11) ...
Setting up libmm-glib0:amd64 (1.6.4-1) ...
Processing triggers for man-db (2.7.6.1-2) ...
Processing triggers for dbus (1.10.18-1+devuan2.3) ...
Processing triggers for hicolor-icon-theme (0.15-1) ...
Setting up libwebkitgtk-3.0-0:amd64 (2.4.11-3) ...
Setting up handbrake-gtk (1:1.0.7-dmo3) ...
Setting up libqmi-glib5:amd64 (1.16.2-1) ...
Setting up libqmi-proxy (1.16.2-1) ...
Setting up geoclue-2.0 (2.4.5-1) ...
Setting up modemmanager (1.6.4-1) ...
Processing triggers for libc-bin (2.24-11) ...
Processing triggers for dbus (1.10.18-1+devuan2.3) ...

Last edited by zenkaon (2017-07-19 16:17:09)

Offline

#6 2017-07-18 22:28:59

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 101

Re: Can I use Debian multimedia?

Some people would use "code" blocks to make their posts readable.
Other people don't bother and don't get read.

Offline

#7 2017-07-18 22:29:01

greenjeans
Member
Registered: 2017-04-07
Posts: 282
Website

Re: Can I use Debian multimedia?

<shameless self-promotion and back patting>  Pretty much everything you mentioned above, Vuu-do (maximal versions) will do out of the box including play DVD's. Don't know about blu-ray as I don't have a machine with a blu-ray optic drive to test with.

VLC
Handbrake
Asunder +lame
Winff (file conversion)
libdvdcss2
Exaile

All included. You can also rip radio streams through Exaile using the Streamripper backend (also included).

And this is all in jessie, so it's actually stable and well tested. And no deb-multimedia!

</shameless self-promotion and back patting>


https://sourceforge.net/projects/vuu-do/
Vuu-do GNU/Linux, minimal 64 and 32 bit Devuan-based openbox and mate systems to build on, maximal versions if you prefer your linux fully-loaded.

Refracta and Miyolinux had too many tequila shots one night...    ....9 months later a vuu-do chile was born.....;-)

Offline

#8 2017-07-19 01:01:03

zenkaon
Member
Registered: 2017-07-17
Posts: 9

Re: Can I use Debian multimedia?

@ralph - new to this forum and it's interface. Apologies. Appreciate it's a bit long with the apt-get output, was hoping to attach a text file but don't see how. The post is actually a copy-n-paste job from the log file I made whilst investigating and was hoping to attach. I was asked to log observations by @golinux and think that it's quite important to see specifically which ascii packages are being replaced. I'm more interested in understanding what's happening - e.g. does the replacement of libgroupsock8 (to pick something at random - I have no idea what it does) have wider ramifications that need to be understood.

@greenjeans - Blu-Ray has been a bitch to get working on Linux for a long long time. I was over the moon to get it working in stretch in vlc. MakeMKV has worked for a while now, but often a Blu-Ray will have 100's of tracks with different ordering of the segments in a classic security through obscurity fashion. Having vlc to cross-reference can be invaluable. I'm mainly on a laptop, but splashed out on a cheep USB Blu-Ray drive on ebay from china for $20 deal. It's by far the worse bit of kit I have, but it reads Blu-Ray which means I can play around with Blu-Ray. Good luck with VUU

Offline

#9 2017-07-19 01:38:35

golinux
Administrator
Registered: 2016-11-25
Posts: 551

Re: Can I use Debian multimedia?

@zenkaon . . . free free to edit your post to add the code tags.   There is a line of formatting options above the input box that will do Just that with one mouse click.  wink

Offline

#10 2017-07-19 16:18:52

zenkaon
Member
Registered: 2017-07-17
Posts: 9

Re: Can I use Debian multimedia?

@gloinux, @ralph - thanks for the formatting advice.

Offline

#11 2017-07-19 16:55:09

fungus
Member
From: Any witch way
Registered: 2017-07-12
Posts: 263
Website

Re: Can I use Debian multimedia?

One thing to keep in mind is that deb-multimedia is not debian but their own multimedia repository.  Debian has no longer have anything to do with it so keep that in mind if things don't work out or work but in a strange way.  Do some research, there is a reason that debian would not host their stuff anymore, and it wasn't cost and space on mirrors.

I think the response here is just like the one you would get from debian.  There are tons and tons of stuff out there you can download and compile for your system.  Why should there be anyone's endorsement to try them?  Just think first what it all means.  Then make your own decision.  It is not an excuse to say that fungus over at devuan told me it was ok.  Would kali or parrot claim they are a debian-security suite?  Would tails say it is debian-anonymity?  If they did would you trust them more and hold debian responsible?

I hope you get my drift.  There is also github, and sourceforge, and upstream.

Offline

#12 2017-07-19 21:47:33

zenkaon
Member
Registered: 2017-07-17
Posts: 9

Re: Can I use Debian multimedia?

@fungus - I get your drift. I've always relied on deb-multimedia to do some of the stuff I want to do since wheezy days. One thing that I found from this little experiment is that I can do all I want to without deb-multimedia, which makes it somewhat surplus to my requirements.

I then went ahead and used it anyways to see what would happen, from a purely academic standpoint as I'd started a thread on the subject, and because I like poking things and seeing if they brake.

That particular instance of devuan has been wiped as I'm trying to understand https://dev1galaxy.org/viewtopic.php?id=1156 what's going on with my encrypted volumes in ascii....

Offline

#13 2017-07-20 19:17:21

greenjeans
Member
Registered: 2017-04-07
Posts: 282
Website

Re: Can I use Debian multimedia?

zenkaon wrote:

I'm mainly on a laptop, but splashed out on a cheep USB Blu-Ray drive on ebay from china for $20 deal. It's by far the worse bit of kit I have, but it reads Blu-Ray which means I can play around with Blu-Ray. Good luck with VUU

About to rebuild the nicer desktop at the house, and that's one of the things I was going to upgrade both to use and to play around with in linux.

Were you able to get blu-ray working with open-source video drivers or did you need proprietary?


https://sourceforge.net/projects/vuu-do/
Vuu-do GNU/Linux, minimal 64 and 32 bit Devuan-based openbox and mate systems to build on, maximal versions if you prefer your linux fully-loaded.

Refracta and Miyolinux had too many tequila shots one night...    ....9 months later a vuu-do chile was born.....;-)

Offline

#14 2017-07-21 10:51:11

zenkaon
Member
Registered: 2017-07-17
Posts: 9

Re: Can I use Debian multimedia?

@greenjeans - the most important part is the KEYDB.cfg file which I've shown you how to wget

Any modern graphics card shouldn't have an issue (open or proprietary). My laptop has a particularly underwhelming intel chip and does fine with open source drivers. I tend to prefer nvidia cards, but I'm bias as I'm a cuda dev who uses K80's at work to do machine learning (proper graphics cards don't have any ports on the back of them)

Last edited by zenkaon (2017-07-21 10:52:14)

Offline

#15 2017-07-24 16:03:35

mckaygerhard
Member
Registered: 2017-04-21
Posts: 157
Website

Re: Can I use Debian multimedia?

well i used deb-multimedia in devuan and except for 2 packages all are 100% compatible, the only two broken are one of the xorg vpau related and the other i dont remenber..

mplayer works pretty good (mplayer1) and tested (but i dont like) the mpv also.. currently used the mlt with kdenlive and openshot and works pretty stable.. clementine need some patches due almost all radio station now are paid services..

in general deb-multimedia does not have some mayor problems.. i you integrate it and use it, due i dont see systemd related packages in it

without deb-multimedia the devuan or debian system are very limited .. that's the true!

PD: edited: deb-multimedia need pining for devuan respect debian and backported proxy repositories, other way its just using aptitude and install one by one manually

Last edited by mckaygerhard (2017-07-24 16:05:35)

Offline

Board footer