The officially official Devuan Forum!

You are not logged in.

#1 2024-03-30 14:16:03

freegamea1
Member
Registered: 2024-03-30
Posts: 1  

[SOLVED] strange process.

sudo ps aux | grep ssh
user      2091  0.0  0.0   7740  2120 ?        Ss   17:10   0:00 /usr/bin/ssh-agent env LD_PRELOAD=libgtk3-nocsd.so.0 x-session-manager

what is this? and how i can disable ssh-agent in devuan?

Offline

#2 2024-03-30 17:20:03

chris2be8
Member
Registered: 2018-08-11
Posts: 265  

Re: [SOLVED] strange process.

See the man page for ssh-agent (although a quick look doesn't say how to disable it). I've not used it myself though.

Offline

#3 2024-03-30 18:19:00

Altoid
Member
Registered: 2017-05-07
Posts: 1,429  

Re: [SOLVED] strange process.

Hello:

I have the same/similar process:

~$ sudo ps aux | grep ssh
user   3129  0.0  0.0   5864   472 ?        Ss   14:00   0:00 /usr/bin/ssh-agent x-session-manager
user  10581  0.0  0.0   3084   896 pts/0    S+   15:10   0:00 grep --color=always ssh
~$ 

This is because I have openssh-client installed so I can command-line log into a headless VM I have running in my box.

~$ apt list | grep installed | grep ssh-
libssh-gcrypt-4/oldoldstable-security,now 0.8.7-1+deb10u2 amd64 [installed,automatic]
openssh-client/oldoldstable-security,now 1:7.9p1-10+deb10u4 amd64 [installed]
ssh-askpass/oldoldstable,now 1:1.2.4.1-10 amd64 [installed,automatic]
~$ 

Best,

A.

Offline

#4 2024-03-30 20:58:20

ralph.ronnquist
Administrator
From: Battery Point, Tasmania, AUS
Registered: 2016-11-30
Posts: 1,118  

Re: [SOLVED] strange process.

Try by adding a single "#" at the beginning of the line that says use-ssh-agent in /etc/X11/Xsession.options; then log out and in to restart the X session.

Online

Board footer