The officially official Devuan Forum!

You are not logged in.

#1 2024-03-14 20:45:32

chomwitt
Member
Registered: 2019-09-24
Posts: 119  

virt-manager works only when started as root.

$ dpkg -l virt-manager
ii  virt-manager   1:4.1.0-2    all          desktop application for managing virtual machines

I have added myself to the libvirt group (to pass another error : unable to connect to libvirt)
but now starting virt-manager as a regular user i see 'QEMU/KVM - Not connected' and left clicking on the create a new virtual machine
i see a error window "Error : No active connection to install on."

But $ sudo virt-manager doesnt display that issue.

Last edited by chomwitt (2024-03-14 22:42:39)


Devuan(Chimaera)(Daedalus)  DS+WM: XorgX11server+StumpVM

Offline

#2 2024-03-14 21:59:32

GlennW
Member
From: Brisbane, Australia
Registered: 2019-07-18
Posts: 587  

Re: virt-manager works only when started as root.

Hi, talking about permissions...

I used to run windows on a virtual (box) machine, and I used these changes to smooth the way...

#chown -hR vboxusers:vboxusers /opt/VirtualBox/VBox.sh
#chown -hR vboxusers:vboxusers /usr/bin/VirtualBox
#chmod -R 755 /usr/bin/VirtualBox
#chmod -R 755 /opt/VirtualBox/VBox.sh
#chgrp -h glenn /home/glenn/local/vm1/
#chmod -R 755 /home/glenn/local/vm1/

Just sharing the idea... I hope it helps.


pic from 1993, new guitar day.

Online

#3 2024-03-14 23:21:49

chomwitt
Member
Registered: 2019-09-24
Posts: 119  

Re: virt-manager works only when started as root.

GlennW thanks for the ideas but i think virtualbox is a different virtualization program .

For time being i followed the https://wiki.archlinux.org/title/Virt-manager  instructions and it worked.

Last edited by chomwitt (2024-03-15 06:31:51)


Devuan(Chimaera)(Daedalus)  DS+WM: XorgX11server+StumpVM

Offline

#4 2024-03-15 06:14:48

GlennW
Member
From: Brisbane, Australia
Registered: 2019-07-18
Posts: 587  

Re: virt-manager works only when started as root.

Great! It's the permissions I was reffering to. But glad you got it working.


pic from 1993, new guitar day.

Online

#5 2024-03-15 06:36:15

chomwitt
Member
Registered: 2019-09-24
Posts: 119  

Re: virt-manager works only when started as root.

Sorry. I guess you are right in guiding towards a pemission issue because eventually i had to change permission
related libvirtd options:

$ sudo nano /etc/libvirt/libvirtd.conf

unix_sock_group = "libvirt"
unix_sock_rw_perms = "0770"

$ sudo nano /etc/libvirt/qemu.con
user = "chomwitt"

group = "chomwitt"

And it was essential  to do also:

Upon opening Virt-Manager, it will default to the system variant (root) of the QEMU connection.
This can be changed to the user connection by going to: File > Add Connection.
Now select QEMU/KVM User session as the Hypervisor and click OK

Last edited by chomwitt (2024-03-15 06:42:17)


Devuan(Chimaera)(Daedalus)  DS+WM: XorgX11server+StumpVM

Offline

#6 2024-03-15 12:36:32

stopAI
Member
Registered: 2023-04-04
Posts: 131  

Re: virt-manager works only when started as root.

Just add your user to

libvirt-qemu

group and relogin session.

Last edited by stopAI (2024-03-15 12:36:43)

Offline

#7 2024-03-17 05:36:22

chomwitt
Member
Registered: 2019-09-24
Posts: 119  

Re: virt-manager works only when started as root.

I will try that and report back in this same reply.


Devuan(Chimaera)(Daedalus)  DS+WM: XorgX11server+StumpVM

Offline

Board footer