The officially official Devuan Forum!

You are not logged in.

#1 2024-02-03 15:42:27

chomwitt
Member
Registered: 2019-09-24
Posts: 108  

Help needed with StumpWM

$ sudo apt-cache show stumpwm
Package: stumpwm
Version: 2:22.11-3

/usr/share/doc/stumpwm/NEWS:
* Changes since 0.9.6
** in float mode windows can be resized with the middle mouse button
....

And while StumpWM is running Prefix + v  gives :  1.0.1 compiled at January 2024.

So what is the 2:22.11-3 for ?
Also the version i use has various bugs . If anyone has managed to compile (or wants to) the latest
version please tell me to help each other.

-------------------------------- my compilation effort
$ dpkg -L stumpwm
/usr/bin/stumpwm        // that is the stumpwm binary from the package Version: 2:22.11-3 in Daedalus.

Following the instructions more closely in the github page i managed to compiled.
I think it crucial to install a linux sbcl binary from the sbcl project page as instructed
and follow the instructions from there.

After installing the sbcl binary and loading to it the libraries needed we
compile the stumpwm src :
$ git clone https://github.com/stumpwm/stumpwm.git
$ ./autogen.sh
$ ./configure
$ make
$ sudo make install

'/usr/local/bin/stumpwm'   is the directory that will be installed if we compile the github sources.
We put that path in .xinitrc and we are ok

-----------------------------------------

Of course that leaves a bitter taste in my Devuan admin mouth. The package 'stumpwm' can not work with sblc  devuan package and that result in  an older version running?  And thus instead of 22.11-3 we get 1.0.1 ?

----------------------------------------
StumpWM main page
Debian tracker / StumpWM

Last edited by chomwitt (2024-02-03 17:23:06)


Devuan(Chimaera)(Daedalus)  DS+WM: XorgX11server+StumpVM

Offline

#2 2024-02-03 16:45:37

boughtonp
Member
From: UK
Registered: 2023-01-19
Posts: 187  
Website

Re: Help needed with StumpWM

Debian version numbers are explained in section 5.6.12 of the Debian Policy Manual:

Debian Policy Manual, section 5.6.12 wrote:

The version number of a package. The format is: [epoch:]upstream_version[-debian_revision].

The three components here are:

epoch
    This is a single (generally small) unsigned integer. It may be omitted, in which case zero is assumed.

    Epochs can help when the upstream version numbering scheme changes, but they must be used with care. You should not change the epoch, even in experimental, without getting consensus on debian-devel first.

upstream_version
    This is the main part of the version number. It is usually the version number of the original (“upstream”) package from which the .deb file has been made, if this is applicable. Usually this will be in the same format as that specified by the upstream author(s); however, it may need to be reformatted to fit into the package management system’s format and comparison scheme.

    The comparison behavior of the package management system with respect to the upstream_version is described below. The upstream_version portion of the version number is mandatory.

    The upstream_version must contain only alphanumerics 6 and the characters . + - ~ (full stop, plus, hyphen, tilde) and should start with a digit. If there is no debian_revision then hyphens are not allowed.

debian_revision
    This part of the version number specifies the version of the Debian package based on the upstream version. It must contain only alphanumerics and the characters + . ~ (plus, full stop, tilde) and is compared in the same way as the upstream_version is.

    It is conventional to restart the debian_revision at 1 each time the upstream_version is increased.

    The package management system will break the version number apart at the last hyphen in the string (if there is one) to determine the upstream_version and debian_revision. The absence of a debian_revision is equivalent to a debian_revision of 0.

    Presence of the debian_revision part indicates this package is a non-native package (see Source packages). Absence indicates the package is a native package.

So the version is 22.11, with an epoch of 2 is because the StumpWM developers appear to have a habit of changing versioning convention.

Checking //tracker.debian.org/stumpwm suggests there was no version 1.0.1 in Debian, though following the homepage link shows documentation links for a "v1.0.1-rc" (but also links for both "1.0.0" and "v1.0.0" so not sure what's up there), as well as for "22.11" and others.

If compiling from source, the correct source code to use is the Debian source code, linked from the Debian Package Tracker link above, (and making sure to switch to the branch corresponding to the Debian/Devuan version being used, otherwise there may be dependency issues).


3.1415P265E589T932E846R64338

Offline

#3 2024-02-05 07:19:42

chomwitt
Member
Registered: 2019-09-24
Posts: 108  

Re: Help needed with StumpWM

@boughtonp  that is usefull info on version format.
But why installing in Daedalus stumpwm 2:22.11-3 when i run it says in the NEWS changes up to 0.9.6 version  and while running reports "version 1.0.1 compiled in 05 February 2024: (date i last tried ! ) ?

I dont compile it. that what it says. I just installed it.

And that happens even if i have sbcl installed not from the devuan repos but from the sblc site (newest stable version).

I also checked the arch stumpwm-22.11-3-x86_64.pkg.tar.zst .
It doesnt contain any NEWS .

Both arch and devuan-debian package contain a README that states :

Note: The recommended way to install SBCL is by downloading one of their
pre-built binaries available in their [web page][sbcl-platform-table] or build
it from source. Please do _not_ install SBCL using your distributions package
manager, especially Ubuntu. If you do so it is likely that you'll run into
problems when building StumpWM due to using obsolete versions of the
dependencies.

Also the debs contain a lot of lisp files. The arch package contains only the binary.

And in the deb the binary /usr/bin/stumpwm is a shell script:

sbcl --load "/usr/lib/stumpwm/load.lisp"

Last edited by chomwitt (2024-02-05 08:19:51)


Devuan(Chimaera)(Daedalus)  DS+WM: XorgX11server+StumpVM

Offline

#4 2024-02-05 08:31:01

chomwitt
Member
Registered: 2019-09-24
Posts: 108  

Re: Help needed with StumpWM

That is the devuan and the debian package stumpwm (2:22.11-3)

I just noticed that deb packages  have a package for ALL architectures. But arch has a binary for amd64.
So that explains my issue but not entirely. Because could it be that the lisp code is older and not 22.11-3 ?

Last edited by chomwitt (2024-02-05 08:35:01)


Devuan(Chimaera)(Daedalus)  DS+WM: XorgX11server+StumpVM

Offline

Board footer