The officially official Devuan Forum!

You are not logged in.

#1 2024-01-02 14:42:18

kapqa
Member
Registered: 2019-01-02
Posts: 323  

[SOLVED] Upgrade Beowulf to Chimaera / No Network-Manager (applet)

Hello ,

found out that i can fully upgrade the older laptop T60 from Debian Wheezy to Devuan Chimaera with nearly no problem and also not loose graphics acceleration for ATI which is very nice!
Thanks!

Now one issue is visiable since the Devuan 4.0 is installed i no longer have a Network Icon in the upper taskbar (for Ethernet).

The internet functions , i can browse, but am worried that this might cause issue, since i have not found any applet to add to panel.

probably i am missing network-manager?

but it could not install

sudo apt install network-manager
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libpolkit-backend-consolekit-1-0 : Conflicts: elogind but 246.10-2 is to be installed
                                    Conflicts: libpam-elogind but 246.10-2 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Hopefully this has been solved already.

Offline

#2 2024-01-02 14:55:30

rolfie
Member
Registered: 2017-11-25
Posts: 1,017  

Re: [SOLVED] Upgrade Beowulf to Chimaera / No Network-Manager (applet)

On my Chimaera laptop with Cinnamon DE I got as well network-manager as network-manager-gnome installed. AFAIR the installation past the DE went without any hasle with consolekit <> elogind, I am on elogind.

Looking at the dependencies: network-manager-gnome depends on network-manager.

Last edited by rolfie (2024-01-02 14:57:00)

Offline

#3 2024-01-02 16:57:31

pcalvert
Member
Registered: 2017-05-15
Posts: 187  

Re: [SOLVED] Upgrade Beowulf to Chimaera / No Network-Manager (applet)

You need network-manager-gnome and not just network-manager.

Try to install it using aptitude:

sudo aptitude install network-manager-gnome

If there is a problem installing it, aptitude will offer possible solutions.


Freespoke is a new search engine that respects user privacy and does not engage in censorship.

Offline

#4 2024-01-02 21:09:16

kapqa
Member
Registered: 2019-01-02
Posts: 323  

Re: [SOLVED] Upgrade Beowulf to Chimaera / No Network-Manager (applet)

hello ,

thanks very much,
now this is the proposed solution by aptitude

sudo aptitude install network-manager-gnome
The following NEW packages will be installed:
  dnsmasq-base{a} elogind{a} libbluetooth3{a} libmbim-glib4{a} 
  libmbim-proxy{a} libndp0{a} libnm0{a} libnma-common{a} libnma0{a} 
  libpam-elogind{a} libqmi-glib5{a} libqmi-proxy{a} libteamdctl0{a} 
  mobile-broadband-provider-info{a} modemmanager{a} network-manager{a} 
  network-manager-gnome policykit-1-gnome{a} 
0 packages upgraded, 18 newly installed, 0 to remove and 6 not upgraded.
Need to get 6,135 kB/8,837 kB of archives. After unpacking 37.9 MB will be used.
The following packages have unmet dependencies:
 libpolkit-backend-consolekit-1-0 : Conflicts: elogind but 246.10-2 is to be installed
                                    Conflicts: libpam-elogind but 246.10-2 is to be installed
The following actions will resolve these dependencies:

     Remove the following packages:                                             
1)     libpolkit-backend-1-0 [0.105-25+devuan9 (now)]                           
2)     libpolkit-backend-consolekit-1-0 [0.105-25+devuan9 (now)]                

     Upgrade the following packages:                                            
3)     gir1.2-polkit-1.0 [0.105-25+devuan9 (now) -> 0.105-31+devuan2 (oldstable)
4)     libpolkit-agent-1-0 [0.105-25+devuan9 (now) -> 0.105-31+devuan2 (oldstabl
5)     policykit-1 [0.105-25+devuan9 (now) -> 0.105-31+devuan2 (oldstable)]     

hope this can be a stable soluton!

EDIT

Current status: 3 (-3) upgradable.

Last edited by kapqa (2024-01-02 21:10:15)

Offline

#5 2024-01-02 21:33:02

rolfie
Member
Registered: 2017-11-25
Posts: 1,017  

Re: [SOLVED] Upgrade Beowulf to Chimaera / No Network-Manager (applet)

Show us a

# apt list libpolkit-backend-consolekit-1-0 

BTW: have you executed a

# apt full-upgrade 

?

Offline

#6 2024-01-02 22:15:28

pcalvert
Member
Registered: 2017-05-15
Posts: 187  

Re: [SOLVED] Upgrade Beowulf to Chimaera / No Network-Manager (applet)

kapqa wrote:

now this is the proposed solution by aptitude

     Remove the following packages:                                             
1)     libpolkit-backend-1-0 [0.105-25+devuan9 (now)]                           
2)     libpolkit-backend-consolekit-1-0 [0.105-25+devuan9 (now)]                

     Upgrade the following packages:                                            
3)     gir1.2-polkit-1.0 [0.105-25+devuan9 (now) -> 0.105-31+devuan2 (oldstable)
4)     libpolkit-agent-1-0 [0.105-25+devuan9 (now) -> 0.105-31+devuan2 (oldstabl
5)     policykit-1 [0.105-25+devuan9 (now) -> 0.105-31+devuan2 (oldstable)]     

I believe that that's the correct solution. On my Chimaera-based Refracta system, these packages don't even exist:

1)     libpolkit-backend-1-0
2)     libpolkit-backend-consolekit-1-0

In other words, not only are they not installed, they cannot be installed. So those packages are most likely leftovers, in which case they should be removed.


Freespoke is a new search engine that respects user privacy and does not engage in censorship.

Offline

#7 2024-01-03 10:20:21

rolfie
Member
Registered: 2017-11-25
Posts: 1,017  

Re: [SOLVED] Upgrade Beowulf to Chimaera / No Network-Manager (applet)

Would agree. I had the consolekit in the way on an older upgrade once, replaced by the elogind packages.

Offline

#8 2024-01-03 13:43:16

kapqa
Member
Registered: 2019-01-02
Posts: 323  

Re: [SOLVED] Upgrade Beowulf to Chimaera / No Network-Manager (applet)

hello ,

it seems that not everything is function,
since now found out that when resuming from suspend, the ethernet is no more active.

there is a NetworkApplet visible now, but it would only handle "wiFi" as it seems, and i dont know how to "hang" on after losing the Ethernet when resuming from suspend.

when resuming from suspend, there would be short instance in terminal where it says like

revalidation failed

thanks for the valid help.

https://ibb.co/2kD08jZ

Offline

#9 2024-01-03 19:13:27

pcalvert
Member
Registered: 2017-05-15
Posts: 187  

Re: [SOLVED] Upgrade Beowulf to Chimaera / No Network-Manager (applet)

if you haven't done so already, reboot to restore internet access.

Then execute this command and post the output:

sudo apt update && apt full-upgrade -s

Freespoke is a new search engine that respects user privacy and does not engage in censorship.

Offline

#10 2024-01-03 19:29:25

rolfie
Member
Registered: 2017-11-25
Posts: 1,017  

Re: [SOLVED] Upgrade Beowulf to Chimaera / No Network-Manager (applet)

You should be able to configure the network manager to find wired and wireless connections.

Offline

#11 2024-01-03 21:13:03

kapqa
Member
Registered: 2019-01-02
Posts: 323  

Re: [SOLVED] Upgrade Beowulf to Chimaera / No Network-Manager (applet)

thank you, yes internet is back after reboot

and your command would yield

Hit:1 http://deb.devuan.org/merged chimaera InRelease
Hit:2 http://deb.devuan.org/merged chimaera-updates InRelease
Hit:3 http://deb.devuan.org/merged chimaera-security InRelease
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
5 packages can be upgraded. Run 'apt list --upgradable' to see them.
NOTE: This is only a simulation!
      apt needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following package was automatically installed and is no longer required:
  libreadline7
Use 'apt autoremove' to remove it.
The following packages will be REMOVED:
  libgc1c2
The following NEW packages will be installed:
  libgc1 linux-image-5.10.0-27-amd64
The following packages will be upgraded:
  guile-2.2-libs libpolkit-gobject-consolekit-1-0 linux-image-amd64
  linux-libc-dev udisks2
5 upgraded, 2 newly installed, 1 to remove and 0 not upgraded.
Inst guile-2.2-libs [2.2.4+1-2+deb10u1] (2.2.7+1-6 Devuan:4.0/oldstable [amd64]) []
Remv libgc1c2 [1:7.6.4-0.4] []
Inst libgc1 (1:8.0.4-3 Devuan:4.0/oldstable [amd64])
Inst libpolkit-gobject-consolekit-1-0 [0.105-25+devuan9] (0.105-31+devuan2 Devuan:4.0/oldstable [amd64])
Inst linux-image-5.10.0-27-amd64 (5.10.205-2 Devuan-Security:4.0/oldstable-security [amd64])
Inst linux-image-amd64 [5.10.197-1] (5.10.205-2 Devuan-Security:4.0/oldstable-security [amd64])
Inst linux-libc-dev [5.10.197-1] (5.10.205-2 Devuan-Security:4.0/oldstable-security [amd64])
Inst udisks2 [2.8.1-4+devuan1] (2.9.2-2+devuan1 Devuan:4.0/oldstable [amd64])
Conf guile-2.2-libs (2.2.7+1-6 Devuan:4.0/oldstable [amd64])
Conf libgc1 (1:8.0.4-3 Devuan:4.0/oldstable [amd64])
Conf libpolkit-gobject-consolekit-1-0 (0.105-31+devuan2 Devuan:4.0/oldstable [amd64])
Conf linux-image-5.10.0-27-amd64 (5.10.205-2 Devuan-Security:4.0/oldstable-security [amd64])
Conf linux-image-amd64 (5.10.205-2 Devuan-Security:4.0/oldstable-security [amd64])
Conf linux-libc-dev (5.10.205-2 Devuan-Security:4.0/oldstable-security [amd64])
Conf udisks2 (2.9.2-2+devuan1 Devuan:4.0/oldstable [amd64])

rolfie i cannot help to think that after suspend the wired is gone; before, when it was gone i could hit "connect" and it would re-establish ethernet connection; now, i dont find any such connect button any longer, also the icon in taskbar is only showing "Wi-Fi Networks" > (greyed out) > "WiFi is disabled" > (one below) "VPN Connections" ;

no wired , but again, after reboot the internet is functioning through Ethernet cable;

Offline

#12 2024-01-03 21:57:30

pcalvert
Member
Registered: 2017-05-15
Posts: 187  

Re: [SOLVED] Upgrade Beowulf to Chimaera / No Network-Manager (applet)

Okay, go ahead and upgrade your OS with this command:

sudo apt full-upgrade

Then, for good measure, reboot.


Freespoke is a new search engine that respects user privacy and does not engage in censorship.

Offline

#13 2024-01-04 06:50:43

kapqa
Member
Registered: 2019-01-02
Posts: 323  

Re: [SOLVED] Upgrade Beowulf to Chimaera / No Network-Manager (applet)

alright, it seems to "autoreconnect" now after suspend, it just takes a longer time;
still have no visible info about being connected to ethernet in taskbar or otherwise, but i guess thats a minor issue;

if i want to disconnect now with laptop open, probably would have to disconnect the cable then, or maybe there is some terminal command to achieve this.

would say issue is partly solved, thanks alot.

Offline

#14 2024-01-04 09:16:24

kapqa
Member
Registered: 2019-01-02
Posts: 323  

Re: [SOLVED] Upgrade Beowulf to Chimaera / No Network-Manager (applet)

thank you,

i resorted to full install of chimaera, and now the ethernet Network is back in Network Icon,
also ATI acceleration works, which i did not fully expect, very nice!

now the only issue is that suspend is no longer active when closing lid as the screensaver seem somehow prevent it;

if i may, please have a look.

https://imgur.com/CYgDPRw.png

otherwise,all suspend function seem present, also took over the swapfile 1,5x times the ram (T60 can only utilise around 3GB of Ram due to 32bit limitation of chipset), so hibernation should function also fine

xfce4-power-manager --dump
---------------------------------------------------
       Xfce power manager version 4.16.0
With policykit support
With network manager support
---------------------------------------------------
Can suspend: True
Can hibernate: True
Authorised to suspend: True
Authorised to hibernate: True
Authorised to shutdown: True
Has battery: True
Has brightness panel: True
Has power button: True
Has hibernate button: True
Has sleep button: True
Has battery button: True
Has LID: True

Offline

#15 2024-01-04 12:22:43

kapqa
Member
Registered: 2019-01-02
Posts: 323  

Re: [SOLVED] Upgrade Beowulf to Chimaera / No Network-Manager (applet)

solution:

the solution for "none of the screen lock tools ran succesfully, the screen will not be locked"
is to "disable" the screensaver in "PowerManager" "System" "security" > untick "Lock Screen when system is going to sleep"

now system would suspend as desired, and even ask for password when resuming, which is intended behaviour (i have enabled screensaver lock in XFCE Settings > screensaver setting)

Offline

Board footer