The officially official Devuan Forum!

You are not logged in.

#1 2023-09-22 16:23:53

mr12345
Member
Registered: 2023-01-09
Posts: 17  

Can not install "qemu-system-x86"

I am on excalibur now. "qemu-system-x86" somehow depends on "python3-libvirt" which is 9.7.0-1 as of today and then it depends on libvirt0 (>= 9.7.0). But today in the  excalibur and ceres repos we only got  libvirt0 9.6.0-1devuan1.

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Note, selecting 'qemu-system-x86' instead of 'qemu-kvm'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python3-libvirt : Depends: libvirt0 (>= 9.7.0) but 9.6.0-1devuan1 is to be installed

I am just a Linux beginner enthusiast smile

Offline

#2 2023-09-22 17:53:12

mr12345
Member
Registered: 2023-01-09
Posts: 17  

Re: Can not install "qemu-system-x86"

got python3-libvirt_9.6.0-1_amd64.deb from the debian snapshots and it did the trick though it is not right. I think the repos should be revised.


I am just a Linux beginner enthusiast smile

Offline

#3 2023-09-24 11:18:53

ralph.ronnquist
Administrator
From: Clifton Hill, Victoria, AUS
Registered: 2016-11-30
Posts: 1,098  

Re: Can not install "qemu-system-x86"

Yeah. It's something to look at when excalibur is going stable.

Offline

Board footer