The officially official Devuan Forum!

You are not logged in.

#1 2023-08-25 12:28:53

Tritonio
Member
Registered: 2022-01-09
Posts: 31  

Lazarus package broken?

I am trying to install lazarus and apt gives me:

 lazarus-2.2 : Depends: lcl-2.2 (>= 2.2.6+dfsg2-2) but it is not installable
               Recommends: fpc

Synaptic also shows red boxes if I try to tick it.

Have I broken my repositories? I'm on Daedalus, recently upgraded from Chimaera.

Here's my sources.list:

deb http://deb.devuan.org/merged daedalus main non-free contrib
deb-src http://deb.devuan.org/merged daedalus main non-free contrib

deb http://pkgmaster.devuan.org/merged daedalus-security main contrib non-free
deb-src http://pkgmaster.devuan.org/merged daedalus-security main contrib non-free
deb http://deb.devuan.org/merged daedalus-updates main contrib non-free
deb-src http://deb.devuan.org/merged daedalus-updates main contrib non-free

deb http://deb.devuan.org/merged daedalus-backports main contrib non-free
deb-src http://deb.devuan.org/merged daedalus-backports main contrib non-free

Offline

#2 2023-08-25 12:44:11

ralph.ronnquist
Administrator
From: Battery Point, Tasmania, AUS
Registered: 2016-11-30
Posts: 1,144  

Re: Lazarus package broken?

Have you done

apt-get update

.. or whatever the corresponding button presses are on the gui tool?

Have you done

apt-get upgrade

.. or whatever the corresponding button presses are on the gui tool?

Have you done

apt-get dist-upgrade

  .. or whatever the corresponding button presses are on the gui tool?

Thoe are the three steps to follow after having changed sources.list.

Offline

#3 2023-08-25 13:24:47

Tritonio
Member
Registered: 2022-01-09
Posts: 31  

Re: Lazarus package broken?

Hello Ralph. I've done all three during the upgrade to Daedalus and I've done the first two multiple times after it to fetch updates to my installed packages. I tried again right now and I did not see any packages that I have not upgraded (and it did fetch the repos again).

Digging a bit deeper it looks like it fails because
lcl-2.2 is not installable because
lcl-gtk2-2.2 is not installable because
fp-units-gtk2 is an unmet dependency because
libatk1.0-dev depends on libatk1.0-0 (= 2.46.0-5) but 2.48.3-1~bpo12+1 is to be installed and, additionally, libatk1.0-dev depends on gir1.2-atk-1.0 (= 2.46.0-5) but 2.48.3-1~bpo12+1 is to be installed.

So I guess they need an exact version but I have a newer one already installed from stable-backports because of gimp-gap.

But gimp-gap needs any libatk1.0-dev version above or equal to 1.12.4, so why isn't apt simply downgrading my libatk1.0-0 version to fix the dependencies?

As for the gir1.2-atk-1.0 dependency it's because lutris depends on gir1.2-gtk-3.0 which in turn depends on gir1.2-atk-1.0 (>= 2.35.1) which once more means that apt should be able to downgrade from the backported 2.48.3 to 2.46.0 and lutris will be happy too.

I guess apt isn't that smart and I need to manually fix the versions of these two packages? (gir1.2-atk-1.0 and libatk1.0-0) Is there anything I need to remember if I fix their versions? For example, how do I know that I'm not missing out on security updates on them?

Offline

#4 2023-08-25 13:54:37

ralph.ronnquist
Administrator
From: Battery Point, Tasmania, AUS
Registered: 2016-11-30
Posts: 1,144  

Re: Lazarus package broken?

You can check all available versions (wrt your sources.list) of a package P with

apt-cache policy P

That tells if there are any associated security updates.

You can also review package P (wrt to a larger sources.list) at https://pkginfo.devuan.org/P.

Offline

#5 2023-08-25 16:31:03

chris2be8
Member
Registered: 2018-08-11
Posts: 267  

Re: Lazarus package broken?

Should you have non-free-firmware in your sources.list? I don't think that would cause this problem but might cause problems with hardware support later.

Offline

#6 2023-08-25 17:46:34

delgado
Member
Registered: 2022-07-14
Posts: 168  

Re: Lazarus package broken?

Tritonio wrote:

I guess apt isn't that smart and I need to manually fix the versions of these two packages?

apt will not downgrade a package versions, unless you pin it.

Offline

#7 2023-08-25 22:30:38

GlennW
Member
From: Brisbane, Australia
Registered: 2019-07-18
Posts: 596  

Re: Lazarus package broken?

a few things I sometimes use, not mentioned here...

# apt auto-remove -y
# apt --fix-broken install   #with no packages (or specify a solution).
# dpkg -i --auto-deconfigure
# dpkg -i -G # -G do not down Grade

of course, with dpkg you need the package's location.

I hope this helps.


pic from 1993, new guitar day.

Offline

Board footer