The officially official Devuan Forum!

You are not logged in.

#1 2023-08-15 18:52:56

Registered: 2019-09-22
Posts: 2  

[SOLVED] HOWTO make pysolfc work in Daedalus

Pysolfc in the Debian and Devuan repos is so old it needs the file /usr/lib/python3.9/
The version of Python in Debian 12 and Devuan Daedalus is 3.11 and no longer exists.

Obviously I did a dist-upgrade from Chimaera so I had Pysolfc installed already, it just refused to run!
Linux Mint provided the answer.
Download Python 3.9.17 - or whatever the latest version of 3.9 is when you need to do this.
Use xarchiver or similar to extract ONLY Python-3.9.17/Lib/
I created /home/my-username/temptemp and worked from there.

Now copy into /usr/lib/python3.11.
And it works!

The real problem is that the debian maintainer of Pysolfc can't be bothered to update the 4 year old version of Pysolfc to the latest v2.20.1 released in April 2023.
Note that Pysolfc is in debian 11, removed from the latest debian 12, but is back in debian sid!
But still the same old v2.6 that still won't work.
A brave soul raised a bug in debian but nothing has been done about it.

Last edited by DaveT (2023-08-15 18:53:33)


#2 2023-08-15 20:40:40

From: Brisbane, Australia
Registered: 2019-07-18
Posts: 596  

Re: [SOLVED] HOWTO make pysolfc work in Daedalus

I don't use it (yet) but thanks for the hack.

regards, Glenn

pic from 1993, new guitar day.


#3 2023-08-16 08:16:55

Registered: 2019-11-19
Posts: 410  

Re: [SOLVED] HOWTO make pysolfc work in Daedalus

Thanks; noted. smile


Board footer