The officially official Devuan Forum!

You are not logged in.

#1 2023-05-11 12:51:45

kapqa
Member
Registered: 2019-01-02
Posts: 328  

(OS-Prober) Beowulf-Grub looses second NVME entry ...

Hello ,

on the computer have 3 SSD installed

2 NVME with Windows 11/7 and the SSD for Linux Debian/Devuan;

the issue is that when installing newer version of Devuan/Debian, it would after installation only list one NVME in Grubmenu (the NVME0 with Win11) and disregard the second NVME (Windows 7); This happens on Devuan 3.0+;

installing Devuan 2.0 Ascii gets the Grubentries correctly listed

Devuan 2.0
+ recovery
NVME0p1 (Win11)
NVME1p1 (Win7)

however, since the APU is bit newer, it needs newer kernel to function correctly, and upgrading to Devuan 3.0 make me loose again the entry for Windows 7, and during the upgrade getting warned :

Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Windows Boot Manager on /dev/nvme1n1p1@/efi/Microsoft/Boot/bootmgfw.efi
done

please have posted this already on Debian Forum since i started out on Debian and crossed over to Devuan,

any hints thoughts solutions welcome,

here the link to topic over at Debian Forums

https://forums.debian.net/viewtopic.php … 55#p772355

thanks.

Offline

#2 2023-05-13 11:38:25

thierrybo
Member
Registered: 2017-11-11
Posts: 107  

Re: (OS-Prober) Beowulf-Grub looses second NVME entry ...

Hi, because grub behavior changed recently to not detect other OS anymore by default because "IT COULD HARM YOUR SYSTEM"! Since several months on my Devuan Testing, each time grub is upgraded, I have to edit /etc/default/grub/ to re-enable other os detection:

# If your computer has multiple operating systems installed, then you
# probably want to run os-prober. However, if your computer is a host
# for guest OSes installed via LVM or raw disk devices, running
# os-prober can cause damage to those guest OSes as it mounts
# filesystems to look for things.
#GRUB_DISABLE_OS_PROBER=false
GRUB_DISABLE_OS_PROBER=false

then  sudo update-grub

It is a pain in the ass.

Offline

#3 2023-05-13 22:51:37

GlennW
Member
From: Brisbane, Australia
Registered: 2019-07-18
Posts: 613  

Re: (OS-Prober) Beowulf-Grub looses second NVME entry ...

I would put the entries into the /etc/default/grub file, if it did not work with the custom entry (/etc/grub.d/40_custom).


pic from 1993, new guitar day.

Offline

Board footer