The officially official Devuan Forum!

You are not logged in.

#1 2023-02-12 22:34:21

Registered: 2018-04-03
Posts: 2  

Missing BAT0 in /proc/acpi/wakeup, Daedalus, ThinkPad z13 (2022)

Hey guys!

Super stoked to get Devuan "unstable" running almost perfectly out of the box on a new ThinkPad z13.  Really fantastic work!  One of the only remaining issues is with ACPI and waking.  It has an issue where suspend wakes from non-critical battery events.  I used acpi_listen to see that:

battery PNP0C0A:00 00000080 00000001

wakes it from suspend, both when I plug in AC and when I disconnect AC.

When I try to get a 'handle' for this device:

cat /sys/bus/acpi/devices/PNP0C0A:00/path gives \_SB_.PCI0.LPC0.EC0_.BAT0

But my /proc/acpi/wakeup does not contain anything having to do with the battery, of this device:

Device  S-state   Status   Sysfs node
GPP0      S4    *disabled
GPP1      S4    *enabled   pci:0000:00:01.2
GPP2      S0    *disabled
GPP5      S4    *disabled
GPP7      S4    *disabled
SWUS      S4    *disabled
SWUS      S4    *disabled
GP17      S4    *enabled   pci:0000:00:08.1
XHC0      S4    *disabled  pci:0000:63:00.3
XHC1      S4    *disabled  pci:0000:63:00.4
HS03      S4    *disabled  no-bus:usb3-port3
                *disabled  usb:3-3
                *disabled  usb:3-3:1.0
XHC2      S4    *disabled  pci:0000:64:00.0
NHI0      S3    *enabled   pci:0000:64:00.5
XHC3      S3    *disabled  pci:0000:64:00.3
NHI1      S3    *enabled   pci:0000:64:00.6
XHC4      S3    *disabled  pci:0000:64:00.4
LID       S4    *enabled   platform:PNP0C0D:00
SLPB      S3    *enabled   platform:PNP0C0E:00

You can see that I tried disabling wakeups from XHCy, to see if that was somehow the issue, but it wasn't.  (Battery looks like its its own thing, so I didn't think it would work).  I also tried

echo "disabled" > /sys/bus/acpi/devices/PNP0C0A:00/power/wakeup

but that didn't work either.  Any ideas?


#2 2023-02-13 06:14:15

From: London
Registered: 2019-03-24
Posts: 3,125  

Re: Missing BAT0 in /proc/acpi/wakeup, Daedalus, ThinkPad z13 (2022)


# echo 'disabled' > /sys/class/power_supply/BAT0/device/power/wakeup

Brianna Ghey — Rest In Power


#3 2023-02-15 13:55:55

Registered: 2018-04-03
Posts: 2  

Re: Missing BAT0 in /proc/acpi/wakeup, Daedalus, ThinkPad z13 (2022)

Didn't work

Feb 15 05:47:15 ibm/hotkey LEN0268:00 00000080 00006032
Feb 15 05:48:10 button/lid LID close
Feb 15 05:48:36 battery PNP0C0A:00 00000080 00000001
Feb 15 05:48:36 ibm/hotkey LEN0268:00 00000080 00006032

Do you think it might be that ibm/hotkey getting triggered simultaneously with the battery event and that might be what's causing this?


Board footer