The officially official Devuan Forum!

You are not logged in.

#1 2023-01-28 18:50:13

Deze
Member
Registered: 2021-10-17
Posts: 14  

[SOLVED] Bluetooth headphone not showing in PulseAudio/pavucontrol

Hello,

In chimaera I'm trying to playback audio on a bluetooth headphone. All good when following the steps at https://wiki.archlinux.org/title/Bluetooth_headset. The headphone connects briefly in blueman-manager with the orange, green and blue bars displaying 100% signal strenght. In PulseAudio the headphone does not show under Output Devices. How to playback audio over bluetooth headphones?

Thank you for any advice.

Last edited by Deze (2023-01-28 18:50:29)


Devuan GNU/Linux 5 (daedalus) x86_64

Offline

#2 2023-01-29 10:31:26

aitor
Member
From: basque country
Registered: 2016-12-03
Posts: 211  
Website

Re: [SOLVED] Bluetooth headphone not showing in PulseAudio/pavucontrol

Did you try with alsa?


If you work systematically, things will come by itself (Lev D. Landau)

Offline

#3 2023-01-30 10:03:05

Deze
Member
Registered: 2021-10-17
Posts: 14  

Re: [SOLVED] Bluetooth headphone not showing in PulseAudio/pavucontrol

Thanks.
Installed and opened alsamixer, the headphone doesn't show.  Where do i go from here?
No luck with searching with keywords alsa headphone bluetooth.


Devuan GNU/Linux 5 (daedalus) x86_64

Offline

#4 2023-01-30 16:33:48

aitor
Member
From: basque country
Registered: 2016-12-03
Posts: 211  
Website

Re: [SOLVED] Bluetooth headphone not showing in PulseAudio/pavucontrol

What's the output of

$ amixer -c 0 scontrols

You can try your luck with higher card numbers, for example -c 1


If you work systematically, things will come by itself (Lev D. Landau)

Offline

#5 2023-01-30 16:43:11

Deze
Member
Registered: 2021-10-17
Posts: 14  

Re: [SOLVED] Bluetooth headphone not showing in PulseAudio/pavucontrol

$ amixer -c 1 scontrols
Invalid card number.

$ amixer -c 0 scontrols
Simple mixer control 'Master',0
Simple mixer control 'Headphone',0
Simple mixer control 'Headphone',1
Simple mixer control 'Speaker',0
Simple mixer control 'PCM',0
Simple mixer control 'Mic',0
Simple mixer control 'Mic Boost',0
Simple mixer control 'Mic Mute-LED Mode',0
Simple mixer control 'IEC958',0
Simple mixer control 'IEC958',1
Simple mixer control 'IEC958',2
Simple mixer control 'Beep',0
Simple mixer control 'Capture',0
Simple mixer control 'Auto-Mute Mode',0
Simple mixer control 'Digital',0
Simple mixer control 'Dock Mic',0
Simple mixer control 'Dock Mic Boost',0
Simple mixer control 'Internal Mic Boost',0
Simple mixer control 'Loopback Mixing',0
Simple mixer control 'Mute-LED Mode',0


Devuan GNU/Linux 5 (daedalus) x86_64

Offline

#6 2023-01-30 19:14:45

aitor
Member
From: basque country
Registered: 2016-12-03
Posts: 211  
Website

Re: [SOLVED] Bluetooth headphone not showing in PulseAudio/pavucontrol

Deze wrote:

Simple mixer control 'Headphone',0
Simple mixer control 'Headphone',1

So, the controls are there. They should be shown by alsamixer then.


If you work systematically, things will come by itself (Lev D. Landau)

Offline

#7 2023-01-30 19:39:13

Deze
Member
Registered: 2021-10-17
Posts: 14  

Re: [SOLVED] Bluetooth headphone not showing in PulseAudio/pavucontrol

Thank you for helping a newb out.

Simple mixer control 'Headphone',1

The bt headphone is off and no wired headphone is connected to the 3.5 mm output. Same when bt headphone is on.

In Alsamixer - Card: PulseAudio
if necessary how can i set this to Alsa?


Devuan GNU/Linux 5 (daedalus) x86_64

Offline

#8 2023-01-30 19:49:10

aitor
Member
From: basque country
Registered: 2016-12-03
Posts: 211  
Website

Re: [SOLVED] Bluetooth headphone not showing in PulseAudio/pavucontrol

Maybe you'll need to install bluez-alsa, but i'm not familiar with it.


If you work systematically, things will come by itself (Lev D. Landau)

Offline

#9 2023-02-01 14:00:11

Deze
Member
Registered: 2021-10-17
Posts: 14  

Re: [SOLVED] Bluetooth headphone not showing in PulseAudio/pavucontrol

Package bluez-alsa is not available.

The headphone is bluetooth 5 and the pc is bt 4.0, apparently these standards don't connect well. I will try with a bt 5 dongle and post the result.


Devuan GNU/Linux 5 (daedalus) x86_64

Offline

#10 2023-02-01 22:16:57

dzz
Member
From: Exmouth, South West England
Registered: 2016-12-01
Posts: 47  

Re: [SOLVED] Bluetooth headphone not showing in PulseAudio/pavucontrol

You don't need pulseaudio and should uninstall if you try this.

Re bluez-alsa: it's only in unstable and not so new. And no syvinit script.
https://dev1galaxy.org/viewtopic.php?id=4612

I made updated packages for chimaera with sysvinit script and posted here (please install libasound2-plugin-bluez first):
https://exegnulinux.net/apt/pool/main/b … _amd64.deb
https://exegnulinux.net/apt/pool/main/b … _amd64.deb

A better way might be with pipewire:
https://dev1galaxy.org/viewtopic.php?id=5385

BT sound working here both ways.

Offline

#11 2023-02-03 23:26:50

Deze
Member
Registered: 2021-10-17
Posts: 14  

Re: [SOLVED] Bluetooth headphone not showing in PulseAudio/pavucontrol

Thank you dzz

sudo apt-get autoremove pulseaudio

Reboot

sudo dpkg -i libasound2-plugin-bluez_3.1.0~git20211121-1+exegnu1_amd64.deb 
sudo apt install orphan-sysvinit-scripts
sudo dpkg -i bluez-alsa-utils_3.1.0~git20211121-1+exegnu1_amd64.deb 
(Reading database ... 203559 files and directories currently installed.)
Preparing to unpack bluez-alsa-utils_3.1.0~git20211121-1+exegnu1_amd64.deb ...
Unpacking bluez-alsa-utils (3.1.0~git20211121-1+exegnu1) over (3.1.0~git20211121-1+exegnu1) ...
dpkg: dependency problems prevent configuration of bluez-alsa-utils:
 bluez-alsa-utils depends on libldacbt-abr2 (>= 2.0.2); however:
  Package libldacbt-abr2 is not installed.
 bluez-alsa-utils depends on libldacbt-enc2 (>= 2.0.2); however:
  Package libldacbt-enc2 is not installed.

dpkg: error processing package bluez-alsa-utils (--install):
 dependency problems - leaving unconfigured
Processing triggers for dbus (1.12.24-0+deb11u1devuan1) ...
Processing triggers for man-db (2.9.4-2) ...
Errors were encountered while processing:
 bluez-alsa-utils
sudo apt --fix-broken install

reboot

BT headphone briefly connects in blueman-manager and doesn't show in alsamixer.

Last edited by Deze (2023-02-04 00:07:05)


Devuan GNU/Linux 5 (daedalus) x86_64

Offline

#12 2023-02-03 23:53:19

aitor
Member
From: basque country
Registered: 2016-12-03
Posts: 211  
Website

Re: [SOLVED] Bluetooth headphone not showing in PulseAudio/pavucontrol

Deze wrote:

Thank you dzz

sudo apt purge *pulseaudio*

will remove bt-reload-headphones* gstreamer1.0-pulseaudio* paprefs* pulseaudio* pulseaudio-equalizer* pulseaudio-module-bluetooth* pulseaudio-module-gsettings*
  pulseaudio-module-zeroconf* pulseaudio-utils* pulseeffects* quodlibet* task-xfce-desktop* xfce4* xfce4-pulseaudio-plugin*

I want to keep xfce4 and quodlibet. Is there a more surgical command?

Try with dpkg, instead of apt (sorry, but I'm not in xfce right now):

# dpkg --purge pulseaudio

I think that the package depending on pulseaudio is the one provided by tasksel, i.e. task-xfce-desktop, but not the whole xfce desktop environment, which can be installed without the tasksel package. Good luck.


If you work systematically, things will come by itself (Lev D. Landau)

Offline

#13 2023-02-04 00:14:35

Deze
Member
Registered: 2021-10-17
Posts: 14  

Re: [SOLVED] Bluetooth headphone not showing in PulseAudio/pavucontrol

sudo apt purge *pulseaudio*

will remove bt-reload-headphones* gstreamer1.0-pulseaudio* paprefs* pulseaudio* pulseaudio-equalizer* pulseaudio-module-bluetooth* pulseaudio-module-gsettings*
  pulseaudio-module-zeroconf* pulseaudio-utils* pulseeffects* quodlibet* task-xfce-desktop* xfce4* xfce4-pulseaudio-plugin*

I want to keep xfce4 and quodlibet. Is there a more surgical command?

Try with dpkg, instead of apt (sorry, but I'm not in xfce right now):

# dpkg --purge pulseaudio

I think that the package depending on pulseaudio is the one provided by tasksel, i.e. task-xfce-desktop, but not the whole xfce desktop environment, which can be installed without the tasksel package. Good luck.

I used

sudo apt-get autoremove pulseaudio

Then succesfully installed bluez-alsa-utils newest version (3.1.0~git20211121-1+exegnu1). alsamixer doesn't see the bt headphone. Can blueman-applet be used next to alsamixer?


Devuan GNU/Linux 5 (daedalus) x86_64

Offline

#14 2023-02-04 15:10:32

dzz
Member
From: Exmouth, South West England
Registered: 2016-12-01
Posts: 47  

Re: [SOLVED] Bluetooth headphone not showing in PulseAudio/pavucontrol

You may also need to create ~/.asoundrc wih something like this (change "Port" and device "mac address" to suit.:

pcm.Port { 

	type bluealsa
	device "77:20:1E:FE:4E:E4"
	profile "a2dp"
	hint  { show on description "Port" }
}

I used bluez-alsa for a while with reasonable success but now finding pipewire more reliable. You can have both installed but if you try pipewire  bluealsa service should stopped and disabled in sysv-rc-conf..

blueman-applet seems the easiest way to search available devices, get info, set up.  Or bluetoothctl in a terminal.  Setup sequence is trust>pair>connect .. good luck..

Offline

#15 2023-02-12 14:49:10

Deze
Member
Registered: 2021-10-17
Posts: 14  

Re: [SOLVED] Bluetooth headphone not showing in PulseAudio/pavucontrol

dzz wrote:

You may also need to create ~/.asoundrc wih something like this (change "Port" and device "mac address" to suit.:

pcm.Port { 

	type bluealsa
	device "77:20:1E:FE:4E:E4"
	profile "a2dp"
	hint  { show on description "Port" }
}

I used bluez-alsa for a while with reasonable success but now finding pipewire more reliable. You can have both installed but if you try pipewire  bluealsa service should stopped and disabled in sysv-rc-conf..

blueman-applet seems the easiest way to search available devices, get info, set up.  Or bluetoothctl in a terminal.  Setup sequence is trust>pair>connect .. good luck..

I put the headphone's MAC and name in  ~/.asoundrc , no succes pairing.

Then pipewire
-In sysv-rc-conf unticked all boxes under bluez-alsa and pulseaudio.
-reboot
-In blueman-applet Set up new device, select headphone, Pair device, Failed to add device.
In blueman-applet in the Devices menu the headphone will now also not connect.

Edit: Oops skipped the first step, which is disconnect headphone from other devices. And.. headphone pairs with chimaera.

$ bluealsa-aplay -L
bluealsa:SRV=org.bluealsa,DEV=**:**:**:**:**:**,PROFILE=a2dp
    Yamaha YH-E700A, trusted , playback
    A2DP (SBC): S16_LE 2 channels 48000 Hz
bluealsa:SRV=org.bluealsa,DEV=**:**:**:**:**:**,PROFILE=sco
    Yamaha YH-E700A, trusted , capture
    SCO (CVSD): S16_LE 1 channel 8000 Hz
bluealsa:SRV=org.bluealsa,DEV=**:**:**:**:**:**,PROFILE=sco
    Yamaha YH-E700A, trusted , playback
    SCO (CVSD): S16_LE 1 channel 8000 Hz

Next challenge adding and selecting it in alsamixer.

Edit 2: Ok, working now. The problem was with the headphone and android. Removed saved headphone from android settings, installed Pulseaudio, connecting and audio playback successful. After connecting to the phone I do have to remove/add the headphone from blueman-applet to connect.

Thank you for the feedback.

Last edited by Deze (2023-02-14 14:34:40)


Devuan GNU/Linux 5 (daedalus) x86_64

Offline

Board footer