The officially official Devuan Forum!

You are not logged in.

#1 2022-09-09 07:20:21

amaro
Member
Registered: 2022-02-08
Posts: 61  

rainlendar2-lite dependencies problems

Hello everybody!

trying to install 'rainlendar2-lite' but facing dependencies problems

ver 2.9

dpkg -i /media/vb/Linux/deb386/rainlendar2-lite_2.9.b111-1_i386.deb
Selecting previously unselected package rainlendar2-lite.
(Reading database ... 135884 files and directories currently installed.)
Preparing to unpack .../rainlendar2-lite_2.9.b111-1_i386.deb ...
Unpacking rainlendar2-lite (2.9.b111-1) ...
dpkg: dependency problems prevent configuration of rainlendar2-lite:
 rainlendar2-lite depends on libcurl3 (>= 7.16.0); however:
  Package libcurl3 is not installed.
 rainlendar2-lite depends on libpango1.0-0 (>= 1.16.2); however:
  Package libpango1.0-0 is not installed.
 rainlendar2-lite depends on libpng12-0; however:
  Package libpng12-0 is not installed.
 rainlendar2-lite depends on tofrodos; however:
  Package tofrodos is not installed.

dpkg: error processing package rainlendar2-lite (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.26-1) ...
Processing triggers for mailcap (3.69) ...
Errors were encountered while processing:
 rainlendar2-lite

ver 2.10

dpkg -i /media/vb/Linux/deb386/rainlendar2-lite_2.10.b120-1_i386.deb
Selecting previously unselected package rainlendar2-lite.
(Reading database ... 135884 files and directories currently installed.)
Preparing to unpack .../rainlendar2-lite_2.10.b120-1_i386.deb ...
Unpacking rainlendar2-lite (2.10.b120-1) ...
dpkg: dependency problems prevent configuration of rainlendar2-lite:
 rainlendar2-lite depends on libcurl3 (>= 7.16.0); however:
  Package libcurl3 is not installed.
 rainlendar2-lite depends on libpango1.0-0 (>= 1.16.2); however:
  Package libpango1.0-0 is not installed.
 rainlendar2-lite depends on libpng12-0; however:
  Package libpng12-0 is not installed.
 rainlendar2-lite depends on tofrodos; however:
  Package tofrodos is not installed.
 rainlendar2-lite depends on libsdl1.2debian; however:
  Package libsdl1.2debian is not installed.
 rainlendar2-lite depends on libssl1.0.0; however:
  Package libssl1.0.0 is not installed.

dpkg: error processing package rainlendar2-lite (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.26-1) ...
Processing triggers for mailcap (3.69) ...
Errors were encountered while processing:
 rainlendar2-lite

ver 2.11

dpkg -i /home/vb/rainlendar2-lite_2.11.1.b129-1_i386.deb
(Reading database ... 135963 files and directories currently installed.)
Preparing to unpack .../rainlendar2-lite_2.11.1.b129-1_i386.deb ...
Unpacking rainlendar2-lite (2.11.1.b129-1) over (2.9.b111-1) ...
dpkg: dependency problems prevent configuration of rainlendar2-lite:
 rainlendar2-lite depends on libcurl3 (>= 7.16.0); however:
  Package libcurl3 is not installed.
 rainlendar2-lite depends on libpango1.0-0 (>= 1.16.2); however:
  Package libpango1.0-0 is not installed.
 rainlendar2-lite depends on libpng12-0; however:
  Package libpng12-0 is not installed.
 rainlendar2-lite depends on tofrodos; however:
  Package tofrodos is not installed.
 rainlendar2-lite depends on libsdl1.2debian; however:
  Package libsdl1.2debian is not installed.
 rainlendar2-lite depends on libssl1.0.0; however:
  Package libssl1.0.0 is not installed.

dpkg: error processing package rainlendar2-lite (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.26-1) ...
Processing triggers for mailcap (3.69) ...
Errors were encountered while processing:
 rainlendar2-lite

which version is less likely to cause dependencies problems in the long run?
is there a way to avoid getting its dependencies manually?

Offline

#2 2022-09-09 08:13:33

brocashelm
Member
Registered: 2020-06-29
Posts: 96  

Re: rainlendar2-lite dependencies problems

First, which Devuan version are you using? If it's Chimaera (stable), then I'd avoid mixing and matching different repositories for the best chances at stability. Some of those packages (libssl1.0.0 in particular) are either no longer installable (deprecated) or not available in your main repository. If you were using Daedalus (testing) or Ceres (unstable), you might be able to get away with installing specific DEBs from other branches.

Have you tried to install from the official DEB file (2.18)? Using Ceres (unstable), GDebi tells me that "all dependencies are satisfiable".


"Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety." - Benjamin Franklin

"In a time of universal deceit, telling the truth is a revolutionary act." - George Orwell

Offline

#3 2022-09-09 09:16:47

amaro
Member
Registered: 2022-02-08
Posts: 61  

Re: rainlendar2-lite dependencies problems

cat /etc/apt/sources.list
# Package repositories
deb http://devuan.ipacct.com/devuan/merged/ daedalus contrib main   
# deb http://devuan.ipacct.com/devuan/merged/ daedalus-updates contrib main  
# deb http://devuan.ipacct.com/devuan/merged/ daedalus-security main  
# deb http://devuan.ipacct.com/devuan/merged/ daedalus-backports main 

# Source repositories
# deb-src http://deb.devuan.org/merged/ chimaera main 
# deb-src http://deb.devuan.org/merged/ chimaera-updates main 
# deb-src http://deb.devuan.org/merged/ chimaera-security main 
# deb-src http://deb.devuan.org/merged/ chimaera-backports main 

looks like your link points to an amd64 file and I too couldn't find a newer version (>2.11) for i386 available

Offline

Board footer