The officially official Devuan Forum!

You are not logged in.

#1 2022-03-22 21:17:38

Altoid
Member
Registered: 2017-05-07
Posts: 1,045  

[SOLVED] More Nvidia 340xx woes ....

Hello:

After my success with updating the backported kernel in my main Beowulf box, I decided to do the same with my parallel Beowulf installation.
It lives on a separate drive in the same box, albeit with a spartan Openbox desktop which is operational but unfinished.

As I was going through the update, I noticed that it was going to Linux devuan 5.10.0-0.bpo.12-amd64 which when I did the same in my main box had not yet been signed.

On reboot, just like with my main box, I was not able to get X started so followed the steps I took here to get things fixed:

https://dev1galaxy.org/viewtopic.php?id=4948

Basically install what was missing via ...

# apt -t beowulf-backports install linux-image-amd64
and
# apt -t beowulf-backports install linux-headers-amd64

But no, no cigar.

There seems to be some sort of dependency problem somewhere.
Here is what I could fish out of /var/log/apt/term.log:

Log started: 2022-03-22  17:32:49
Setting up nvidia-legacy-340xx-kernel-dkms (340.108-3~deb10u1) ...
Removing old nvidia-legacy-340xx-340.108 DKMS files...

------------------------------
Deleting module version: 340.108
completely from the DKMS tree.
------------------------------
Done.
Loading new nvidia-legacy-340xx-340.108 DKMS files...
Building for 5.10.0-0.bpo.12-amd64
Building initial module for 5.10.0-0.bpo.12-amd64

Error! Bad return status for module build on kernel: 5.10.0-0.bpo.12-amd64 (x86_64)      <---------------------------------------                    

Consult /var/lib/dkms/nvidia-legacy-340xx/340.108/build/make.log for more information.
error processing package nvidia-legacy-340xx-kernel-dkms (--configure):
installed nvidia-legacy-340xx-kernel-dkms package post-installation script subprocess returned error exit status 10
dependency problems prevent configuration of nvidia-legacy-340xx-driver:

nvidia-legacy-340xx-driver depends on nvidia-legacy-340xx-kernel-dkms (= 340.108-3~deb10u1) | nvidia-legacy-340xx-kernel-340.108; however:
  Package nvidia-legacy-340xx-kernel-dkms is not configured yet.
  Package nvidia-legacy-340xx-kernel-340.108 is not installed.
  Package nvidia-legacy-340xx-kernel-dkms which provides nvidia-legacy-340xx-kernel-340.108 is not configured yet.

error processing package nvidia-legacy-340xx-driver (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 nvidia-legacy-340xx-kernel-dkms
 nvidia-legacy-340xx-driver
Log ended: 2022-03-22  17:33:20

I did not encounter any problems when I later updated my main box from Linux devuan 5.10.0-0.bpo.11-amd64 to the now signed Linux devuan 5.10.0-0.bpo.12-amd64.

I then went looking to see what may be amiss:

uname -a gave the same printout and cat /etc/apt/sources.list shows the same in both installations:

~$ cat /etc/apt/sources.list
## package repositories

# Changed - 20210218 - upgrade to Beowulf

# beowulf stable
deb http://deb.devuan.org/merged/ beowulf main contrib non-free 
deb http://deb.devuan.org/merged/ beowulf-security main contrib non-free 
deb http://deb.devuan.org/merged/ beowulf-updates main contrib non-free 

# needed x virtualbox backport - enable to update package
deb http://deb.devuan.org/merged/ beowulf-backports main contrib non-free 

# virtual box repository x installation
deb https://download.virtualbox.org/virtualbox/debian/ buster contrib non-free 
~$ 

Then I looked for anomalies in the installed 340xx packages and found that the lists were not the same:

My main box has 17 packages:

libegl1-nvidia-legacy-340xx/oldstable,now 340.108-3~deb10u1 amd64 [installed,automatic]
libgl1-nvidia-legacy-340xx-glx/oldstable,now 340.108-3~deb10u1 amd64 [installed,automatic]
	
        libgles1-nvidia-legacy-340xx/oldstable,now 340.108-3~deb10u1 amd64 [installed,automatic]    <---- missing
	libgles2-nvidia-legacy-340xx/oldstable,now 340.108-3~deb10u1 amd64 [installed,automatic]    <---- missing
	libnvidia-legacy-340xx-cfg1/oldstable,now 340.108-3~deb10u1 amd64 [installed,automatic]     <---- missing

libnvidia-legacy-340xx-eglcore/oldstable,now 340.108-3~deb10u1 amd64 [installed,automatic]
libnvidia-legacy-340xx-glcore/oldstable,now 340.108-3~deb10u1 amd64 [installed,automatic]
libnvidia-legacy-340xx-ml1/oldstable,now 340.108-3~deb10u1 amd64 [installed,automatic]
nvidia-legacy-340xx-alternative/oldstable,now 340.108-3~deb10u1 amd64 [installed,automatic]
nvidia-legacy-340xx-driver-bin/oldstable,now 340.108-3~deb10u1 amd64 [installed,automatic]
nvidia-legacy-340xx-driver-libs/oldstable,now 340.108-3~deb10u1 amd64 [installed,automatic]
nvidia-legacy-340xx-driver/oldstable,now 340.108-3~deb10u1 amd64 [installed]

	nvidia-legacy-340xx-kernel-dkms/oldstable-backports,now 340.108-10~bpo10+1 amd64 [installed]    <---- bad version

nvidia-legacy-340xx-kernel-support/oldstable,now 340.108-3~deb10u1 amd64 [installed,automatic]
nvidia-legacy-340xx-vdpau-driver/oldstable,now 340.108-3~deb10u1 amd64 [installed,automatic]

	nvidia-settings-legacy-340xx/oldstable,now 340.108-1~deb10u1 amd64 [installed,automatic]    <---- missing

xserver-xorg-video-nvidia-legacy-340xx/oldstable,now 340.108-3~deb10u1 amd64 [installed,automatic]

But the parallel installation has only 13 packages and the wrong version for the package that is not able to complete its job: nvidia-legacy-340xx-kernel-dkms/oldstable-backports.

ie:
The working installation has nvidia-legacy-340xx-kernel-dkms /oldstable-backports,now 340.108-10~bpo10+1 amd64
The non-working installation has nvidia-legacy-340xx-kernel-dkms /oldstable-backports,now 340.108-3 ~deb10u1 amd64

340.108-10~bpo10+1 is the backported driver
340.108-3 ~deb10u1 does not seem to be.

Any idea as to why this is so?
Can't figure out what is wrong or how it got like this.

I tried manually installing the missing packaged but it seems the problems is with the wrong version of the dkms package.

Thanks in advance.

Best,

A.

Last edited by Altoid (2022-03-22 21:21:20)

Offline

#2 2022-03-22 23:05:56

Altoid
Member
Registered: 2017-05-07
Posts: 1,045  

Re: [SOLVED] More Nvidia 340xx woes ....

Hello:

myself wrote:

... seems the problem is with the wrong version of the dkms package.

I was able to fix it all by doing a manual installation:

apt -t beowulf-backports install nvidia-legacy-340xx-driver --no-install-recommends

Now ...

~$ apt list | grep installed | grep legacy-340xx
--- snip ---
libegl1-nvidia-legacy-340xx/oldstable-backports,now 340.108-10~bpo10+1 amd64 [installed,automatic]
libgl1-nvidia-legacy-340xx-glx/oldstable-backports,now 340.108-10~bpo10+1 amd64 [installed,automatic]
libgles1-nvidia-legacy-340xx/oldstable-backports,now 340.108-10~bpo10+1 amd64 [installed]
libgles2-nvidia-legacy-340xx/oldstable-backports,now 340.108-10~bpo10+1 amd64 [installed]
libnvidia-legacy-340xx-cfg1/oldstable-backports,now 340.108-10~bpo10+1 amd64 [installed]
libnvidia-legacy-340xx-eglcore/oldstable-backports,now 340.108-10~bpo10+1 amd64 [installed,automatic]
libnvidia-legacy-340xx-glcore/oldstable-backports,now 340.108-10~bpo10+1 amd64 [installed,automatic]
libnvidia-legacy-340xx-ml1/oldstable-backports,now 340.108-10~bpo10+1 amd64 [installed,automatic]
nvidia-legacy-340xx-alternative/oldstable-backports,now 340.108-10~bpo10+1 amd64 [installed,automatic]
nvidia-legacy-340xx-driver-bin/oldstable-backports,now 340.108-10~bpo10+1 amd64 [installed,automatic]
nvidia-legacy-340xx-driver-libs/oldstable-backports,now 340.108-10~bpo10+1 amd64 [installed,automatic]
nvidia-legacy-340xx-driver/oldstable-backports,now 340.108-10~bpo10+1 amd64 [installed]
nvidia-legacy-340xx-kernel-dkms/oldstable-backports,now 340.108-10~bpo10+1 amd64 [installed,automatic]
nvidia-legacy-340xx-kernel-support/oldstable-backports,now 340.108-10~bpo10+1 amd64 [installed,automatic]
nvidia-legacy-340xx-vdpau-driver/oldstable-backports,now 340.108-10~bpo10+1 amd64 [installed,automatic]
nvidia-settings-legacy-340xx/oldstable,now 340.108-1~deb10u1 amd64 [installed]
xserver-xorg-video-nvidia-legacy-340xx/oldstable-backports,now 340.108-10~bpo10+1 amd64 [installed,automatic]
~$ 

I think (?) what was happening is related to what rolfie points out here:

https://dev1galaxy.org/viewtopic.php?pid=35311#p35311

In any case, now it works.

Best,

A.

Offline

Board footer